Modify

Opened 3 years ago

Closed 3 years ago

#12971 closed defect (fixed)

Setting WMS Simultaneous connections to 1 makes JOSM unusable

Reported by: josm@… Owned by: wiktorn
Priority: minor Milestone: 16.06
Component: Core imagery Version: tested
Keywords: template_report max_threads preferences imagery JCSCachedTileLoaderJob Cc:

Description

What steps will reproduce the problem?

  1. Set preference WMS/TMS -> Settings -> WMS settings -> Simultaneous connections = "1" (cache.jcs.max_threads = 1)
  2. Restart
  3. Try to access Preferences (F12) or try to open download map data window.

What is the expected result?

Get access to preferences window, or download form OSM window.

What happens instead?

Exception or silent error eg. "Could not initialize class org.openstreetmap.josm.data.cache.JCSCachedTileLoaderJob" and nothing happens, or JOSM opens empty unusable download data from OSM window. I have also reproduced this error with default settings. It taked me a while to find which changed option caused this behaviour. Cannot access preferences window to change "Simultaneous connections" to something greater than 1. Beginner may not know what caused this, and may be forced to deleting his preferences. Finally, I have edited preferences.xml manually. Setting cache.jcs.max_threads to value greater than 1 resolved problem. I had temporarily very limited internet bandwidth 64 kbps/s after excessing provider quota, and I tried setting "Simultaneous connections" to "1" to not overload internet connection.

Thank you for your work on JOSM.

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-06-04 17:28:58 +0200 (Sat, 04 Jun 2016)
Build-Date:2016-06-04 15:31:27
Revision:10327
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10327 pl) Windows 8.1 64-Bit
Memory Usage: 485 MB / 910 MB (415 MB allocated, but free)
Java version: 1.8.0_91-b15, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM


Last errors/warnings:
- E: java.net.SocketTimeoutException: Read timed out
- E: java.lang.ExceptionInInitializerError. Przyczyna: java.lang.IllegalArgumentException

java.lang.ExceptionInInitializerError
	at org.openstreetmap.josm.gui.preferences.imagery.WMSSettingsPanel.<init>(WMSSettingsPanel.java:45)
	at org.openstreetmap.josm.gui.preferences.imagery.ImageryPreference.<init>(ImageryPreference.java:82)
	at org.openstreetmap.josm.gui.preferences.imagery.ImageryPreference.<init>(ImageryPreference.java:76)
	at org.openstreetmap.josm.gui.preferences.imagery.ImageryPreference$Factory.createPreferenceSetting(ImageryPreference.java:91)
	at org.openstreetmap.josm.gui.preferences.PreferenceTabbedPane.buildGui(PreferenceTabbedPane.java:473)
	at org.openstreetmap.josm.gui.preferences.PreferenceDialog.build(PreferenceDialog.java:81)
	at org.openstreetmap.josm.gui.preferences.PreferenceDialog.<init>(PreferenceDialog.java:48)
	at org.openstreetmap.josm.actions.PreferencesAction.run(PreferencesAction.java:106)
	at org.openstreetmap.josm.actions.PreferencesAction.actionPerformed(PreferencesAction.java:101)
	at javax.swing.SwingUtilities.notifyAction(Unknown Source)
	at javax.swing.JComponent.processKeyBinding(Unknown Source)
	at javax.swing.KeyboardManager.fireBinding(Unknown Source)
	at javax.swing.KeyboardManager.fireKeyboardAction(Unknown Source)
	at javax.swing.JComponent.processKeyBindingsForAllComponents(Unknown Source)
	at javax.swing.JComponent.processKeyBindings(Unknown Source)
	at javax.swing.JComponent.processKeyEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.KeyboardFocusManager.redispatchEvent(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.dispatchKeyEvent(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.preDispatchKeyEvent(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.typeAheadAssertions(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.dispatchEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)
Caused by: java.lang.IllegalArgumentException
	at java.util.concurrent.ThreadPoolExecutor.<init>(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor.<init>(Unknown Source)
	at org.openstreetmap.josm.data.cache.JCSCachedTileLoaderJob.<clinit>(JCSCachedTileLoaderJob.java:73)
	... 48 more

Attachments (0)

Change History (3)

comment:1 Changed 3 years ago by wiktorn

Owner: changed from team to wiktorn
Status: newassigned

comment:2 Changed 3 years ago by Don-vip

Milestone: 16.06

comment:3 Changed 3 years ago by wiktorn

Resolution: fixed
Status: assignedclosed

In 10408/josm:

Set core pool size to 1, so minimum number of thread can be 1.

Closes: #12971

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain wiktorn.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.