Modify

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#12973 closed defect (fixed)

Different rendering of intermittend=yes on area and relation

Reported by: mdk Owned by: team
Priority: normal Milestone: 16.06
Component: Internal mappaint style Version: latest
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Open attached intermittend.osm

What is the expected result?

Both waterway=riverbank areas (one is a normal way, the other a multipolygon) should be drawn with dashed lines (like the waterway=river).

What happens instead?

the multipolygon is drawn with a solid line:

Please provide any additional information below. Attach a screenshot if possible.

Shouldn't areas not always be rendered the same not mention if they are simple closed ways or multipolygons?

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-06-09 23:01:04 +0200 (Thu, 09 Jun 2016)
Build-Date:2016-06-10 01:32:20
Revision:10349
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10349 en) Linux Ubuntu 15.10
Memory Usage: 448 MB / 876 MB (227 MB allocated, but free)
Java version: 1.8.0_91-8u91-b14-0ubuntu4~15.10.1-b14, Oracle Corporation, OpenJDK Server VM
VM arguments: [-Djosm.restart=true, -Djosm.home=<josm.pref>, -Djava.net.useSystemProxies=true]
Dataset consistency test: No problems found

Plugins:
- ColumbusCSV (32158)
- FastDraw (32158)
- HouseNumberTaggingTool (31926)
- Mapillary (32158)
- OpeningHoursEditor (32158)
- RoadSigns (32177)
- SimplifyArea (32158)
- apache-commons (32158)
- apache-http (32158)
- buildings_tools (32158)
- contourmerge (1014)
- imagery-xml-bounds (32158)
- imagery_offset_db (32158)
- pbf (32158)
- poly (32158)
- public_transport (32158)
- reltoolbox (32158)
- reverter (32158)
- terracer (32158)
- turnlanes (32158)
- turnrestrictions (32158)
- utilsplugin2 (32158)

Tagging presets:
- https://josm.openstreetmap.de/josmfile?page=Presets/LaneAttributes&preset&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/OneClick&zip=1

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Traffic_signs&zip=1

Last errors/warnings:
- E: Skipping to the next rule, because of an error:
- E: org.openstreetmap.josm.gui.mappaint.mapcss.parsergen.ParseException: Encountered " <IDENT> "preset "" at line 1, column 19.
- W: Failed to parse Mappaint styles from 'https://josm.openstreetmap.de/josmfile?page=Styles/Traffic_signs&zip=1'. Error was: Reached end of file while parsing
- E: org.openstreetmap.josm.gui.mappaint.mapcss.parsergen.ParseException: Reached end of file while parsing
- W: Initializing map style https://josm.openstreetmap.de/josmfile?page=Styles/Traffic_signs&zip=1 completed in 19 ms (2 errors, 0 warnings)

Attachments (2)

intermittend.osm (8.7 KB) - added by mdk 3 years ago.
intermittend.png (56.7 KB) - added by mdk 3 years ago.

Download all attachments as: .zip

Change History (5)

Changed 3 years ago by mdk

Attachment: intermittend.osm added

Changed 3 years ago by mdk

Attachment: intermittend.png added

comment:1 Changed 3 years ago by Don-vip

Component: Core mappaintInternal mappaint style

comment:2 Changed 3 years ago by Klumbumbus

Resolution: fixed
Status: newclosed

In 10419/josm:

fix #12973 - fix intermittent-dashes for natural=water and waterway=riverbank multipolygons; see #9182 - adjust negative layer warning messages; remove unnecessary spaces

comment:3 Changed 3 years ago by Klumbumbus

Milestone: 16.06

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.