Modify

Opened 6 years ago

Closed 14 months ago

Last modified 14 months ago

#12326 closed enhancement (fixed)

"Empty" and "Modified" indicators in the data layers

Reported by: naoliv Owned by: simon04
Priority: normal Milestone: 21.03
Component: Core Version:
Keywords: Cc:

Description

Sometimes I work with a lot of layers, for example:

http://i.imgur.com/xMdqpPT.png

But I miss some kind of visual indicator for two cases:

  • when the layer is empty (ie, 0 objects inside it)
  • when the layer is modified (I have removed, added or modified any object inside it)

Could we have some kind of visual mark for this, please?

JOSM:

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-01-08 10:43:21 +0100 (Fri, 08 Jan 2016)
Build-Date:2016-01-09 02:34:54
Revision:9345
Relative:URL: ^/trunk

Identification: JOSM/1.5 (9345 pt_BR) Linux Debian GNU/Linux unstable (sid)
Memory Usage: 1247 MB / 3641 MB (415 MB allocated, but free)
Java version: 1.8.0_72-internal-b05, Oracle Corporation, OpenJDK 64-Bit Server VM
VM arguments: [-Dawt.useSystemAAFontSettings=on]

Dataset consistency test:
[WARN - NO NODES] Way {Way id=387220682 version=1 VT nodes=[{Node id=3905388832 version=1 V lat=-23.5578016,lon=-46.4762442}]} has only one node


Plugins:
- AddrInterpolation (31772)
- Create_grid_of_ways (31772)
- FastDraw (31895)
- FixAddresses (31772)
- OpeningHoursEditor (31772)
- PicLayer (31895)
- SimplifyArea (31895)
- apache-commons (31895)
- buildings_tools (31895)
- download_along (31772)
- editgpx (31772)
- ejml (31895)
- geotools (31895)
- graphview (31895)
- jts (31772)
- log4j (31895)
- measurement (31895)
- merge-overlap (31772)
- opendata (31937)
- pdfimport (31895)
- photo_geotagging (31895)
- poly (31772)
- reverter (31926)
- tagging-preset-tester (31895)
- todo (29154)
- turnrestrictions (31895)
- undelete (31895)
- utilsplugin2 (31895)

Attachments (0)

Change History (3)

comment:1 Changed 14 months ago by simon04

Milestone: 21.03
Owner: changed from team to simon04
Status: newassigned

Related: r7484 and application title "* Java OpenStreetMap Editor"

comment:2 Changed 14 months ago by simon04

Resolution: fixed
Status: assignedclosed

In 17626/josm:

fix #12326 - Layer list: "dirty" and "modified" indicators for data layers

comment:3 Changed 14 months ago by simon04

Ticket #19201 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain simon04.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.