Modify

Opened 5 years ago

Closed 4 years ago

#12295 closed enhancement (fixed)

Prevent users to create defect tickets without status report

Reported by: Don-vip Owned by: stoecker
Priority: normal Milestone:
Component: Trac Version:
Keywords: Cc: stoecker, simon04, bastiK, Klumbumbus

Description

I'm tired of people who ignore the flashy, yellow, translated, instructions on newticket.

Is there a way with Trac to detect missing status reports to force users to use the "Help => Report bug" feature?

Attachments (0)

Change History (9)

comment:1 Changed 5 years ago by Klumbumbus

Cc: Klumbumbus added

comment:2 Changed 5 years ago by stoecker

That's something we need to endure. There are two choices

  • allow nearly everybody to submit bug-reports (results in incomplete reports)
  • restrict the entrance level a lot (results in people simply not reporting)

For JOSM the choice was number 1. That has drawbacks for sure, but the opposite is worse. I e.g. don't report many bugs in other bugtrackers, as usually you need to get and verify an account click there, do that, fill that check that.... When I finally reach the target I lost all interest to report a bug.

For JOSM server the design choice was to have an entrance level as small as possible.

comment:3 Changed 5 years ago by simon04

Can we pre-fill the following content in newticket?

==== What steps will reproduce the problem?
1. 
2. 
3. 

==== What is the expected result?

==== What happens instead?

==== Please provide any additional information below. Attach a screenshot if possible.

comment:4 Changed 5 years ago by simon04

Or what about changing the link in the Trac menu to https://josm.openstreetmap.de/josmticket?gdata=Cg== – this fills in the template from comment:3 automatically? :)

comment:5 Changed 5 years ago by floscher

Anyway, only allowing to file bug reports with the "report bug" button is a bad idea. A moment ago, I wanted to file a bug report that way, but my JOSM (r9329) freezes when I click "report bug" in the menu bar (I'll soon file a separate bug report for this issue and the one I originally wanted to report).

But prefilling any new tickets created with the "new ticket" button on the website is indeed a very good idea.

comment:6 Changed 5 years ago by stoecker

I found no useful way to change the link or prefill the ticket. I think we will survive the troublesome reports. Maybe We should add a [[BadReport]] macro, so we don't need to retype the same text always? :-)

comment:7 in reply to:  6 Changed 5 years ago by Don-vip

Replying to stoecker:

Maybe We should add a [[BadReport]] macro, so we don't need to retype the same text always? :-)

That's a good idea! :)

comment:8 Changed 5 years ago by stoecker

Ok. Here it is (change text at BadReport page).

---

Thanks for your report, however your ticket is incomplete and therefore not helpful in its current form.

Please add all needed information according to this list:

  • The required parts of the Status Report from your JOSM.
  • Describe what behaviour you expected.
  • Describe what did happen instead.
  • Describe if and how the issue is reproducible.
  • Add any relevant information like error messages or screenshots.

To ensure that all technical relevant information is contained, create new tickets by clicking in JOSMs Main Menu on Helpsource:trunk/resources/images/bug.svg Report Bug.


---

comment:9 Changed 4 years ago by stoecker

Resolution: fixed
Status: newclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain stoecker.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.