Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#12183 closed defect (fixed)

Registered toolbar action bug when deleting a layer

Reported by: rickmastfan67 Owned by: team
Priority: minor Milestone: 15.12
Component: Core Version: latest
Keywords: Cc:

Description

Steps to reproduce:

  1. Start JOSM and create a new layer (Ctrl+N).
  2. Delete the layer by hitting the garbage can icon in the 'Layers' window.

What happens:
This message shows up in the CL:
INFO: Registered toolbar action save_as-session overwritten: org.openstreetmap.josm.actions.SessionSaveAsAction gets org.openstreetmap.josm.gui.io.SaveLayersDialog$SaveSessionAction

What should happen:
The above message shouldn't show up.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2015-12-10 19:27:17 +0100 (Thu, 10 Dec 2015)
Build-Date:2015-12-11 02:32:44
Revision:9098
Relative:URL: ^/trunk

Identification: JOSM/1.5 (9098 en) Windows 7 64-Bit
Memory Usage: 371 MB / 1820 MB (157 MB allocated, but free)
Java version: 1.7.0_79, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Dataset consistency test: No problems found

Plugins:
- OpeningHoursEditor (31772)
- buildings_tools (31772)
- measurement (31772)
- osmarender (31772)
- reverter (31772)
- turnrestrictions (31772)
- undelete (31772)
- utilsplugin2 (31772)

Attachments (0)

Change History (7)

comment:1 Changed 4 years ago by rickmastfan67

Summary: Registered toolbar action bug when delting a layerRegistered toolbar action bug when deleting a layer

comment:2 Changed 4 years ago by simon04

Resolution: fixed
Status: newclosed

In 9152/josm:

fix #12183 - "Registered toolbar action save_as-session overwritten"

comment:3 Changed 4 years ago by simon04

Milestone: 16.01

comment:4 Changed 4 years ago by rickmastfan67

Shouldn't the milestone be 15.12 instead since the 'tested' version is r9229 for that milestone? I would change it, but I don't have 15.12 listed for me.

comment:5 Changed 4 years ago by simon04

The milestone indicates which version will include the fix.

comment:6 Changed 4 years ago by rickmastfan67

I know that. The fix, as you mentioned above, was in [9152]. That's before the last 'tested' of r9229, which was milestone 15.12. So, shouldn't it be listed as 15.12 for this fix instead of 16.01?

comment:7 Changed 4 years ago by simon04

Milestone: 16.0115.12

Sorry. You are completely right – svn propediting leads to big confusions ;)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.