Modify

Opened 6 years ago

Closed 6 years ago

#12159 closed defect (worksforme)

Can not add existing way in a relation twice

Reported by: pl71 Owned by: team
Priority: normal Milestone:
Component: Core Version: tested
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

We have one way tagged as highway=secondary and I want to mark 'no-U-turn' at specific node on this way.

  1. New turn restriction (no-u-turn)
  2. Adding 'from' and 'via' members (part of the way and node)
  3. Trying to add 'to' member, which in this case is same as 'from' member

What is the expected result?

'To' way to be added to relation

What happens instead?

Nothing happens

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2015-11-24 00:04:12 +0100 (Tue, 24 Nov 2015)
Build-Date:2015-11-23 23:14:21
Revision:9060
Relative:URL: ^/trunk

Identification: JOSM/1.5 (9060 bg) Windows 10 64-Bit
Memory Usage: 233 MB / 455 MB (146 MB allocated, but free)
Java version: 1.8.0_65, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Dataset consistency test: No problems found

Plugins:
- colorscheme (31772)
- gpsblam (31772)
- measurement (31772)
- reverter (31772)
- undelete (31772)
- utilsplugin2 (31772)

Last errors/warnings:
- W: PluginException: Invalid jar file 'C:\Users\Plamen\AppData\Roaming\JOSM\plugins\ElevationProfile.jar.new'
- W: Failed to scan file 'ElevationProfile.jar.new' for plugin information. Skipping.
- W: Failed to install plugin 'C:\Users\Plamen\AppData\Roaming\JOSM\plugins\ElevationProfile.jar' from temporary download file 'C:\Users\Plamen\AppData\Roaming\JOSM\plugins\ElevationProfile.jar.new'. error in opening zip file

Attachments (0)

Change History (6)

comment:1 Changed 6 years ago by pl71

Summary: Can not add existing in relation way twiceCan not add existing way in a relation twice

comment:2 Changed 6 years ago by Klumbumbus

It works for me. It asks If I really want to do this. Maybe you once answered this question with "no" and saved this answer. I'm not sure where you can reset these saved answeres.

comment:3 Changed 6 years ago by pl71

Found how to reset this one:
Edit - Preferences - Advanced Preferences (expert mode)
Search for: "relation"
Edit following row: "message.add_primitive_to_relation_value" from 'false' to 'true'.
But there is no remainder/warning how to reset once set default action.

comment:4 Changed 6 years ago by Klumbumbus

Yes, it would be nice if there is a GUI with a list of all the saved answers. There is the same problem also for ignored validator warnings.

comment:5 Changed 6 years ago by anonymous

Yes relation dialog box should have warning or reset button.

comment:6 Changed 6 years ago by simon04

Resolution: worksforme
Status: newclosed

For the UI enhancement, see #12290.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.