Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#12160 closed defect (fixed)

Combobox List Entries with Empty Value – display_value and short_description not shown

Reported by: Nakaner Owned by: team
Priority: normal Milestone: 16.02
Component: Core Version: tested
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Load the attached preset (a minimum working example).
  2. Draw a line, select it.
  3. Open the preset.

What is the expected result, what happens instead?

The preset contains three comboboxes. Each combobox has three entries. One which is displayed correctly. The second has an space as value, it is also displayed correctly. The third entry has an empty value. Its display_value and short_description is not shown.

The problem occurs if you want to remove a tag but want to give the user the choice if he wants to do so. To remove a tag, you add an empty value. My current workaround is to use a space as a value and JOSM will (as expected) remove the tag because JOSM strips the value string and an empty string remains.

Also comboboxes with editable='true' are affected.

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2015-11-24 00:04:12 +0100 (Tue, 24 Nov 2015)
Build-Date:2015-11-23 23:14:21
Revision:9060
Relative:URL: ^/trunk

Identification: JOSM/1.5 (9060 de) Linux Arch Linux
Memory Usage: 507 MB / 1746 MB (187 MB allocated, but free)
Java version: 1.8.0_66, Oracle Corporation, OpenJDK 64-Bit Server VM
VM arguments: [-Djosm.restart=true]

Plugins:
- Mapillary (31799)
- apache-commons (31772)
- apache-http (31772)
- buildings_tools (31772)
- ejml (31772)
- geotools (31774)
- jts (31772)
- reverter (31772)
- utilsplugin2 (31772)

Last errors/warnings:
- E: Defekte Objektvorlage "railway:signal:departure:states-Anzeigbare Signalbilder" - Anzahl der Datenworte in 'display_values' und in 'values' müssen gleich sein
- E: Detaillierte Information: [A 1 (Türen schließen);A 2 (Abfahren), A 1 (Türen schließen);A 2 (Abfahrt)] <> [DE-BOStrab:a1;off, DE-BOStrab:a2;off, DE-BOStrab:a1;DE-BOStrab:a2;off]

The preset bugs listed above were caused by another preset which I am going to fix after filing this bug report.

Attachments (1)

empty-value.xml (1.2 KB) - added by Nakaner 4 years ago.
minimum working example

Download all attachments as: .zip

Change History (4)

Changed 4 years ago by Nakaner

Attachment: empty-value.xml added

minimum working example

comment:1 Changed 4 years ago by simon04

Milestone: 16.02

comment:2 Changed 4 years ago by simon04

Resolution: fixed
Status: newclosed

In 9465/josm:

fix #12160 - Combobox List Entries with Empty Value – display_value and short_description not shown

comment:3 Changed 4 years ago by Don-vip

In 9571/josm:

fix #12416 - see #12160 - fix unnecessary use of scrollbar in tagging presets combos (regression from r9465)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.