Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#12153 closed defect (fixed)

Changing sorting order in Tags/Memberships window and clicking in one tag, edits the wrong tag

Reported by: zermes Owned by: team
Priority: critical Milestone: 15.12
Component: Core Version: tested
Keywords: template_report, Tags/Memberships, sort Cc:

Description (last modified by Don-vip)

What steps will reproduce the problem?

  1. Open menu Windows > Tags/Memberships (Alt+Shift+P it's open by default)
  2. Select or create something with at least 2 tags
  3. Change the tag order in the Keys or Values column (must change the default order, so tags change positions, to reproduce the error)
  4. Select and edit one tag (clicking 2 times or clicking Edit button reproduce the same problem) or delete one tag

What is the expected result?

JOSM should show the selected tag in edit tag dialog, or delete the selected tag

What happens instead?

JOSM shows the wrong tag in edit tag dialog. If we try to delete the selected tag, deletes the other tag, not the selected one.

Although JOSM changes the sorting order, it deletes the tag in "defauld sort order". It's like if we change the sort order, JOSM changes the order as it is shown, but in fact, "internaly" it didn't change the order.

Please provide any additional information below. Attach a screenshot if possible.

If someone doesn't pays attention, it keeps deleting or changing the wrong tags and uploads it to OSM, it's like making unintentional vandalism. Until I found what was going on I was desperate trying to edit the correct tags, specially in objects with many tags, clicking in all of them until it opened the correct edit tag dialog.

Tested in JOSM 9060 stable and 9079 develop versions, without any plug-ins installed. I use JOSM with plugins, but tried it without plug-ins too.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2015-11-24 00:04:12 +0100 (Tue, 24 Nov 2015)
Build-Date:2015-11-23 23:14:21
Revision:9060
Relative:URL: ^/trunk

Identification: JOSM/1.5 (9060 en) Windows 7 64-Bit
Memory Usage: 282 MB / 3623 MB (149 MB allocated, but free)
Java version: 1.8.0_65, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM

JOSM sorting problem in Tags/Menbership window

Attachments (1)

JOSM_error.png (22.1 KB) - added by zermes 4 years ago.
JOSM sorting problem in Tags/Menbership window

Download all attachments as: .zip

Change History (10)

Changed 4 years ago by zermes

Attachment: JOSM_error.png added

JOSM sorting problem in Tags/Menbership window

comment:1 Changed 4 years ago by zermes

P.S.: in attachment, don't pay attention to the change in "building=yes" to "building=roof" between the 2 screenshots, it was I that changed it while I was taking screenshots (shouldn't have done that, could cause confusion), and not JOSM by mistake.

comment:2 Changed 4 years ago by Don-vip

Description: modified (diff)

comment:3 Changed 4 years ago by Klumbumbus

maybe related to #12022

comment:4 Changed 4 years ago by Don-vip

Milestone: 15.12
Priority: normalcritical

Reproduced

comment:5 Changed 4 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 9086/josm:

fix #12153 - Changing sorting order in Tags/Memberships window and clicking in one tag, edits the wrong tag

comment:6 Changed 4 years ago by GerdP

Hmm, maybe their is more to it.
I now have a dialong box showing four tags for way 62271938 in this order:
note=A13-06_17.xml
source=MLIT, Japan
source_ref=http://nlftp.mlit.go.jp/ksj/jpgis/datalist/KsjTmplt-A13.html
source:ja=国土数値情報(森林地域データ)平成18年 国土交通省
The sort indicator in the dialog box shows an "up" sign for the tag key.
Still, when I double click on source_ref line
the dialog presents the source:ja tag.
I've opened a 2nd instance of JOSM 9060 to check.
1) Download way 62271938
2) The tag list shows
note=A13-06_17.xml
source=MLIT, Japan
source:ja=国土数値情報(森林地域データ)平成18年 国土交通省
source_ref=http://nlftp.mlit.go.jp/ksj/jpgis/datalist/KsjTmplt-A13.html
(note that source:ja appears before source_ref)
When I click on the "Key" title the tags are sorted as shown above and the
error occurs.

Anyhow, with JOSM 9086 the change in the order appears as well,but
it doesn't show the error reg. wrong selection.

comment:7 Changed 4 years ago by simon04

Ticket #12223 has been marked as a duplicate of this ticket.

comment:8 Changed 4 years ago by Don-vip

Ticket #12203 has been marked as a duplicate of this ticket.

comment:9 Changed 4 years ago by simon04

Ticket #12166 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.