Modify

Opened 4 years ago

Closed 4 years ago

#12122 closed defect (fixed)

Mapillary Plugin does not log into Mapillary

Reported by: miketho16@… Owned by: nokutu
Priority: normal Milestone:
Component: Plugin mapillary Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. click "Edit" menu
  2. click "preferences"
  3. click "display settings" (top tab on left)
  4. click "Mappilary" tab (top right)
  5. click "login" button
  6. Default brower opens to a Mapillary page
  7. Log in to Mapillary with mapillary username and password
  8. Log in is successful
  9. Mapillary page then asks me to "authenticate" (i.e. grant JOSM access to my account)
  10. click "authenticate" button
  11. a new webpage is displayed whose address is "http://localhost:8763/?error=invalid_request&error_description=Wrong%20RedirectUri%20provided" (note apparent error message in address)
  12. The above webpage displays "Login successful, return to JOSM"
  13. alt-tab to return to JOSM
  14. click "file" menu
  15. click "Upload Pictures" (menu item has Mapillary logo to the left)
  16. Message is displayed "go to settings and log into Mapillary before uploading"

What is the expected result?

  1. No error message embedded in web address, e.g. not "http://localhost:8763/?error=invalid_request&error_description=Wrong%20RedirectUri%20provided"
  2. After performing the steps above through #15, I am able to upload photos to Mapillary.

What happens instead?

answer given as part of "What steps will reproduce the problem?"

Please provide any additional information below. Attach a screenshot if possible.

I also tried it on a different machine on a different network with the same results. Information about that installation:
JOSM Version 8969
Java Version 1.7.0_79
Ubuntu 14.04 LTS

Revision: 8969
Repository Root: http://josm.openstreetmap.de/svn
Relative URL: ^/trunk
Last Changed Author: Don-vip
Last Changed Date: 2015-10-29 22:15:23 +0100 (Thu, 29 Oct 2015)
Build-Date: 2015-10-30 02:32:24
URL: http://josm.openstreetmap.de/svn/trunk
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last Changed Rev: 8969

Identification: JOSM/1.5 (8969 en) Windows 7 64-Bit
Memory Usage: 404 MB / 1776 MB (248 MB allocated, but free)
Java version: 1.8.0_65, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Dataset consistency test: No problems found

Plugins:
- AddrInterpolation (31694)
- InfoMode (31603)
- Mapillary (31694)
- PicLayer (31694)
- apache-commons (31718)
- apache-http (31687)
- buildings_tools (31694)
- ejml (31756)
- geotools (31755)
- jts (31603)
- opendata (31695)
- photo_geotagging (31694)
- photoadjust (31694)
- proj4j (31603)
- undelete (31603)
- utilsplugin2 (31694)

Last errors/warnings:
- E: org.apache.commons.imaging.ImageReadException: Expected String value(36867 (0x9003: DateTimeOriginal): ): [Ljava.lang.String;@2eef0f7
- E: org.apache.commons.imaging.ImageReadException: Expected String value(36867 (0x9003: DateTimeOriginal): ): [Ljava.lang.String;@7c758879
- E: org.apache.commons.imaging.ImageReadException: Expected String value(36867 (0x9003: DateTimeOriginal): ): [Ljava.lang.String;@32f9dc55
- E: org.apache.commons.imaging.ImageReadException: Expected String value(36867 (0x9003: DateTimeOriginal): ): [Ljava.lang.String;@77fc8b78
- E: org.apache.commons.imaging.ImageReadException: Expected String value(36867 (0x9003: DateTimeOriginal): ): [Ljava.lang.String;@1853a7ca

Attachments (0)

Change History (4)

comment:1 Changed 4 years ago by Don-vip

Component: CorePlugin mapillary
Owner: changed from team to nokutu

comment:2 Changed 4 years ago by nokutu

Thanks for reporting, I'm talking with the Mapillary team trying to fix the issue.

comment:3 Changed 4 years ago by miketho16@…

Thanks for the quick action. Let me know if you need any additional information.

comment:4 Changed 4 years ago by nokutu

Resolution: fixed
Status: newclosed

It should be working now, it was a bug at their side because of a server crash they had.

Tell me if you still have any issue

Jorge

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain nokutu.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.