Modify

Opened 4 years ago

Closed 3 years ago

#12058 closed defect (fixed)

AlignWays plugin causes crashes/unexpected errors

Reported by: skquinn Owned by: tilusnet
Priority: normal Milestone:
Component: Plugin alignways Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Correct alignment of a way using AlignWays plugin
  2. Note that after switching away from AlignWays plugin, green and yellow segments from plugin remain.
  3. Try to do something with the segments (delete, combine).

What is the expected result?

No error message.

What happens instead?

"An unexpected error occurred" etc. This has been happening for at least the two most recent stable versions.

Please provide any additional information below. Attach a screenshot if possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2015-10-30 02:32:24
Last Changed Author: Don-vip
Revision: 8969
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2015-10-29 22:15:23 +0100 (Thu, 29 Oct 2015)
Last Changed Rev: 8969

Identification: JOSM/1.5 (8969 en) Linux Ubuntu 14.04.3 LTS
Memory Usage: 285 MB / 876 MB (92 MB allocated, but free)
Java version: 1.7.0_76, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
VM arguments: [-Djosm.restart=true, -Djava.net.useSystemProxies=true, -Djosm.home=/home/skquinn/.josm-ogf]
Program arguments: [ar901_20151103T1728.osm]

Dataset consistency test:
[WARN - NO NODES] Way {Way id=1374163 version=1 V nodes=[{Node id=16586235 version=1 V lat=-8.7070409,lon=170.0267767}]} has only one node


Plugins:
- AddrInterpolation (31694)
- BuildingGeneralization (UNKNOWN)
- ColorPlugin (1414145445)
- Create_grid_of_ways (31603)
- DirectDownload (31603)
- DirectUpload (31694)
- FixAddresses (31694)
- HouseNumberTaggingTool (31603)
- OpeningHoursEditor (31696)
- RoadSigns (31694)
- alignways (31694)
- areaselector (263)
- buildings_tools (31694)
- contourmerge (1013)
- download_along (31603)
- ext_tools (31603)
- fieldpapers (v0.4.0)
- graphview (31694)
- log4j (31603)
- measurement (31694)
- michigan_left (31603)
- poly (31694)
- reltoolbox (31694)
- reverter (31694)
- terracer (31694)
- turnlanes (31603)
- turnrestrictions (31694)
- undelete (31603)
- utilsplugin2 (31694)
- walkingpapers (31603)
- waydownloader (31603)
- waypoint_search (31603)
- wikipedia (31694)

Last errors/warnings:
- E: java.lang.ArrayIndexOutOfBoundsException: 0

java.lang.ArrayIndexOutOfBoundsException: 0
	at org.openstreetmap.josm.data.osm.Way.getNode(Way.java:134)
	at com.tilusnet.josm.plugins.alignways.AlignWaysSegment.drawSegment(AlignWaysSegment.java:101)
	at com.tilusnet.josm.plugins.alignways.AlignWaysSegment.highlightSegment(AlignWaysSegment.java:96)
	at com.tilusnet.josm.plugins.alignways.AlignWaysSegment.paint(AlignWaysSegment.java:88)
	at com.tilusnet.josm.plugins.alignways.AlignWaysAlgnSegment.paint(AlignWaysAlgnSegment.java:224)
	at org.openstreetmap.josm.gui.MapView.paint(MapView.java:726)
	at javax.swing.JComponent.paintChildren(JComponent.java:888)
	at javax.swing.JComponent.paint(JComponent.java:1064)
	at javax.swing.JComponent.paintToOffscreen(JComponent.java:5232)
	at javax.swing.BufferStrategyPaintManager.paint(BufferStrategyPaintManager.java:295)
	at javax.swing.RepaintManager.paint(RepaintManager.java:1249)
	at javax.swing.JComponent._paintImmediately(JComponent.java:5180)
	at javax.swing.JComponent.paintImmediately(JComponent.java:4991)
	at javax.swing.RepaintManager$3.run(RepaintManager.java:808)
	at javax.swing.RepaintManager$3.run(RepaintManager.java:796)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:796)
	at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:769)
	at javax.swing.RepaintManager.prePaintDirtyRegions(RepaintManager.java:718)
	at javax.swing.RepaintManager.access$1100(RepaintManager.java:62)
	at javax.swing.RepaintManager$ProcessingRunnable.run(RepaintManager.java:1677)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:312)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:738)
	at java.awt.EventQueue.access$300(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:699)
	at java.awt.EventQueue$3.run(EventQueue.java:697)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:708)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)

Attachments (0)

Change History (2)

comment:1 Changed 4 years ago by anonymous

Same error over here, occuring since the last two stable versions -- System identification: JOSM/1.5 (8969 en) Windows 10

comment:2 Changed 3 years ago by Don-vip

Resolution: fixed
Status: newclosed

Fixed in [o32160:32162]. For point 2, see #12132

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain tilusnet.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.