Modify

Opened 5 years ago

Closed 5 years ago

#12057 closed defect (duplicate)

Combobox and table rendering problems

Reported by: *Martin* Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: linux Cc:

Description

Items in the combo box are moving up and down when I want to select one and they are rendered at wrong positions. Also there is a problem with property grid - when selecting a cell it is incorrectly rendered. Please see it at https://drive.google.com/file/d/0B6M72P2gzYmwSWlyTUxpUW52c0E/view?usp=sharing

I am using Xfce 4.12 on Debian Jessie

java version "1.7.0_91"
OpenJDK Runtime Environment (IcedTea 2.6.2) (7u91-2.6.2-1)
OpenJDK 64-Bit Server VM (build 24.91-b01, mixed mode)

The same problem is with Java 8.

Attachments (1)

out5.ogv (3.4 MB) - added by *Martin* 5 years ago.
the video demonstrating the problem

Change History (8)

Changed 5 years ago by *Martin*

Attachment: out5.ogv added

the video demonstrating the problem

comment:1 Changed 5 years ago by Klumbumbus

looks similar to #11920

comment:2 Changed 5 years ago by naoliv

Jessie was released on late April (so my guess is that it isn't a problem with a possible updated/newer lib).
I will see if I can reproduce this with older JOSM releases and try to bisect it.

comment:3 Changed 5 years ago by *Martin*

Now I see simmilar problem with comboboxes in different Swing apps. But none of them has that editable grid. Not sure if both problems are related.

comment:4 Changed 5 years ago by Don-vip

Keywords: linux added

comment:5 Changed 5 years ago by Don-vip

So far the problem only concerns Debian or its derivatives (Ubuntu/Mint). Could someone please test on another distros? (fedora/arch for example)

comment:6 Changed 5 years ago by mdk

see also #12022

comment:7 Changed 5 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #12022.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.