Modify

Opened 7 years ago

Closed 7 years ago

#11920 closed defect (duplicate)

Wrong values displayed in tags window

Reported by: naoliv Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: linux debian Cc: Klumbumbus

Description

Take a look at the video and note on how sometimes when I just click at the value cell it wrongly displays another value in key and/or value: http://naoliv.iq.unesp.br/osm/11920.ogv

JOSM

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2015-10-02 01:32:15
Last Changed Author: wiktorn
Revision: 8815
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2015-10-01 21:45:34 +0200 (Thu, 01 Oct 2015)
Last Changed Rev: 8815

Identification: JOSM/1.5 (8815 pt_BR) Linux Debian GNU/Linux testing (stretch)
Memory Usage: 1016 MB / 9102 MB (542 MB allocated, but free)
Java version: 1.7.0_85, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u85-2.6.1-3
VM arguments: [-Dawt.useSystemAAFontSettings=on, -Dsun.java2d.opengl=true]
Dataset consistency test: No problems found

Plugins:
- Create_grid_of_ways (31241)
- OpeningHoursEditor (31241)
- PicLayer (31241)
- RoadSigns (31241)
- SimplifyArea (31241)
- buildings_tools (31558)
- conflation (0.1.7)
- contourmerge (1013)
- download_along (31241)
- editgpx (31241)
- geotools (31126)
- imagery_offset_db (31241)
- importvec (31241)
- jts (31126)
- log4j (31231)
- measurement (31289)
- merge-overlap (31241)
- opendata (31241)
- pbf (31241)
- pdfimport (31241)
- poly (31241)
- reverter (31241)
- scripting (30710)
- todo (29154)
- turnrestrictions (31578)
- undelete (31241)
- utilsplugin2 (31463)

Attachments (0)

Change History (10)

comment:1 in reply to:  description Changed 7 years ago by Don-vip

Replying to naoliv:

VM arguments: [-Dawt.useSystemAAFontSettings=on, -Dsun.java2d.opengl=true]

that's very weird. Do you reproduce the problem without these options?

comment:2 Changed 7 years ago by naoliv

Tested without any options and I still see the same problem.

comment:3 Changed 7 years ago by Don-vip

ok thanks. And with Java 8, same behaviour?

comment:4 Changed 7 years ago by Klumbumbus

Cc: Klumbumbus added

comment:5 Changed 7 years ago by naoliv

Seeing the same issue with Java 8:

Revision: 8826
Repository Root: http://josm.openstreetmap.de/svn
Relative URL: ^/trunk
Last Changed Author: Don-vip
Last Changed Date: 2015-10-05 00:41:14 +0200 (Mon, 05 Oct 2015)
Build-Date: 2015-10-05 01:32:00
URL: http://josm.openstreetmap.de/svn/trunk
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last Changed Rev: 8826

Identification: JOSM/1.5 (8826 pt_BR) Linux Debian GNU/Linux testing (stretch)
Memory Usage: 596 MB / 9102 MB (462 MB allocated, but free)
Java version: 1.8.0_66-internal, Oracle Corporation, OpenJDK 64-Bit Server VM
VM arguments: [-Dawt.useSystemAAFontSettings=on]
Dataset consistency test: No problems found

comment:6 in reply to:  5 Changed 7 years ago by Don-vip

Replying to naoliv:

VM arguments: [-Dawt.useSystemAAFontSettings=on]

Where does this option come from? Can you test to switch it off with -Dawt.useSystemAAFontSettings=off?

comment:7 Changed 7 years ago by Don-vip

Keywords: linux added

comment:8 Changed 7 years ago by Don-vip

Keywords: debian added

comment:9 Changed 7 years ago by naoliv

I pass -Dawt.useSystemAAFontSettings=on so I can get antialiased fonts (otherwise they get really ugly)
Tested combinations using -Dawt.useSystemAAFontSettings=on and -Dawt.useSystemAAFontSettings=off both with Java 7 and 8:

java version "1.7.0_91"
OpenJDK Runtime Environment (IcedTea 2.6.2) (7u91-2.6.2-1)
OpenJDK 64-Bit Server VM (build 24.91-b01, mixed mode)
openjdk version "1.8.0_66-internal"
OpenJDK Runtime Environment (build 1.8.0_66-internal-b17)
OpenJDK 64-Bit Server VM (build 25.66-b17, mixed mode)

With the four combinations I see the same behavior (and in two different machines).

comment:10 Changed 7 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #12022.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.