Modify

Opened 4 years ago

Closed 3 years ago

#11921 closed enhancement (duplicate)

Sorting of multiple values changes when edited with different language settings

Reported by: osm.mapper999@… Owned by: osm.mapper999@…
Priority: normal Milestone:
Component: Internal preset Version: tested
Keywords: Cc:

Description (last modified by Don-vip)

Since r8493 the sorting of values is based on the language used.

This leads to the following problem which I found when tagging railway signals:

  • somebody creates a tag with a value of e.g. "A;B" with a German JOSM
  • another mapper with an English JOSM opens the preset dialogue for this tag and closes it with "Apply" without changing anything.
  • the value is now changed to "B;A", because in English the alphabetical order of the values is different.

So now we have a new version of this node/way without actually changing anything. A solution could be that the applied value is always sorted based on the value and not based on the display_values. In the preset window it can still be ordered based on language settings.

(see also https://github.com/rurseekatze/OpenRailwayMap/pull/357)

Attachments (0)

Change History (3)

comment:1 Changed 4 years ago by Don-vip

Description: modified (diff)

comment:2 Changed 4 years ago by Klumbumbus

Owner: changed from team to osm.mapper999@…
Status: newneedinfo

Can you please give a real example?

comment:3 Changed 3 years ago by Don-vip

Resolution: duplicate
Status: needinfoclosed

Closed as duplicate of #11926.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain osm.mapper999@….
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.