Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#12059 closed defect (fixed)

convert gpx-layer to data-layer not working if in session.joz

Reported by: MKnight Owned by: team
Priority: normal Milestone: 15.11
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Add a GPX-Layer
  2. Save as session
  3. mark "add" (hinzufügen) instead local file
  4. Close/open Session
  5. go to convert gpx to data layer

What is the expected result?

Convert GPX to data layer (or alternatively not possible to use this function)

What happens instead?

Nothing AND Program Error

Please provide any additional information below. Attach a screenshot if possible.

Revision: 8969
Repository Root: http://josm.openstreetmap.de/svn
Relative URL: ^/trunk
Last Changed Author: Don-vip
Last Changed Date: 2015-10-29 22:15:23 +0100 (Thu, 29 Oct 2015)
Build-Date: 2015-10-30 02:32:24
URL: http://josm.openstreetmap.de/svn/trunk
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last Changed Rev: 8969

Identification: JOSM/1.5 (8969 de) Windows 7 64-Bit
Memory Usage: 276 MB / 1353 MB (139 MB allocated, but free)
Java version: 1.8.0_60, Oracle Corporation, Java HotSpot(TM) Client VM
Program arguments: [de-josm-kreise.joz]

Plugins:
- Mapillary (31694)
- OpeningHoursEditor (31696)
- RoadSigns (31694)
- apache-commons (31718)
- apache-http (31687)
- buildings_tools (31694)
- continuosDownload (1446070193)
- jts (31603)
- log4j (31603)
- measurement (31694)
- pbf (31694)
- public_transport (31646)
- reltoolbox (31694)
- reverter (31694)
- scripting (30722)
- tag2link (31603)
- terracer (31694)
- turnlanes (31603)
- turnrestrictions (31694)
- undelete (31603)
- utilsplugin2 (31694)
- waydownloader (31603)

Last errors/warnings:
- E: No tagging preset submenu for   
- E: No tagging preset submenu for   
- E: No tagging preset submenu for   
- E: No tagging preset submenu for   
- E: java.lang.NullPointerException

Attachments (1)

hc_206.png (312.2 KB) - added by MKnight 5 years ago.

Download all attachments as: .zip

Change History (5)

Changed 5 years ago by MKnight

Attachment: hc_206.png added

comment:1 Changed 5 years ago by simon04

Milestone: 15.11

comment:2 Changed 5 years ago by simon04

Resolution: fixed
Status: newclosed

In 8987/josm:

fix #12059 - NPE when converting GPX layer to data-layer from session.joz

Regression from r8830.

comment:3 Changed 5 years ago by Don-vip

Ticket #12095 has been marked as a duplicate of this ticket.

comment:4 Changed 5 years ago by Don-vip

Ticket #12134 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.