Modify

Opened 3 years ago

Closed 3 weeks ago

#11949 closed defect (fixed)

History dialog going crazy sometimes with long usernames

Reported by: rickmastfan67 Owned by: team
Priority: normal Milestone: 18.05
Component: Core Version: latest
Keywords: history Cc:

Description

Steps to reproduce:

  1. Download the following relation (just the relation, don't need the ways to see this happening): https://www.openstreetmap.org/relation/411603
  2. Once downloaded, select the relation and call up the 'History' dialog for it (Ctrl+H)
  3. When the History dialog shows up, you should be comparing versions 67 & 68 in the 'Tag' area.
  4. Now attempt to compare versions 60 & 61.
  5. Now compare versions 61 & 62.

What happens:
The columns in the 'Tag' area start going crazy whenever you attempt to view any other history entry.

What should happen:
The columns in the 'Tag' area (& members) should be a fixed size so that it doesn't 'spaz' out.

It seems that the long user name of the editor who made the change in Version 61 is causing the comparing area to freak out. Maybe the 'Changeset' button there is also causing problems because it keeps changing width.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2015-10-08 01:33:51
Last Changed Author: Don-vip
Revision: 8837
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2015-10-08 02:05:12 +0200 (Thu, 08 Oct 2015)
Last Changed Rev: 8837

Identification: JOSM/1.5 (8837 en) Windows 7 64-Bit
Memory Usage: 650 MB / 1820 MB (506 MB allocated, but free)
Java version: 1.7.0_79, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Dataset consistency test: No problems found

Plugins:
- OpeningHoursEditor (31603)
- buildings_tools (31603)
- measurement (31603)
- osmarender (31603)
- reverter (31603)
- turnrestrictions (31603)
- undelete (31603)
- utilsplugin2 (31603)

Attachments (0)

Change History (3)

comment:1 Changed 3 years ago by Don-vip

Summary: History dialog going crazy sometimesHistory dialog going crazy sometimes with long usernames

Indeed, osm_validation_and_improvements is a quite long username.

comment:2 Changed 3 weeks ago by Don-vip

Milestone: 18.05

comment:3 Changed 3 weeks ago by Don-vip

Resolution: fixed
Status: newclosed

In 13853/josm:

fix #11949 - History dialog: insert <wbr> in username labels to preserve dialog layout for long usernames

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.