Modify

Opened 4 years ago

Closed 3 years ago

Last modified 3 years ago

#11878 closed defect (fixed)

Terracer plugin causes unexpected exception. Can't upload.

Reported by: LivingWithDragons Owned by: team
Priority: critical Milestone:
Component: Plugin terracer Version: latest
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  • Open JOSM
  • Create a new layer (or download OSM data) with a highway.
  • Use the "building tools" plugin to create a long rectangle with building=yes
  • Select both items, initiate the "terracer" plugin by Cntrl+T
  • Enter values, such as numbers from 1 to 5. Tick the box to create an associatedStreet relation
  • Click okay and the "Update plug-ins" popup appears. *An unexpected exception occurred that may have come from the 'terracer' plug-in. According to the information within the plug-in, the author is Matt Amos. Try updating to the newest version of this plug-in before reporting a bug.*
  • Keep or Disable plugin, and the "Unexpected exception" appears, which lets me file a bug report or not, and I do so.
  • The terracer plugin dialog is still open, but I see behind it the building has been split, numbered, and relation created.
  • I click cancel. When I click the "upload" button, the "Unexpected exception" appears rather than the upload dialog.

What is the expected result?

A row of joined buildings, numbered and in a relation.

What happens instead?

An unexpected exception. The desired result happens in the background. The upload dialog will not appear when later requested.

Attempts to reset any bad configuration (as I had tried to change a preference setting, but misundersto0d it)

I tried to fix this, even going as far as...

  • Deleting the josm-latest.jar file.
  • Renaming the .josm file in my home directory (contains plugins and settings/preferences)
  • Downloading josm-latest.jar again
  • Reinstalling plugins of my choice
  • Following the steps above to recreate the problem, and getting the same result.

Unexpected exception

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2015-09-18 01:32:13
Last Changed Author: Don-vip
Revision: 8765
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2015-09-18 00:59:57 +0200 (Fri, 18 Sep 2015)
Last Changed Rev: 8765

Identification: JOSM/1.5 (8765 en_GB) Linux Ubuntu 12.04.5 LTS
Memory Usage: 197 MB / 876 MB (71 MB allocated, but free)
Java version: 1.7.0_65, Oracle Corporation, OpenJDK Server VM
Java package: openjdk-7-jre:i386-7u65-2.5.1-4ubuntu1~0.12.04.2

Dataset consistency test:
[NO DATASET] {Way id=-23 version=0 MVT nodes=[{Node id=-19 version=0 MV lat=0.0010779783408696225,lon=-0.013295066204968915}, {Node id=-28 version=0 MV lat=0.0019313778604832018,lon=-0.008803489784371309}, {Node id=-29 version=0 MV lat=-8.716848874667206E-4,lon=-0.008270907862184033}, {Node id=-22 version=0 MV lat=-0.0017250844071529958,lon=-0.01276248428278164}, {Node id=-19 version=0 MV lat=0.0010779783408696225,lon=-0.013295066204968915}]} is referenced by {Relation id=-39 version=0 VT [way -11, way -23, way -36, way -37, way -38]} but not found in dataset


Plugins:
- DirectUpload (31241)
- Mapillary (31550)
- OpeningHoursEditor (31241)
- PicLayer (31241)
- areaselector (257)
- buildings_tools (31558)
- commons-imaging (31241)
- geochat (31241)
- log4j (31231)
- measurement (31289)
- photo_geotagging (31241)
- public_transport (31241)
- public_transport_layer (31220)
- reverter (31241)
- terracer (31241)

Last errors/warnings:
- E: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Relation member must be part of the same dataset as relation(relation -39, way -23)

org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Relation member must be part of the same dataset as relation(relation -39, way -23)
	at org.openstreetmap.josm.data.osm.Relation.checkMembers(Relation.java:493)
	at org.openstreetmap.josm.data.osm.Relation.setDataset(Relation.java:483)
	at org.openstreetmap.josm.data.osm.DataSet.addPrimitive(DataSet.java:468)
	at org.openstreetmap.josm.command.AddCommand.executeCommand(AddCommand.java:60)
	at org.openstreetmap.josm.command.SequenceCommand.executeCommand(SequenceCommand.java:53)
	at terracer.TerracerAction$1.executeCommand(TerracerAction.java:470)
	at org.openstreetmap.josm.data.UndoRedoHandler.addNoRedraw(UndoRedoHandler.java:43)
	at org.openstreetmap.josm.data.UndoRedoHandler.add(UndoRedoHandler.java:69)
	at terracer.TerracerAction.terraceBuilding(TerracerAction.java:428)
	at terracer.HouseNumberInputHandler.actionPerformed(HouseNumberInputHandler.java:294)
	at terracer.HouseNumberInputDialog.buttonAction(HouseNumberInputDialog.java:235)
	at org.openstreetmap.josm.gui.ExtendedDialog$1.actionPerformed(ExtendedDialog.java:327)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2018)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2341)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:402)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:252)
	at java.awt.Component.processMouseEvent(Component.java:6516)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3311)
	at java.awt.Component.processEvent(Component.java:6281)
	at java.awt.Container.processEvent(Container.java:2229)
	at java.awt.Component.dispatchEventImpl(Component.java:4872)
	at java.awt.Container.dispatchEventImpl(Container.java:2287)
	at java.awt.Component.dispatchEvent(Component.java:4698)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4832)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4492)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4422)
	at java.awt.Container.dispatchEventImpl(Container.java:2273)
	at java.awt.Window.dispatchEventImpl(Window.java:2719)
	at java.awt.Component.dispatchEvent(Component.java:4698)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:735)
	at java.awt.EventQueue.access$200(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:694)
	at java.awt.EventQueue$3.run(EventQueue.java:692)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:87)
	at java.awt.EventQueue$4.run(EventQueue.java:708)
	at java.awt.EventQueue$4.run(EventQueue.java:706)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:705)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:154)
	at java.awt.WaitDispatchSupport$2.run(WaitDispatchSupport.java:182)
	at java.awt.WaitDispatchSupport$4.run(WaitDispatchSupport.java:221)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.awt.WaitDispatchSupport.enter(WaitDispatchSupport.java:219)
	at java.awt.Dialog.show(Dialog.java:1082)
	at java.awt.Component.show(Component.java:1655)
	at java.awt.Component.setVisible(Component.java:1607)
	at java.awt.Window.setVisible(Window.java:1014)
	at java.awt.Dialog.setVisible(Dialog.java:1005)
	at org.openstreetmap.josm.gui.ExtendedDialog.setVisible(ExtendedDialog.java:502)
	at org.openstreetmap.josm.gui.ExtendedDialog.showDialog(ExtendedDialog.java:290)
	at terracer.TerracerAction.actionPerformed(TerracerAction.java:233)
	at javax.swing.SwingUtilities.notifyAction(SwingUtilities.java:1662)
	at javax.swing.JComponent.processKeyBinding(JComponent.java:2869)
...<snip>...

Attachments (0)

Change History (10)

comment:1 Changed 3 years ago by stoecker

Ticket #13167 has been marked as a duplicate of this ticket.

comment:2 Changed 3 years ago by stoecker

#13167 has a good (or another) description for reproducing the issue.

comment:3 Changed 3 years ago by stoecker

Ticket #13103 has been marked as a duplicate of this ticket.

comment:4 Changed 3 years ago by stoecker

Ticket #12930 has been marked as a duplicate of this ticket.

comment:5 Changed 3 years ago by stoecker

Ticket #12917 has been marked as a duplicate of this ticket.

comment:6 Changed 3 years ago by stoecker

Ticket #12911 has been marked as a duplicate of this ticket.

comment:7 Changed 3 years ago by stoecker

Ticket #12738 has been marked as a duplicate of this ticket.

comment:8 Changed 3 years ago by stoecker

Ticket #12695 has been marked as a duplicate of this ticket.

comment:9 Changed 3 years ago by bastiK

Resolution: fixed
Status: newclosed

In [o33031]:
fixed ​#11878 Terracer plugin: error when creating associatedStreet relation

comment:10 Changed 3 years ago by bastiK

Ticket #13662 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.