Modify

Opened 5 years ago

Closed 5 years ago

#12738 closed defect (duplicate)

2nd + later terrace is missing addr:street key/value, whilst 1st terrace contains it

Reported by: alexkemp Owned by: team
Priority: normal Milestone:
Component: Plugin terracer Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. start OS then start JOSM
  2. select 1st building + street then create terrace using terracer (check 'create an associatedStreet relation') (check 'keep outline way') (else causes JOSM crash) (works fine in all respects)
  3. repeat step (2) with 2nd & subsequent buildings

What is the expected result?

a terrace + house/street relation

What happens instead?

(on 2nd + any subsequent terrace creation during the same session)
addr:street key/value is missing from each house; in all other respects the 2nd & subsequent buildings produce accurate terraces; adding the missing addr:street key/value back to each house also seems to produce accurate relations.

Please provide any additional information below.

terracer produces a terrace ordered either from low-house to high-house number, or from hi-to-lo; that order can vary (hi-to-lo or lo-to-hi) from one building to the next during the same session; I cannot discover any combo of options that affects which ordering is chosen; it seems random. However, normally, during a session terracer will produce the same order within a terrace from one building to the next. But I promise you:- sometimes that order changes!

Attach a screenshot if possible.

Screenshots of both 1st + 2nd building creation are attached, as is a status report.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-03-13 01:17:21 +0100 (Sun, 13 Mar 2016)
Build-Date:2016-03-13 02:35:00
Revision:9979
Relative:URL: ^/trunk

Identification: JOSM/1.5 (9979 en_GB) Linux Debian GNU/Linux 8.4 (jessie)
Memory Usage: 182 MB / 247 MB (44 MB allocated, but free)
Java version: 1.8.0_77-b03, Oracle Corporation, Java HotSpot(TM) Client VM
VM arguments: [-Djava.net.useSystemProxies=true]
Dataset consistency test: No problems found

Plugins:
- DirectUpload (30762)
- HouseNumberTaggingTool (31772)
- buildings_tools (31895)
- continuosDownload (1446070193)
- imagery_offset_db (32046)
- imageryadjust (31772)
- terracer (31895)
- utilsplugin2 (32099)

Attachments (3)

building_1.png (1.1 MB) - added by alexkemp 5 years ago.
Building 1 just before pressing OK
building_2.png (886.7 KB) - added by alexkemp 5 years ago.
Building 2 *after* pressing 'OK'
status report.txt (30.8 KB) - added by alexkemp 5 years ago.
Status report

Download all attachments as: .zip

Change History (5)

Changed 5 years ago by alexkemp

Attachment: building_1.png added

Building 1 just before pressing OK

Changed 5 years ago by alexkemp

Attachment: building_2.png added

Building 2 *after* pressing 'OK'

Changed 5 years ago by alexkemp

Attachment: status report.txt added

Status report

comment:1 Changed 5 years ago by Don-vip

Component: CorePlugin terracer

comment:2 Changed 5 years ago by stoecker

Resolution: duplicate
Status: newclosed

Closed as duplicate of #11878.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.