Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#11861 closed defect (duplicate)

Yellow squares on nodes not visible anymore / gele vierkantjes bij knopen niet meer zichtbaar

Reported by: acfvh@… Owned by: acfvh@…
Priority: normal Milestone:
Component: Internal mappaint style Version: tested
Keywords: Cc:

Description

Hello,

I just downloaded the latest version of the josm-tested.jar file (8677) after working over a year in a previous version (7287). The first thing i missed were the little yellow squares on the nodes which made it easy to snap to/from nodes. In my opinion it makes it more difficult to see, select and move existing nodes. I did see the wireframe-visualisation in which the yellow squares are visible again, but then i can't move nodes at all it seems and off course all other styles dissappear too.
Is it possible to get the yellow squares back on the nodes as in the previous version i used. For example by making it a radio button or something like that. Until that time i will continue using version 7287 as for me its easier in use. If possible i'd like a reaction by mail: acfvh@…

Greetings, Antoon van Ham, Netherlands

Attachments (1)

Difference in JOSM-version.png (393.8 KB) - added by acfvh@… 4 years ago.
On the left the older version of JOSM, on the right the latest version

Download all attachments as: .zip

Change History (7)

comment:1 Changed 4 years ago by Klumbumbus

Owner: changed from team to acfvh@…
Status: newneedinfo

Please attach your statusreport and a screenshoot as asked on newticket.

comment:2 Changed 4 years ago by Klumbumbus

Component: unspecifiedInternal mappaint style
Type: enhancementdefect

Changed 4 years ago by acfvh@…

On the left the older version of JOSM, on the right the latest version

comment:3 Changed 4 years ago by acfvh@…

What steps will reproduce the problem?

  1. Open JOSM version 8677 in stead of version 7287
  2. Download a certain area from the server (open geofiction)

What is the expected result?

Yellow squares on the nodes that turn brightly red when selected and can be moved in the same mouseclick

What happens instead?

The yellow squares only appear when very far zoomed in. It's hardly visible when a node is selected (just one red pixel?). The click and move is only possible when very far zoomed in.

Please provide any additional information below. Attach a screenshot if possible.

Revision: 8677
Repository Root: http://josm.openstreetmap.de/svn
Relative URL: ^/trunk
Last Changed Author: Don-vip
Last Changed Date: 2015-08-21 22:18:03 +0200 (Fri, 21 Aug 2015)
Build-Date: 2015-08-21 23:32:08
URL: http://josm.openstreetmap.de/svn/trunk
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last Changed Rev: 8677

Identification: JOSM/1.5 (8677 nl) Windows 7 64-Bit
Memory Usage: 167 MB / 247 MB (32 MB allocated, but free)
Java version: 1.8.0_31, Oracle Corporation, Java HotSpot(TM) Client VM
Dataset consistency test: No problems found

Plugins:
- buildings_tools (31361)
- geotools (31126)
- jts (31126)
- measurement (31289)
- opendata (31241)
- pbf (31241)
- utilsplugin2 (31463)

Last errors/warnings:
- E: org.openstreetmap.josm.io.OsmTransferException: java.net.SocketTimeoutException: Read timed out. Oorzaak: java.net.SocketTimeoutException: Read timed out

comment:4 Changed 4 years ago by Klumbumbus

Resolution: duplicate
Status: needinfoclosed

Closed as duplicate of #10540.

This is the intended behavior. Nodes shrink when you zoom out to avoid node clutter and for better visibility of the ways. The zoom level you show in the screenshot (212m at the scale) is zoomed out far. At this zoom level you usually do not edit single nodes because it is to much imprecise. (In your example you have very few data. Try to download a part of a city and zoom to this level.) Making the selected node bigger is part of #10540 or #9891.

Also note that the snap distance is always the same for big and small nodes.

However if you want, you can disable the node shrinking in the style settings in the mappaint style toggle dialog. https://josm.openstreetmap.de/wiki/Help/Dialog/MapPaint#Stylesettings

Last edited 4 years ago by Klumbumbus (previous) (diff)

comment:5 Changed 4 years ago by Klumbumbus

Resolution: duplicate
Status: closedreopened

sorry, wrong ticket

comment:6 Changed 4 years ago by Klumbumbus

Resolution: duplicate
Status: reopenedclosed

Closed as duplicate of #9891.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain acfvh@….
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.