Modify

Opened 5 years ago

Closed 3 years ago

#10540 closed enhancement (fixed)

Selected plain node is not filled in JOSM default MapCSS style (unlike old XML)

Reported by: grinapo Owned by: team
Priority: normal Milestone: 16.02
Component: Internal mappaint style Version: latest
Keywords: template_report Cc: skyper

Description

What steps will reproduce the problem?

  • When using JOSM default XML style a selected node is visible: filled
  • Using JOSM default MapCSS style selected node is the same as nonselected (hole in the middle), so the selection is invisible

What is the expected result?

  • same as old XML did, selected nodes are filled, or otherwise visibly marked

Please provide any additional information below. Attach a screenshot if
possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-09-21 01:34:10
Last Changed Author: stoecker
Revision: 7573
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-09-20 21:37:54 +0200 (Sat, 20 Sep 2014)
Last Changed Rev: 7573

Identification: JOSM/1.5 (7573 en) Linux Debian GNU/Linux unstable (sid)
Memory Usage: 200 MB / 1765 MB (58 MB allocated, but free)
Java version: 1.7.0_55, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u55-2.4.7-2
WebStart package: icedtea-netx:amd64-1.5-1
VM arguments: [-Dicedtea-web.bin.name=javaws, -Dicedtea-web.bin.location=/usr/bin/javaws, -Djava.security.manager, -Djava.security.policy=/etc/icedtea-web/javaws.policy]
Dataset consistency test: No problems found

Plugins:
- AddrInterpolation (30416)
- DirectUpload (30416)
- ElevationProfile (30416)
- FixAddresses (30416)
- HouseNumberTaggingTool (30416)
- InfoMode (30416)
- OpeningHoursEditor (30609)
- PicLayer (30436)
- RoadSigns (30495)
- alignways (30631)
- buildings_tools (30485)
- dataimport (30416)
- download_along (30416)
- editgpx (30634)
- ext_tools (30416)
- fieldpapers (b49dadd)
- gpsblam (30444)
- graphview (30416)
- imagery_offset_db (30534)
- junctionchecking (30416)
- log4j (30416)
- mapdust (30502)
- measurement (30641)
- notes (v0.9.4)
- osmarender (30416)
- pbf (30660)
- photo_geotagging (30462)
- reltoolbox (30587)
- reverter (30521)
- routing (30416)
- scripting (30700)
- tageditor (30488)
- turnlanes (30416)
- turnrestrictions (30651)
- undelete (30416)
- utilsplugin2 (30460)
- videomapping (30639)
- walkingpapers (30416)
- waypoint_search (30416)

Last errors/warnings:
- W: Detected deprecated 'canvas{background-color}' in 'http://josm.openstreetmap.de/josmfile?page=Styles/Fixme&style' which will be removed shortly. Use 'fill-color' instead.
- W: Failed to load http://openptmap.de/favicon_pt.png, use cached file and retry next time: java.net.SocketTimeoutException: connect timed out

Attachments (1)

Selection.PNG (564.7 KB) - added by Max 5 years ago.
Example of difference between old and new node selection

Download all attachments as: .zip

Change History (19)

comment:1 Changed 5 years ago by Klumbumbus

There is a difference between selected and non selected nodes. The color of the selected node still changes from yellow to red.

If it should be filled when selected, then I think we need the :selected pseudo class for mapcss (see #9891), because of canvas {default-points: false} which was added in #10363.

comment:2 in reply to:  1 Changed 5 years ago by grinapo

Replying to Klumbumbus:

There is a difference between selected and non selected nodes. The color of the selected node still changes from yellow to red.

Where should I start looking if they don't change for me? They're completely same looking yellow hollow points. (I tried to take care not to have any else custom styles selected, but I may have other settings around, if there could be any related, which I doubt.)

(By the way I've never seen selected red nodes. They're always have been yellow all way around.)

comment:3 Changed 5 years ago by Klumbumbus

preferences -> colors -> selected

comment:4 in reply to:  3 Changed 5 years ago by grinapo

Replying to Klumbumbus:

preferences -> colors -> selected

Oh, interesting. I am pretty sure I haven't manually changed any colors but indeed, setting all to defaults resulted red selections all around.

At least it's partially visible now but yeah, #9891 is probably the way to go.

Thanks. I'd keep this open till the new could look like the old.

comment:5 Changed 5 years ago by grinapo

Summary: Selected plain node is not visible in JOSM default MapCSS styleSelected plain node is not filled in JOSM default MapCSS style (unlike old XML)
Type: defectenhancement

comment:6 Changed 5 years ago by Max

I can confirm this changed for me without me changing anything: selected nodes just became "invisible" after a JOSM update, while they were prominently visible before. Having applied the suggested solution they at least started changing colour now, but for all practical purposes they are still invisible. Putting aside the amount of sheer luck one needs to stumble upon an explanation after such an apparently mysterious change, this is a setback in usability of monstrous proportions for me, so much so I'm forced to go back at an older version and stay with it as long as I need to until this gets sorted out (unfortunate since some plugins refuse to work with older versions).

comment:7 Changed 5 years ago by Klumbumbus

Can you explain again, what exactly is the "setback in usability of monstrous proportions"? That a selcted node is not filled? (This is actually the only difference to the old style when you disable "less obtrusive node symbols at low zoom" in the mappaint settings.)

Changed 5 years ago by Max

Attachment: Selection.PNG added

Example of difference between old and new node selection

comment:8 Changed 5 years ago by Max

Why yes, yes indeed, I can - and unfortunately that's exactly what it is as far as I'm concerned: in my experience, 95% of editing work goes toward making sure that ALL the right nodes are selected before an operation, and ONLY they are. Please see the attached sample where the old node selection jumps off the page even when using the same yellow color unselected nodes use, vs. the new style where leaving selection as yellow makes it completely indistinguishable from non-selection, and even changing to red (the rest of the colors I tried were even less visible) leaves selected nodes practically invisible. Please also note the recommended setting is unchecked - it changes nothing whatsoever for me.

comment:9 Changed 5 years ago by skyper

Cc: skyper added

comment:10 Changed 5 years ago by skyper

Thought I had reported the change while we did the transition but got probably lost in some comment.

comment:11 in reply to:  8 Changed 5 years ago by bastiK

Replying to Max:

and even changing to red (the rest of the colors I tried were even less visible) leaves selected nodes practically invisible. Please also note the recommended setting is unchecked - it changes nothing whatsoever for me.

If the red and yellow nodes were really that indistinguishable, we'd have more reports by now. This is probably perceived very differently from user to user.

As Klumbumbus explained, this problem is a known regression from a larger rework of the style, but it is more work to fix this properly (by adding :selected pseudo class).

comment:12 Changed 5 years ago by Klumbumbus

One more regression is, that selected nodes were a bit larger than unselected (with the old xml style). To fix this also the :selcted pseudo class is needed.

comment:13 Changed 4 years ago by Klumbumbus

Ticket #11861 has been marked as a duplicate of this ticket.

comment:14 Changed 3 years ago by Don-vip

Milestone: 16.01

comment:15 Changed 3 years ago by Don-vip

Milestone: 16.0116.02

comment:16 Changed 3 years ago by Klumbumbus

In 9451/josm:

see #10540, see #9891 - make selected nodes more visible, i.e. always filled and size 6 (like in old XML style)

comment:17 Changed 3 years ago by Klumbumbus

I let the ticket open. I do not know if there are any drawbacks. See ticket:9891#comment:19

comment:18 Changed 3 years ago by Klumbumbus

Resolution: fixed
Status: newclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.