Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#10539 closed defect (duplicate)

missing disk selection in File open dialog window on OS X

Reported by: vlada@… Owned by: vlada@…
Priority: normal Milestone:
Component: Core Version: latest
Keywords: open, file, osx Cc:

Description

Josm 7480 on OS X 10.9.6 with Java 1.7.0_12-ea when the "File open" dialog window is missing the ability to select other disks. I can only select folders up to root disk but not folders in /Volumes or such. The dialog window does not seem to be the classical Finder dialog window.

Attachments (0)

Change History (5)

comment:1 in reply to:  description ; Changed 5 years ago by Don-vip

Owner: changed from team to vlada@…
Status: newneedinfo

Replying to vlada@…:

with Java 1.7.0_12-ea

Why are you using a development version of a very old snapshot of Java 7? You're clearly looking for trouble. Please try first to update to latest Java (7u67) and tell us if it does solve your problem.

comment:2 Changed 5 years ago by Don-vip

Resolution: duplicate
Status: needinfoclosed

Closed as duplicate of #10024.
Should have read the whole ticket. Doesn't change the fact you should really upgrade your Java version.

comment:3 in reply to:  1 Changed 5 years ago by anonymous

Replying to Don-vip:

Replying to vlada@…:

with Java 1.7.0_12-ea

Why are you using a development version of a very old snapshot of Java 7? You're clearly looking for trouble. Please try first to update to latest Java (7u67) and tell us if it does solve your problem.

Actually, I was using 7u67, it's just java on command line goes to /System rather than /Library (a consequence of the Apple transitioning Java on OS X to Oracle)

comment:4 Changed 5 years ago by Don-vip

OK, much better :) I suppose you need to manually uninstall this old version. Concerning your request I just have fixed the other ticket, next version of JOSM will contain a setting in Look and feel preferences to enable native dialogs. Be aware they have functional limitations (no file filters for example).

comment:5 Changed 5 years ago by anonymous

Yeah, I noticed the other ticket, thanks for that. Going to restart josm soonish (I am starting it via javaws from http) to try it out.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain vlada@….
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.