Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#11819 closed enhancement (fixed)

History dialog not properly showing ways being reversed anymore.

Reported by: rickmastfan67 Owned by: team
Priority: normal Milestone: 15.09
Component: Core Version: latest
Keywords: history Cc: simon04

Description (last modified by rickmastfan67)

Steps to reproduce:

  1. Download any way in the OSM database. (for this ticket, we'll use Way 12060923)
  2. Once way 12060923 is downloaded, select it, and pull up the history (Ctrl+H) for it.
  3. Once the 'History' window has loaded for the way, select the 'Nodes' view.
  4. Now, look at the order of the nodes. n108984387 -> n109118075 -> n109055320
  5. Close the 'History' window.
  6. Reverse the way. (R)
  7. Reopen the 'History' window and go back to the 'Nodes' view.

What happens:
The nodes order has been reversed (n109055320 -> n109118075 -> n108984387) but there is no indication that the way was reversed. You have to be paying attention to the node order because the new 'reversed' order is being shown on the left when it shouldn't be.
JOSM 8701:

What should happen:
The nodes should be shown being reversed like in the past via the color coding like in the past (or at least showing the old order on the left and the new 'reversed' order on the right).
JOSM 7646:

I'm not sure what version broke this, but it's somewhere between r7646 and r8479 at least. I know, that's a big gap, but that's all I know for sure since I don't have the time to do the testing. However, the fix for #6994 ([8219]) might be to blame here.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2015-08-29 01:32:08
Last Changed Author: Klumbumbus
Revision: 8701
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2015-08-28 22:43:26 +0200 (Fri, 28 Aug 2015)
Last Changed Rev: 8701

Identification: JOSM/1.5 (8701 en) Windows 7 64-Bit
Memory Usage: 365 MB / 1820 MB (194 MB allocated, but free)
Java version: 1.7.0_79, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM

Plugins:
- OpeningHoursEditor (31241)
- buildings_tools (31361)
- measurement (31289)
- mirrored_download (31520)
- osmarender (31241)
- reverter (31241)
- turnrestrictions (31241)
- undelete (31241)
- utilsplugin2 (31463)

Attachments (3)

ticket11819___josm7646.png (39.5 KB) - added by rickmastfan67 4 years ago.
ticket11819___josm8701.png (44.3 KB) - added by rickmastfan67 4 years ago.
2015-08-31-190712_825x512_scrot.png (25.5 KB) - added by simon04 4 years ago.

Download all attachments as: .zip

Change History (14)

Changed 4 years ago by rickmastfan67

Attachment: ticket11819___josm7646.png added

Changed 4 years ago by rickmastfan67

Attachment: ticket11819___josm8701.png added

comment:1 Changed 4 years ago by rickmastfan67

Description: modified (diff)

comment:2 Changed 4 years ago by Don-vip

Cc: simon04 added
Milestone: 15.09

comment:3 in reply to:  description Changed 4 years ago by Klumbumbus

Replying to rickmastfan67:

but there is no indication that the way was reversed.

There is. It is the up or down arrow beside the word "Nodes" in the heading of the nodes table.
This is the intended behavior. This way you directly see, that the way was just reversed, while before [8219] you need to manually compare the node ids, to check if nodes were replaced by new ones, or the way was just reversed.

comment:4 Changed 4 years ago by rickmastfan67

Keywords: regression removed

I see this now. Still, the nodes on the left should be the same order as the previous way IMO. Maybe add some text that shows up when you hover over the 'arrow' with your mouse?

Also, maybe when a way is reversed, you could make all the nodes 'yellow' instead to alert the user the way was reversed so they aren't confused? I think that plus the arrows would work the best since I honestly don't think people will notice the 'arrows' since they are so small.

comment:5 Changed 4 years ago by simon04

In 8702/josm:

see #11819 - History dialog: show reversed nodes in yellow, show explanatory tooltip on column header

Changed 4 years ago by simon04

comment:6 Changed 4 years ago by rickmastfan67

That should work perfectly! Thanks for changing that Simon.

comment:7 Changed 4 years ago by simon04

You're welcome :)

comment:8 Changed 4 years ago by Klumbumbus

Priority: majornormal
Resolution: fixed
Status: newclosed
Type: defectenhancement

comment:9 Changed 4 years ago by Don-vip

Someone to reflect these changes to Help/Action/ObjectHistory? :)

comment:10 in reply to:  9 Changed 4 years ago by Klumbumbus

Replying to Don-vip:

Someone to reflect these changes to Help/Action/ObjectHistory? :)

Done.

You can delete https://josm.openstreetmap.de/attachment/wiki/Help/Action/ObjectHistory/history_dialog_nodes_tab_alt1.png (I made a upload mistake)

comment:11 Changed 4 years ago by simon04

Thank you! Deleted.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.