Modify

Opened 4 years ago

Closed 4 years ago

#11810 closed defect (fixed)

Exception in Imagery-XML-Bounds while loading http://josm.openstreetmap.de/maps

Reported by: jcr83 Owned by: Don-vip
Priority: normal Milestone:
Component: Plugin imagery-xml-bounds Version: latest
Keywords: template_report Cc:

Description (last modified by Don-vip)

What steps will reproduce the problem?

  1. Install the Imagery-XML-Bounds
  2. In JOSM, open location http://josm.openstreetmap.de/maps (Ctrl-L)

What is the expected result?

All the imagery limits should be loaded in JOSM.

What happens instead?

Nothing is loaded in JOSM.

Error messages displayed on the console :

Error : java.util.concurrent.ExecutionException: java.lang.NoSuchMethodError: org.openstreetmap.josm.data.imagery.ImageryInfo.getAttributionText(ILorg/openstreetmap/gui/jmapviewer/Coordinate;Lorg/openstreetmap/gui/jmapviewer/Coordinate;)Ljava/lang/String;. Cause : java.lang.NoSuchMethodError: org.openstreetmap.josm.data.imagery.ImageryInfo.getAttributionText(ILorg/openstreetmap/gui/jmapviewer/Coordinate;Lorg/openstreetmap/gui/jmapviewer/Coordinate;)Ljava/lang/String;
java.util.concurrent.ExecutionException: java.lang.NoSuchMethodError: org.openstreetmap.josm.data.imagery.ImageryInfo.getAttributionText(ILorg/openstreetmap/gui/jmapviewer/Coordinate;Lorg/openstreetmap/gui/jmapviewer/Coordinate;)Ljava/lang/String;
	at java.util.concurrent.FutureTask.report(FutureTask.java:122)
	at java.util.concurrent.FutureTask.get(FutureTask.java:188)
	at org.openstreetmap.josm.actions.downloadtasks.PostDownloadHandler.run(PostDownloadHandler.java:71)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
	at java.util.concurrent.FutureTask.run(FutureTask.java:262)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
	at java.lang.Thread.run(Thread.java:745)
Caused by: java.lang.NoSuchMethodError: org.openstreetmap.josm.data.imagery.ImageryInfo.getAttributionText(ILorg/openstreetmap/gui/jmapviewer/Coordinate;Lorg/openstreetmap/gui/jmapviewer/Coordinate;)Ljava/lang/String;
	at org.openstreetmap.josm.plugins.imageryxmlbounds.data.XmlBoundsConverter.convertImagery(XmlBoundsConverter.java:125)
	at org.openstreetmap.josm.plugins.imageryxmlbounds.data.XmlBoundsConverter.convertImageryEntries(XmlBoundsConverter.java:40)
	at org.openstreetmap.josm.plugins.imageryxmlbounds.io.XmlBoundsImporter.parseDataSet(XmlBoundsImporter.java:60)
	at org.openstreetmap.josm.plugins.imageryxmlbounds.io.XmlBoundsImporter.parseDataSet(XmlBoundsImporter.java:35)
	at org.openstreetmap.josm.plugins.imageryxmlbounds.io.JosmServerLocationReader.parseOsm(JosmServerLocationReader.java:31)
	at org.openstreetmap.josm.actions.downloadtasks.DownloadOsmTask$DownloadTask.parseDataSet(DownloadOsmTask.java:306)
	at org.openstreetmap.josm.actions.downloadtasks.DownloadOsmTask$DownloadTask.realRun(DownloadOsmTask.java:314)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:93)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:161)
	... 5 more

Please provide any additional information below. Attach a screenshot if possible.

Build-Date: 2015-08-26 15:00:29
Revision: 8693
Is-Local-Build: true

Identification: JOSM/1.5 (8693 SVN fr) Linux Gentoo/Linux
Memory Usage: 76 MB / 643 MB (28 MB allocated, but free)
Java version: 1.7.0_79, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: icedtea-bin:7.2.5.5-r1

VM arguments: [-Djava.library.path=/lib:/usr/lib]

Plugins:
- PicLayer (31241)
- imagery-xml-bounds (31241)

Last errors/warnings:
- E: java.util.concurrent.ExecutionException: java.lang.NoSuchMethodError: org.openstreetmap.josm.data.imagery.ImageryInfo.getAttributionText(ILorg/openstreetmap/gui/jmapviewer/Coordinate;Lorg/openstreetmap/gui/jmapviewer/Coordinate;)Ljava/lang/String;. Cause : java.lang.NoSuchMethodError: org.openstreetmap.josm.data.imagery.ImageryInfo.getAttributionText(ILorg/openstreetmap/gui/jmapviewer/Coordinate;Lorg/openstreetmap/gui/jmapviewer/Coordinate;)Ljava/lang/String;

Attachments (0)

Change History (2)

comment:1 Changed 4 years ago by Don-vip

Description: modified (diff)

comment:2 Changed 4 years ago by Don-vip

Resolution: fixed
Status: newclosed

Fixed in [o31530:31531].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.