Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#11811 closed defect (fixed)

Crash in reverter plugin when trying to revert CS 33588417

Reported by: Dakon Owned by: Upliner
Priority: normal Milestone:
Component: Plugin reverter Version: tested
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. start JOSM
  2. try to revert CS 33588417

What is the expected result?

All data of the CS should be downloaded.

What happens instead?

Plugin crash.

Please provide any additional information below. Attach a screenshot if possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2015-08-21 23:32:08
Last Changed Author: Don-vip
Revision: 8677
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2015-08-21 22:18:03 +0200 (Fri, 21 Aug 2015)
Last Changed Rev: 8677

Identification: JOSM/1.5 (8677 de) Linux openSUSE 13.1 (Bottle) (x86_64)
Memory Usage: 378 MB / 910 MB (178 MB allocated, but free)
Java version: 1.7.0_85, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: java-1_7_0-openjdk:x86_64-1.7.0.85
Dataset consistency test: No problems found

Plugins:
- FixAddresses (31241)
- OpeningHoursEditor (31241)
- buildings_tools (31361)
- geochat (31241)
- imagery_offset_db (31241)
- jna (31126)
- native_password_manager (31241)
- osmarender (31241)
- pbf (31241)
- poly (31241)
- public_transport (31241)
- reverter (31241)
- terracer (31241)
- turnrestrictions (31241)
- undelete (31241)
- utilsplugin2 (31463)

Last errors/warnings:
- W: New conflict: Conflict [my={Node id=1543121457 version=2 D }, their={Node id=1543121457 version=0 IV lat=52.2525631,lon=9.4190502}]
- W: New conflict: Conflict [my={Node id=1543121453 version=2 D }, their={Node id=1543121453 version=0 IV lat=52.2520557,lon=9.4167078}]
- W: New conflict: Conflict [my={Node id=1543121449 version=2 D }, their={Node id=1543121449 version=0 IV lat=52.2515373,lon=9.4155185}]
- W: New conflict: Conflict [my={Node id=1543121451 version=2 D }, their={Node id=1543121451 version=0 IV lat=52.251791,lon=9.414978}]
- E: java.lang.IllegalStateException: Konflikt mit Element "{Node id=1543121451 version=2 D }" besteht bereits

java.lang.IllegalStateException: Konflikt mit Element "{Node id=1543121451 version=2 D }" besteht bereits
	at org.openstreetmap.josm.data.conflict.ConflictCollection.addConflict(ConflictCollection.java:108)
	at org.openstreetmap.josm.data.conflict.ConflictCollection.add(ConflictCollection.java:123)
	at reverter.DataSetCommandMerger.mergeWay(DataSetCommandMerger.java:123)
	at reverter.DataSetCommandMerger.merge(DataSetCommandMerger.java:173)
	at reverter.DataSetCommandMerger.<init>(DataSetCommandMerger.java:44)
	at reverter.ChangesetReverter.getCommands(ChangesetReverter.java:344)
	at reverter.RevertChangesetTask.realRun(RevertChangesetTask.java:104)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:93)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:161)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
	at java.util.concurrent.FutureTask.run(FutureTask.java:262)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
	at java.lang.Thread.run(Thread.java:745)

Attachments (0)

Change History (3)

comment:1 Changed 4 years ago by simon04

Resolution: fixed
Status: newclosed

comment:2 Changed 4 years ago by simon04

Ticket #9479 has been marked as a duplicate of this ticket.

comment:3 Changed 4 years ago by simon04

Ticket #11875 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Upliner.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.