Modify

Opened 5 years ago

Closed 5 years ago

Last modified 2 years ago

#11629 closed enhancement (fixed)

[Patch] Fixed state errors in selection (rect/lasso) and made them draw on a temporary layer.

Reported by: michael2402 Owned by: team
Priority: normal Milestone: 15.08
Component: Core Version:
Keywords: gsoc Cc:

Description

This is required for the OpenGl plugin and to avoid having the special handling of rect/polygon drawing in NavigateableComponent. By the way, this should fix #10218 and fixes #11094.

Attachments (1)

0003-Fixed-state-errors-in-selection-rect-lasso-and-made-.patch (17.0 KB) - added by michael2402 5 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 5 years ago by Don-vip

Keywords: gsoc added
Milestone: 15.07

comment:2 Changed 5 years ago by bastiK

Resolution: fixed
Status: newclosed

In 8550/josm:

applied #11629 - Fixed state errors in selection (rect/lasso) and made them draw on a temporary layer; added polygon fill effect for lasso selection. (patch by michael2402)

comment:3 Changed 5 years ago by bastiK

Great, I like the new polygon fill in lasso mode!

This very fragile code, so don't be surprised to get bug reports in the next few days. (Let's hope not. :) )

comment:4 Changed 5 years ago by Don-vip

Milestone: 15.0715.08

Milestone renamed

comment:5 Changed 2 years ago by Don-vip

Ticket #10218 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.