Modify

Opened 5 years ago

Closed 17 months ago

#10218 closed defect (duplicate)

Left click selection box doesn't always disappear

Reported by: rickmastfan67 Owned by: team
Priority: minor Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

Steps to reproduce:

  1. Download some data or open a local file.
  2. Hit 's' to active the selection tool.
  3. Left click and hold to make a selection.
  4. While still holding down the left button on your mouse, hit the right click at the same time to have the right click menu show up.
  5. Left click out of the 'right click menu'.

What happens:
The section box that you created with the left click is still on the screen.

What should happen:
The box should disappear right away.

Work around:
If you left click again, the box then disappears, but you shouldn't need to click the left click again. Also, you can 'right click pan' and have the box stay visible till you finally left click again.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2014-07-02 01:34:24
Last Changed Author: Don-vip
Revision: 7281
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2014-07-01 20:31:49 +0200 (Tue, 01 Jul 2014)
Last Changed Rev: 7281

Identification: JOSM/1.5 (7281 en) Windows 7 64-Bit
Memory Usage: 339 MB / 1820 MB (146 MB allocated, but free)
Java version: 1.7.0_55, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
VM arguments: [-Xmx2048M]
Dataset consistency test: No problems found

Plugin: ImageryCache (30416)
Plugin: OpeningHoursEditor (30416)
Plugin: buildings_tools (30485)
Plugin: measurement (30416)
Plugin: mirrored_download (30495)
Plugin: notes (v0.9.2)
Plugin: osmarender (30416)
Plugin: reverter (30436)
Plugin: turnrestrictions (30454)
Plugin: undelete (30416)
Plugin: utilsplugin2 (30460)

Attachments (0)

Change History (2)

comment:1 Changed 5 years ago by Don-vip

Summary: Left click selection box doesn't always disapearLeft click selection box doesn't always disappear

comment:2 Changed 17 months ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #11629.
This has been fixed with r8550.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.