Modify

Opened 5 years ago

Last modified 5 years ago

#11595 reopened enhancement

Elements still marked as changed even if changes were manually removed

Reported by: Dakon Owned by: team
Priority: normal Milestone:
Component: Core Version: tested
Keywords: Cc:

Description

  • download anything
  • add a key
  • manually remove that key (do NOT use "undo")
  • click upload

The selected element is scheduled for upload, even if has the same state as before.

Attachments (0)

Change History (4)

comment:1 Changed 5 years ago by stoecker

Resolution: wontfix
Status: newclosed

JOSM does not track original state, so any changes are changes, also reverting changes. In the first menu you have "Update modified". This can be used to replace such "unchanged changes" with the original state.

comment:2 Changed 5 years ago by simon04

Resolution: wontfix
Status: closedreopened
Type: defectenhancement

I would like to keep this as a – complicated to implement – enhancement. This helps to avoid creating new versions for objects which in fact haven't changed. Often Undo is not applicable since dozens of other operations have been performed in the meantime.

comment:3 Changed 5 years ago by wiktorn

On the other hand, I use this trick/bug sometimes, for example to refresh Nominatim indexing (when for some reason, it got the data wrong).

comment:4 Changed 5 years ago by stoecker

It's not complicated to implement. You simply need to automatically do the "Update modified" before a new upload. But that needs additional time, may result in unexpected behaviour and I never considered that issue of a small number of unnecessary changes important enough to bother the users with the implications of that procedure.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as reopened The owner will remain team.
as The resolution will be set.
to The owner will be changed from team to the specified user.
The owner will change to Dakon
as duplicate The resolution will be set to duplicate.The specified ticket will be cross-referenced with this ticket

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.