Modify

Opened 6 years ago

Closed 6 years ago

#11520 closed defect (duplicate)

NoSuchMethodError in Mapillary plugin

Reported by: philippecasteleyn@… Owned by: nokutu
Priority: normal Milestone:
Component: Plugin mapillary Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. The sequences are visible as connected little green arrows.
  2. I click on a little green arrow.

What is the expected result?

A Mly picture

What happens instead?

No such method error

Please provide any additional information below. Attach a screenshot if possible.

Revision: 8339
Repository Root: http://josm.openstreetmap.de/svn
Relative URL: ^/trunk
Last Changed Author: stoecker
Last Changed Date: 2015-05-07 17:30:43 +0200 (Thu, 07 May 2015)
Build-Date: 2015-05-08 01:31:23
URL: http://josm.openstreetmap.de/svn/trunk
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last Changed Rev: 8339

Identification: JOSM/1.5 (8339 en) Windows 8.1 64-Bit
Memory Usage: 256 MB / 910 MB (73 MB allocated, but free)
Java version: 1.8.0_45, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Dataset consistency test: No problems found

Plugins:
- Mapillary (31196)
- commons-imaging (31181)

Last errors/warnings:
- E: java.lang.NoSuchMethodError: org.openstreetmap.josm.plugins.mapillary.cache.MapillaryCache.cancelOutstandingTasks()V
- E: java.lang.NoSuchMethodError: org.openstreetmap.josm.plugins.mapillary.cache.MapillaryCache.cancelOutstandingTasks()V
- E: java.lang.NoSuchMethodError: org.openstreetmap.josm.plugins.mapillary.cache.MapillaryCache.cancelOutstandingTasks()V
- E: java.lang.NoSuchMethodError: org.openstreetmap.josm.plugins.mapillary.cache.MapillaryCache.cancelOutstandingTasks()V
- E: java.lang.NoSuchMethodError: org.openstreetmap.josm.plugins.mapillary.cache.MapillaryCache.cancelOutstandingTasks()V

java.lang.NoSuchMethodError: org.openstreetmap.josm.plugins.mapillary.cache.MapillaryCache.cancelOutstandingTasks()V
	at org.openstreetmap.josm.plugins.mapillary.MapillaryToggleDialog.updateImage(MapillaryToggleDialog.java:117)
	at org.openstreetmap.josm.plugins.mapillary.MapillaryData.setSelectedImage(MapillaryData.java:156)
	at org.openstreetmap.josm.plugins.mapillary.MapillaryLayer.mouseClicked(MapillaryLayer.java:302)
	at java.awt.AWTEventMulticaster.mouseClicked(Unknown Source)
	at java.awt.AWTEventMulticaster.mouseClicked(Unknown Source)
	at java.awt.AWTEventMulticaster.mouseClicked(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (1)

CaptureJosmMapillary001.PNG (351.4 KB) - added by anonymous 6 years ago.

Download all attachments as: .zip

Change History (4)

Changed 6 years ago by anonymous

Attachment: CaptureJosmMapillary001.PNG added

comment:1 Changed 6 years ago by Don-vip

Component: CorePlugin mapillary
Owner: changed from team to nokutu

comment:2 Changed 6 years ago by Don-vip

Summary: Mapillary pluginNoSuchMethodError in Mapillary plugin

comment:3 Changed 6 years ago by nokutu

Resolution: duplicate
Status: newclosed

Closed as duplicate of #11521.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain nokutu.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.