Modify

Opened 6 years ago

Closed 6 years ago

#11521 closed defect (fixed)

503 Error when using Mapillary plugin

Reported by: escada Owned by: nokutu
Priority: normal Milestone:
Component: Plugin mapillary Version: tested
Keywords: Mapillary Cc:

Description (last modified by Don-vip)

I installed the initial version for the Mapilary plugin. I get to the point that there is a layer showing all sequences in an area together with little icons.
When I click on this layer nothing happens. I see in the console the following stacktrace

java.io.IOException: Server returned HTTP response code: 503 for URL: https://a.mapillary.com/v2/search/s/?client_id=NzNRM2otQkR2SHJzaXJmNmdQWVQ0dzo1YTA2NmNlODhlNWMwOTBm&min_lat=51.097701&min_lon=4.4051743&max_lat=51.1112821&max_lon=4.4192505&page=48&limit=1
java.io.IOException: Server returned HTTP response code: 503 for URL: https://a.mapillary.com/v2/search/s/?client_id=NzNRM2otQkR2SHJzaXJmNmdQWVQ0dzo1YTA2NmNlODhlNWMwOTBm&min_lat=51.097701&min_lon=4.4051743&max_lat=51.1112821&max_lon=4.4192505&page=48&limit=1
	at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1626)
	at sun.net.www.protocol.https.HttpsURLConnectionImpl.getInputStream(HttpsURLConnectionImpl.java:254)
	at java.net.URL.openStream(URL.java:1037)
	at org.openstreetmap.josm.plugins.mapillary.downloads.MapillarySequenceDownloadThread.run(MapillarySequenceDownloadThread.java:47)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
	at java.lang.Thread.run(Thread.java:744)

Attachments (0)

Change History (15)

comment:1 Changed 6 years ago by escada

I just noticed that before the above mentioned problem, I have several

[INFO] IndexedDiskCache - Region [TMS] Cache file root directory: /Users/marcgemis/Library/Caches/JOSM/tms
[INFO] IndexedDiskCache - Region [TMS] Set maxKeySize to: '25000'
[INFO] IndexedDiskCache - Region [TMS] Loaded keys from [TMS], key count: 546; up to 25000 will be available.
[INFO] IndexedDiskCache - Region [TMS] Finished inital consistency check, isOk = true in 2ms.
[INFO] IndexedDiskCache - Region [TMS] Indexed Disk Cache is alive.
[INFO] CompositeCacheConfigurator - No special ElementAttribute class defined for key [jcs.region.Mapillary.elementattributes], using default class.
[INFO] AbstractDoubleLinkedListMemoryCache - initialized MemoryCache for Mapillary
[INFO] CompositeCache - Constructed cache with name [Mapillary] and cache attributes [ useLateral = true, useRemote = true, useDisk = true, maxObjs = 1000, maxSpoolPerRun = -1, diskUsagePattern = UPDATE, spoolChunkSize = 2 ]
java.lang.NoSuchMethodError: org.openstreetmap.josm.plugins.mapillary.cache.MapillaryCache.submit(Lorg/openstreetmap/josm/data/cache/ICachedLoaderListener;Z)V

at org.openstreetmap.josm.plugins.mapillary.MapillaryToggleDialog.updateImage(MapillaryToggleDialog.java:120)
at org.openstreetmap.josm.plugins.mapillary.MapillaryData.setSelectedImage(MapillaryData.java:156)
at org.openstreetmap.josm.plugins.mapillary.MapillaryLayer.mouseClicked(MapillaryLayer.java:301)
at java.awt.AWTEventMulticaster.mouseClicked(AWTEventMulticaster.java:270)
at java.awt.Component.processMouseEvent(Component.java:6508)
at javax.swing.JComponent.processMouseEvent(JComponent.java:3320)
at java.awt.Component.processEvent(Component.java:6270)
at java.awt.Container.processEvent(Container.java:2229)
at java.awt.Component.dispatchEventImpl(Component.java:4861)
at java.awt.Container.dispatchEventImpl(Container.java:2287)
at java.awt.Component.dispatchEvent(Component.java:4687)
at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4832)
at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4501)
at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4422)
at java.awt.Container.dispatchEventImpl(Container.java:2273)
at java.awt.Window.dispatchEventImpl(Window.java:2719)
at java.awt.Component.dispatchEvent(Component.java:4687)
at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:735)
at java.awt.EventQueue.access$200(EventQueue.java:103)
at java.awt.EventQueue$3.run(EventQueue.java:694)
at java.awt.EventQueue$3.run(EventQueue.java:692)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:87)
at java.awt.EventQueue$4.run(EventQueue.java:708)
at java.awt.EventQueue$4.run(EventQueue.java:706)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:705)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)

comment:2 Changed 6 years ago by nokutu

Owner: changed from team to nokutu
Status: newassigned

comment:3 Changed 6 years ago by nokutu

Resolution: fixed
Status: assignedclosed

comment:4 Changed 6 years ago by nokutu

It should be fixed.

comment:5 Changed 6 years ago by escada

Resolution: fixed
Status: closedreopened

I still get exceptions, but different ones now:

[INFO] CompositeCache - Constructed cache with name [Mapillary] and cache attributes [ useLateral = true, useRemote = true, useDisk = true, maxObjs = 1000, maxSpoolPerRun = -1, diskUsagePattern = UPDATE, spoolChunkSize = 2 ]
FOUT: java.lang.IndexOutOfBoundsException: Index: 20, Size: 20
java.lang.IndexOutOfBoundsException: Index: 20, Size: 20

at java.util.ArrayList.rangeCheck(ArrayList.java:635)
at java.util.ArrayList.get(ArrayList.java:411)
at java.util.Collections$UnmodifiableList.get(Collections.java:1211)
at org.glassfish.json.JsonArrayBuilderImpl$JsonArrayImpl.getJsonArray(JsonArrayBuilderImpl.java:179)
at org.openstreetmap.josm.plugins.mapillary.downloads.MapillarySequenceDownloadThread.run(MapillarySequenceDownloadThread.java:66)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
at java.lang.Thread.run(Thread.java:744)

java.lang.NoSuchMethodError: org.openstreetmap.josm.plugins.mapillary.cache.MapillaryCache.submit(Lorg/openstreetmap/josm/data/cache/ICachedLoaderListener;Z)V

at org.openstreetmap.josm.plugins.mapillary.MapillaryToggleDialog.updateImage(MapillaryToggleDialog.java:120)
at org.openstreetmap.josm.plugins.mapillary.MapillaryData.setSelectedImage(MapillaryData.java:156)
at org.openstreetmap.josm.plugins.mapillary.MapillaryLayer.mouseClicked(MapillaryLayer.java:301)
at java.awt.AWTEventMulticaster.mouseClicked(AWTEventMulticaster.java:270)
at java.awt.Component.processMouseEvent(Component.java:6508)
at javax.swing.JComponent.processMouseEvent(JComponent.java:3320)
at java.awt.Component.processEvent(Component.java:6270)
at java.awt.Container.processEvent(Container.java:2229)
at java.awt.Component.dispatchEventImpl(Component.java:4861)
at java.awt.Container.dispatchEventImpl(Container.java:2287)
at java.awt.Component.dispatchEvent(Component.java:4687)
at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4832)
at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4501)
at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4422)
at java.awt.Container.dispatchEventImpl(Container.java:2273)
at java.awt.Window.dispatchEventImpl(Window.java:2719)
at java.awt.Component.dispatchEvent(Component.java:4687)
at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:735)
at java.awt.EventQueue.access$200(EventQueue.java:103)
at java.awt.EventQueue$3.run(EventQueue.java:694)
at java.awt.EventQueue$3.run(EventQueue.java:692)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:87)
at java.awt.EventQueue$4.run(EventQueue.java:708)
at java.awt.EventQueue$4.run(EventQueue.java:706)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:705)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)

java.lang.NoSuchMethodError: org.openstreetmap.josm.plugins.mapillary.cache.MapillaryCache.cancelOutstandingTasks()V

at org.openstreetmap.josm.plugins.mapillary.MapillaryToggleDialog.updateImage(MapillaryToggleDialog.java:117)
at org.openstreetmap.josm.plugins.mapillary.MapillaryData.setSelectedImage(MapillaryData.java:156)
at org.openstreetmap.josm.plugins.mapillary.MapillaryLayer.mouseClicked(MapillaryLayer.java:301)
at java.awt.AWTEventMulticaster.mouseClicked(AWTEventMulticaster.java:270)
at java.awt.Component.processMouseEvent(Component.java:6508)
at javax.swing.JComponent.processMouseEvent(JComponent.java:3320)
at java.awt.Component.processEvent(Component.java:6270)
at java.awt.Container.processEvent(Container.java:2229)
at java.awt.Component.dispatchEventImpl(Component.java:4861)
at java.awt.Container.dispatchEventImpl(Container.java:2287)
at java.awt.Component.dispatchEvent(Component.java:4687)
at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4832)
at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4501)
at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4422)
at java.awt.Container.dispatchEventImpl(Container.java:2273)
at java.awt.Window.dispatchEventImpl(Window.java:2719)
at java.awt.Component.dispatchEvent(Component.java:4687)
at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:735)
at java.awt.EventQueue.access$200(EventQueue.java:103)
at java.awt.EventQueue$3.run(EventQueue.java:694)
at java.awt.EventQueue$3.run(EventQueue.java:692)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:87)
at java.awt.EventQueue$4.run(EventQueue.java:708)
at java.awt.EventQueue$4.run(EventQueue.java:706)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:705)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)

comment:6 Changed 6 years ago by nokutu

What OSM area are you downloading, could you paste here the link?

comment:7 Changed 6 years ago by escada

A small rectangle around Eikenstraat in this http://www.openstreetmap.org/relation/58865#map=15/51.1051/4.4136&layers=N area
so I basicly only download that street. I tried clicking on one of the icons near "Eugeen Roelandtsstraat"

comment:8 Changed 6 years ago by Don-vip

Component: PluginPlugin mapillary

comment:9 Changed 6 years ago by nokutu

The no method error is because of the JOSM version. I'm developing in latest and the submit method has changed. I've created a ticket and until it is solved I will try to create a simple bypass.

comment:10 Changed 6 years ago by nokutu

Ticket #11520 has been marked as a duplicate of this ticket.

comment:11 in reply to:  9 Changed 6 years ago by wiktorn

Replying to nokutu:

The no method error is because of the JOSM version. I'm developing in latest and the submit method has changed. I've created a ticket and until it is solved I will try to create a simple bypass.

You should bump requiremnts:

<property name="plugin.main.version" value="8433"/>

in your build.xml, so at least your incompaibility will be detected while loading of JOSM plugin.

comment:12 Changed 6 years ago by Don-vip

Description: modified (diff)

comment:13 Changed 6 years ago by escada

I also tried a small rectangle around Prins Boudewijnlaan : http://www.openstreetmap.org/relation/58865#map=17/51.15471/4.43214&layers=N
Just the part between Drie Eikenstraat en Heihoefseweg.
The sequence is drawn, as well as the icons, but as soon as I click one of the icons, I get the

java.lang.NoSuchMethodError: org.openstreetmap.josm.plugins.mapillary.cache.MapillaryCache.submit(Lorg/openstreetmap/josm/data/cache/ICachedLoaderListener;Z)V

error

comment:14 Changed 6 years ago by nokutu

Ticket #11525 has been marked as a duplicate of this ticket.

comment:15 Changed 6 years ago by nokutu

Resolution: fixed
Status: reopenedclosed

I close this, using latest version should solve all this problems.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain nokutu.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.