Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#11518 closed defect (fixed)

TurnRestrictions plugin conflicts with CADTools, LaneConnector and ContourOverlappingMerge

Reported by: anonymous Owned by: team
Priority: normal Milestone: 15.05
Component: Core Version:
Keywords: Cc:

Description

Revision: 8339
Repository Root: http://josm.openstreetmap.de/svn
Relative URL: ^/trunk
Last Changed Author: stoecker
Last Changed Date: 2015-05-07 17:30:43 +0200 (Thu, 07 May 2015)
Build-Date: 2015-05-08 01:31:23
URL: http://josm.openstreetmap.de/svn/trunk
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last Changed Rev: 8339

Identification: JOSM/1.5 (8339 pt_BR) Windows 7 32-Bit
Memory Usage: 131 MB / 989 MB (54 MB allocated, but free)
Java version: 1.8.0_40, Oracle Corporation, Java HotSpot(TM) Client VM
Dataset consistency test: No problems found

Plugins:
- BuildingGeneralization (UNKNOWN)
- CADTools (1003)
- ColorPlugin (1414145445)
- CommandLine (30892)
- ContourOverlappingMerge (1000)
- Create_grid_of_ways (30892)
- DirectDownload (30892)
- DirectUpload (30892)
- DxfImport (UNKNOWN)
- FastDraw (30892)
- FixAddresses (30892)
- HouseNumberTaggingTool (30892)
- ImageWayPoint (30892)
- OpeningHoursEditor (30962)
- PicLayer (31114)
- Remove.redundant.points (1000)
- RoadSigns (30977)
- alignways (30892)
- buildings_tools (31120)
- colorscheme (30892)
- conflation (0.1.7)
- contourmerge (1013)
- download_along (30892)
- fieldpapers (b49dadd)
- geochat (31056)
- imagery-xml-bounds (31019)
- imagery_offset_db (31056)
- imageryadjust (30892)
- jna (30892)
- jts (31002)
- kendzi3d (1.0.184)
- kendzi3d-jogl (37)
- log4j (30892)
- mapdust (30892)
- matsim (v0.4.0)
- measurement (30892)
- merge-overlap (30988)
- namemanager (30892)
- pbf (31010)
- pdfimport (30892)
- photo_geotagging (30967)
- photoadjust (30964)
- poly (31056)
- print (30892)
- public_transport (31114)
- reltoolbox (31056)
- reverter (31120)
- routes (30892)
- routing (30892)
- scoutsigns (46)
- tag2link (31066)
- tageditor (30892)
- terracer (30892)
- turnlanes (30892)
- turnrestrictions (31034)
- undelete (30892)
- utilsplugin2 (31153)
- videomapping (30892)
- walkingpapers (31114)
- waydownloader (30892)
- wikipedia (31114)
- wms-turbo-challenge2 (30892)

Last errors/warnings:
- W: PluginException: Arquivo jar inválido 'C:\Users\Deni\AppData\Roaming\JOSM\plugins\areaselector.jar.new'
- W: Falha ao digitalizar o arquivo 'areaselector.jar.new' para informações do plugin. Ignorando.
- E: org.openstreetmap.josm.plugins.PluginException: Um erro ocorreu com o plugin turnrestrictions. Causa: java.lang.reflect.InvocationTargetException. Causa: java.lang.NoClassDefFoundError: org/openstreetmap/josm/gui/JMultilineLabel. Causa: java.lang.ClassNotFoundException: org.openstreetmap.josm.gui.JMultilineLabel
- W: PluginException: Arquivo jar inválido 'C:\Users\Deni\AppData\Roaming\JOSM\plugins\areaselector.jar.new'
- W: Falha ao digitalizar o arquivo 'areaselector.jar.new' para informações do plugin. Ignorando.

org.openstreetmap.josm.plugins.PluginException: Um erro ocorreu com o plugin turnrestrictions
	at org.openstreetmap.josm.plugins.PluginProxy.mapFrameInitialized(PluginProxy.java:34)
	at org.openstreetmap.josm.Main.setMapFrame(Main.java:507)
	at org.openstreetmap.josm.Main.createMapFrame(Main.java:760)
	at org.openstreetmap.josm.Main.addLayer(Main.java:747)
	at org.openstreetmap.josm.Main.addLayer(Main.java:732)
	at org.openstreetmap.josm.Main.addLayer(Main.java:719)
	at org.openstreetmap.josm.actions.NewAction.actionPerformed(NewAction.java:32)
	at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
	at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
	at javax.swing.AbstractButton.doClick(Unknown Source)
	at javax.swing.plaf.basic.BasicMenuItemUI.doClick(Unknown Source)
	at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(Unknown Source)
	at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)
Caused by: java.lang.reflect.InvocationTargetException
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
	at java.lang.reflect.Method.invoke(Unknown Source)
	at org.openstreetmap.josm.plugins.PluginProxy.mapFrameInitialized(PluginProxy.java:30)
	... 45 more
Caused by: java.lang.NoClassDefFoundError: org/openstreetmap/josm/gui/JMultilineLabel
	at org.openstreetmap.josm.plugins.turnrestrictions.list.TurnRestrictionsInDatasetView.build(TurnRestrictionsInDatasetView.java:27)
	at org.openstreetmap.josm.plugins.turnrestrictions.list.TurnRestrictionsInDatasetView.<init>(TurnRestrictionsInDatasetView.java:47)
	at org.openstreetmap.josm.plugins.turnrestrictions.list.TurnRestrictionsListDialog.build(TurnRestrictionsListDialog.java:124)
	at org.openstreetmap.josm.plugins.turnrestrictions.list.TurnRestrictionsListDialog.<init>(TurnRestrictionsListDialog.java:152)
	at org.openstreetmap.josm.plugins.turnrestrictions.TurnRestrictionsPlugin.mapFrameInitialized(TurnRestrictionsPlugin.java:26)
	... 50 more
Caused by: java.lang.ClassNotFoundException: org.openstreetmap.josm.gui.JMultilineLabel
	at java.net.URLClassLoader.findClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	... 55 more

Attachments (0)

Change History (3)

comment:1 Changed 4 years ago by Don-vip

Component: Plugin turnrestrictionsCore
Milestone: 15.05
Summary: Bug TurnRestrictionsTurnRestrictions plugin conflicts with CADTools, LaneConnector and ContourOverlappingMerge

This is caused by the presence of erroneous plugins (in your case CADTools and ContourOverlappingMerge).
You must uninstall them. I'm going to make JOSM smarter about it, see https://lists.openstreetmap.org/pipermail/josm-dev/2015-June/007371.html

comment:2 Changed 4 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 8453/josm:

fix #11518 - ban plugins CADTools, LaneConnector and ContourOverlappingMerge

comment:3 Changed 4 years ago by Don-vip

In 8944/josm:

see #11468, #11518: missed another dummy plugin: RemoveRedundantPoints ==> unmaintained

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.