Modify

Opened 4 years ago

Closed 4 years ago

#11517 closed defect (duplicate)

Simple error !!

Reported by: geofrizz@… Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Update JOSM to the latest snapshot
  2. Update plugins
  3. Help/About

What is the expected result?

The "About" window

What happens instead?

Error message with a link to this page !!! :-)

Please provide any additional information below. Attach a screenshot if possible.

After restart of JOSM all ok, no error message.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2015-06-02 12:06:24
Last Changed Author: Don-vip
Revision: 8441
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2015-06-02 14:03:31 +0200 (Tue, 02 Jun 2015)
Last Changed Rev: 8441

Identification: JOSM/1.5 (8441 en) Linux Ubuntu 14.04.2 LTS
Memory Usage: 519 MB / 2656 MB (263 MB allocated, but free)
Java version: 1.7.0_79, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u79-2.5.5-0ubuntu0.14.04.2
VM arguments: [-Djosm.restart=true, -Djosm.home=/home/geofrizz/.josm-latest, -Djava.net.useSystemProxies=true]

Plugins:
- BuildingGeneralization (UNKNOWN)
- FixAddresses (30892)
- buildings_tools (31120)
- imagery_offset_db (31056)
- measurement (30892)
- merge-overlap (30988)
- pbf (31010)
- reltoolbox (31056)
- todo (29154)
- undelete (30892)
- utilsplugin2 (31153)
- waydownloader (30892)

Last errors/warnings:
- E: Failed to locate image 'icons/hot_camping.n.24.png'
- W: Could not get presets icon icons/hot_camping.n.24.png
- E: Failed to locate image ''
- W: Could not get presets icon 
- E: sun.awt.X11.XException: Cannot write XdndAware property

sun.awt.X11.XException: Cannot write XdndAware property
	at sun.awt.X11.XDnDDropTargetProtocol.registerDropTarget(XDnDDropTargetProtocol.java:97)
	at sun.awt.X11.XDropTargetRegistry.registerDropSite(XDropTargetRegistry.java:571)
	at sun.awt.X11.XWindowPeer.addDropTarget(XWindowPeer.java:1932)
	at sun.awt.X11.XComponentPeer.addDropTarget(XComponentPeer.java:1386)
	at java.awt.dnd.DropTarget.addNotify(DropTarget.java:509)
	at java.awt.Component.addNotify(Component.java:6924)
	at java.awt.Container.addNotify(Container.java:2758)
	at javax.swing.JComponent.addNotify(JComponent.java:4744)
	at java.awt.Container.addNotify(Container.java:2769)
	at javax.swing.JComponent.addNotify(JComponent.java:4744)
	at java.awt.Container.addNotify(Container.java:2769)
	at javax.swing.JComponent.addNotify(JComponent.java:4744)
	at java.awt.Container.addNotify(Container.java:2769)
	at javax.swing.JComponent.addNotify(JComponent.java:4744)
	at java.awt.Container.addNotify(Container.java:2769)
	at javax.swing.JComponent.addNotify(JComponent.java:4744)
	at java.awt.Container.addNotify(Container.java:2769)
	at javax.swing.JComponent.addNotify(JComponent.java:4744)
	at java.awt.Container.addNotify(Container.java:2769)
	at javax.swing.JComponent.addNotify(JComponent.java:4744)
	at java.awt.Container.addNotify(Container.java:2769)
	at javax.swing.JComponent.addNotify(JComponent.java:4744)
	at java.awt.Container.addNotify(Container.java:2769)
	at javax.swing.JComponent.addNotify(JComponent.java:4744)
	at java.awt.Container.addNotify(Container.java:2769)
	at javax.swing.JComponent.addNotify(JComponent.java:4744)
	at java.awt.Container.addNotify(Container.java:2769)
	at javax.swing.JComponent.addNotify(JComponent.java:4744)
	at javax.swing.JRootPane.addNotify(JRootPane.java:756)
	at java.awt.Container.addNotify(Container.java:2769)
	at java.awt.Window.addNotify(Window.java:770)
	at java.awt.Dialog.addNotify(Dialog.java:760)
	at java.awt.Window.pack(Window.java:807)
	at javax.swing.JOptionPane.initDialog(JOptionPane.java:987)
	at javax.swing.JOptionPane.createDialog(JOptionPane.java:968)
	at javax.swing.JOptionPane.showOptionDialog(JOptionPane.java:867)
	at javax.swing.JOptionPane.showMessageDialog(JOptionPane.java:667)
	at org.openstreetmap.josm.actions.AboutAction.actionPerformed(AboutAction.java:107)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2018)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2341)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:402)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259)
	at javax.swing.AbstractButton.doClick(AbstractButton.java:376)
	at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:833)
	at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:877)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:289)
	at java.awt.Component.processMouseEvent(Component.java:6516)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3312)
	at java.awt.Component.processEvent(Component.java:6281)
	at java.awt.Container.processEvent(Container.java:2229)
	at java.awt.Component.dispatchEventImpl(Component.java:4872)
	at java.awt.Container.dispatchEventImpl(Container.java:2287)
	at java.awt.Component.dispatchEvent(Component.java:4698)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4832)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4492)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4422)
	at java.awt.Container.dispatchEventImpl(Container.java:2273)
	at java.awt.Window.dispatchEventImpl(Window.java:2719)
	at java.awt.Component.dispatchEvent(Component.java:4698)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:747)
	at java.awt.EventQueue.access$300(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:706)
	at java.awt.EventQueue$3.run(EventQueue.java:704)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:87)
	at java.awt.EventQueue$4.run(EventQueue.java:720)
	at java.awt.EventQueue$4.run(EventQueue.java:718)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:717)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
...<snip>...

Attachments (0)

Change History (1)

comment:1 Changed 4 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #9771.
This is a known bug of Java, please update to Java 8.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.