Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#11456 closed defect (fixed)

Bing capture date missing

Reported by: anonymous Owned by: wiktorn
Priority: normal Milestone: 15.05
Component: Core imagery Version: latest
Keywords: bing regression Cc:

Description

The Bing capture date (X-VE-TILEMETA-CaptureDatesRange) is not displayed any more, if I select "Show Tile Info", old JOSM versions still show this information.

Attachments (4)

Kachelinformationen1.png (38.6 KB) - added by Klumbumbus 4 years ago.
Kachelinformationen2.png (30.8 KB) - added by Klumbumbus 4 years ago.
Kachelinformationen3.png (36.7 KB) - added by Klumbumbus 4 years ago.
07.gif (1.5 MB) - added by Klumbumbus 4 years ago.

Download all attachments as: .zip

Change History (24)

comment:1 Changed 4 years ago by rickmastfan67

Component: CoreCore imagery
Version: latest

I just noticed this as well. That was very helpful to have.

I'll do some testing to see when it was last working.

comment:2 in reply to:  1 Changed 4 years ago by wiktorn

Replying to rickmastfan67:

I just noticed this as well. That was very helpful to have.

I'll do some testing to see when it was last working.

No need. It was an innocent victim of caching mechanism rewrite.

comment:3 Changed 4 years ago by wiktorn

Owner: changed from team to wiktorn
Status: newassigned

comment:4 Changed 4 years ago by Don-vip

Keywords: bing regression added
Milestone: 15.05

comment:5 Changed 4 years ago by wiktorn

Last edited 4 years ago by wiktorn (previous) (diff)

comment:6 Changed 4 years ago by wiktorn

Owner: changed from wiktorn to anonymous
Status: assignedneedinfo

comment:7 Changed 4 years ago by wiktorn

Owner: changed from anonymous to wiktorn
Status: needinfoassigned

comment:8 Changed 4 years ago by wiktorn

Resolution: fixed
Status: assignedclosed

In 8418/josm, in [o31142]:

Add posibility to display HTTP headers in Show Tile Info dialog. Closes #11456

Last edited 4 years ago by wiktorn (previous) (diff)

comment:9 Changed 4 years ago by stoecker

Please don't forget the Javadocs for new functions (including @since). Also for privates.

comment:10 Changed 4 years ago by wiktorn

In 8420/josm:

Java docs for @8418, addresses #11456

comment:11 Changed 4 years ago by anonymous

Thank you very much for the fast response and implementation!

comment:12 Changed 4 years ago by wiktorn

Ticket #11470 has been marked as a duplicate of this ticket.

Changed 4 years ago by Klumbumbus

Attachment: Kachelinformationen1.png added

Changed 4 years ago by Klumbumbus

Attachment: Kachelinformationen2.png added

Changed 4 years ago by Klumbumbus

Attachment: Kachelinformationen3.png added

comment:13 Changed 4 years ago by Klumbumbus

Resolution: fixed
Status: closedreopened

The capture date is not displayed always. I do not really know how to reproduce, but, sometimes I get different popups with less information. If I click again at the same tile, then to full info is shown. I already cleared tile cache with the last entry of the right click menu.



Revision: 8481
Repository Root: http://josm.openstreetmap.de/svn
Relative URL: ^/trunk
Last Changed Author: akks
Last Changed Date: 2015-06-08 13:14:03 +0200 (Mon, 08 Jun 2015)
Build-Date: 2015-06-08 22:45:00
URL: http://josm.openstreetmap.de/svn/trunk
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last Changed Rev: 8481

Identification: JOSM/1.5 (8481 de) Windows 7 32-Bit
Memory Usage: 439 MB / 742 MB (214 MB allocated, but free)
Java version: 1.8.0_45, Oracle Corporation, Java HotSpot(TM) Client VM
VM arguments: [-Djava.security.manager, -Djava.security.policy=file:C:\Program Files\Java\jre1.8.0_45\lib\security\javaws.policy, -DtrustProxy=true, -Djnlpx.home=<java.home>\bin, -Djnlpx.origFilenameArg=C:\Program Files\josm-latest-bla.jnlp, -Djnlpx.remove=true, -Djava.util.Arrays.useLegacyMergeSort=true, -Djnlpx.heapsize=256m,768m, -Djnlpx.splashport=59126, -Djnlpx.jvm=<java.home>\bin\javaw.exe, -Djnlpx.vmargs=LURqYXZhLnV0aWwuQXJyYXlzLnVzZUxlZ2FjeU1lcmdlU29ydD10cnVlAA==]
Dataset consistency test: No problems found
Last edited 4 years ago by Klumbumbus (previous) (diff)

Changed 4 years ago by Klumbumbus

Attachment: 07.gif added

comment:14 Changed 4 years ago by Klumbumbus

The version with only 4 lines is reproducible if you click fast and the tile (or all displayed tiles?) are not yet full loaded. See attached gif. I don't know if this the intended behaviour.

comment:15 in reply to:  14 Changed 4 years ago by wiktorn

Replying to Klumbumbus:

The version with only 4 lines is reproducible if you click fast and the tile (or all displayed tiles?) are not yet full loaded. See attached gif. I don't know if this the intended behaviour.

This is intended behaviour, I can't tell any more about the tile before it's loaded.

Though missing capture date is something harder. If you've already cleared the cache, all ways I tried to reproduce it failed.

comment:16 Changed 4 years ago by Klumbumbus

Resolution: fixed
Status: reopenedclosed

I cannot reproduce the missing date anymore (maybe it was only before I cleared the cache, I'm not sure anymore). There was someone else with the same problem in the wiki http://forum.openstreetmap.org/viewtopic.php?pid=509048, but cache clearing fixed it for him. So would say it is fixed.

comment:17 Changed 4 years ago by mapwitch

I have the mystery effect that the tile info doesn't show the "capture-date" constantly. See topic in the OSM forum (http://forum.openstreetmap.org/viewtopic.php?id=31223)

The tile cache clearing has helped once. But after restarting JOSM the next day the problem occurs again.

comment:18 in reply to:  17 ; Changed 4 years ago by mapwitch

Replying to mapwitch:

The tile cache clearing has helped once. But after restarting JOSM the next day the problem occurs again.

And now tile cache clearing gives no effect... :-(

comment:19 in reply to:  18 ; Changed 4 years ago by wiktorn

Replying to mapwitch:

Replying to mapwitch:

The tile cache clearing has helped once. But after restarting JOSM the next day the problem occurs again.

And now tile cache clearing gives no effect... :-(

Are you sure you are still using josm-latest version?

If yes, can you copy the tile url from tile info dialog?

comment:20 in reply to:  19 Changed 4 years ago by anonymous

Replying to wiktorn:

Replying to mapwitch:

Replying to mapwitch:

The tile cache clearing has helped once. But after restarting JOSM the next day the problem occurs again.

And now tile cache clearing gives no effect... :-(

Are you sure you are still using josm-latest version?

Yes I do.

While testing around a lot yesterday the tile info changes sometimes. First the capture date was shown in the last line, then it was missing again, finally it appears above the expirationTime. Deletion of the file bing.attribution.xml in C:\Users\Monika\AppData\Local\JOSM\cache for two times has helped.

Today it seems to be stable. But I've no idea about the causal links...

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain wiktorn.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.