Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#11457 closed defect (fixed)

Cannot import zip files using JosmRemote for OpenData plugin

Reported by: StefanB Owned by: team
Priority: normal Milestone: 15.05
Component: Core Version:
Keywords: template_report shapefile shp zip Cc:

Description (last modified by StefanB)

What steps will reproduce the problem?

  1. Call JOSM remote plugin http://127.0.0.1:8111/import?url=http%3A%2F%2Fraba.openstreetmap.si%2FRabaSplits_20150331_EPSG4326%2Fraba49dissJosm.zip
  1. Observe the JOSM console logging
    INFO: RemoteControl received: GET /import?url=http%3A%2F%2Fraba.openstreetmap.si%2FRabaSplits_20150331_EPSG4326%2Fraba49dissJosm.zip HTTP/1.1
    
  1. See the "The following download tasks accept the URL patterns shown:" dialog http://i.imgur.com/kFsc6ta.png

What is the expected result?

File should be imported using OpenData plugin.

What happens instead?

Error dialog gets shown, because URL (*.zip) doesn't match any predefined pattern.

Please provide any additional information below. Attach a screenshot if possible.

File is ok, as it opens nicely if downloaded using browser from http://raba.openstreetmap.si/RabaSplits_20150331_EPSG4326/raba49dissJosm.zip to disk and dragged into JOSM.

Revision: 8339
Repository Root: http://josm.openstreetmap.de/svn
Relative URL: ^/trunk
Last Changed Author: stoecker
Last Changed Date: 2015-05-07 17:30:43 +0200 (Thu, 07 May 2015)
Build-Date: 2015-05-08 01:31:23
URL: http://josm.openstreetmap.de/svn/trunk
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last Changed Rev: 8339

Identification: JOSM/1.5 (8339 en) Windows 7 64-Bit
Memory Usage: 839 MB / 3598 MB (312 MB allocated, but free)
Java version: 1.8.0_25, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
VM arguments: [-Djava.security.manager, -Djava.security.policy=file:C:\Program Files\Java\jre1.8.0_25\lib\security\javaws.policy, -DtrustProxy=true, -Djnlpx.home=<java.home>\bin, -Djnlpx.origFilenameArg=C:\Users\stefan\AppData\LocalLow\Sun\Java\Deployment\cache\6.0\56\1ee8cfb8-5fdcb48b, -Djnlpx.remove=false, -Djava.util.Arrays.useLegacyMergeSort=true, -Djnlpx.splashport=50914, -Djnlp.application.href=https://josm.openstreetmap.de/download/josm.jnlp, -Djnlpx.jvm=<java.home>\bin\javaw.exe, -Djnlpx.vmargs=LURqYXZhLnV0aWwuQXJyYXlzLnVzZUxlZ2FjeU1lcmdlU29ydD10cnVlAC1Eam5scC5hcHBsaWNhdGlvbi5ocmVmPWh0dHBzOi8vam9zbS5vcGVuc3RyZWV0bWFwLmRlL2Rvd25sb2FkL2pvc20uam5scAA=]
Dataset consistency test: No problems found

Plugins:
- SimplifyArea (30962)
- geotools (31068)
- jts (31002)
- kendzi3d (1.0.184)
- kendzi3d-jogl (37)
- log4j (30892)
- opendata (31116)
- reverter (31120)
- todo (29154)
- utilsplugin2 (31120)

Same happens with revision 8395.
It seems that it was caused by recent changes in http://josm.openstreetmap.de/browser/josm/trunk/src/org/openstreetmap/josm/actions/downloadtasks

Attachments (0)

Change History (5)

comment:1 Changed 5 years ago by StefanB

Description: modified (diff)

comment:2 Changed 5 years ago by Don-vip

Component: Plugin opendataCore
Milestone: 15.05
Owner: changed from Don-vip to team

comment:3 Changed 5 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 8400/josm:

fix #11457 - use global action to benefit from custom download tasks in import handler

comment:4 Changed 5 years ago by StefanB

Thanks, I will test it first thing in the morning.

Alternatively we could name the files as *.shp.zip or so, but that wouldn't match any listed pattern either.

comment:5 Changed 5 years ago by StefanB

Confirming that it works nicely now with build 8401.
Thank you!

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.