Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#11441 closed defect (fixed)

NPE when clicking on Imagery/MapQuest aerial

Reported by: anonymous Owned by: The111
Priority: normal Milestone:
Component: JMapViewer Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Clicked on Imagery/MapQuest aerial and immediate crash/file bug request
  2. Using JOSM-latest downloaded 12 hours ago

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2015-05-16 01:31:09
Last Changed Author: Don-vip
Revision: 8362
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2015-05-16 02:41:56 +0200 (Sat, 16 May 2015)
Last Changed Rev: 8362

Identification: JOSM/1.5 (8362 en_AU) Linux Ubuntu 14.04.2 LTS
Memory Usage: 150 MB / 910 MB (75 MB allocated, but free)
Java version: 1.7.0_79, Oracle Corporation, OpenJDK Server VM
Java package: openjdk-7-jre:i386-7u79-2.5.5-0ubuntu0.14.04.2
Dataset consistency test: No problems found


Last errors/warnings:
- E: java.lang.NullPointerException
- E: java.lang.NullPointerException
- E: java.lang.NullPointerException
- E: java.lang.NullPointerException
- E: java.lang.NullPointerException

java.lang.NullPointerException
	at org.openstreetmap.gui.jmapviewer.tilesources.AbstractTMSTileSource.isNoTileAtZoom(AbstractTMSTileSource.java:139)
	at org.openstreetmap.josm.data.imagery.TMSCachedTileLoaderJob.handleNotFound(TMSCachedTileLoaderJob.java:328)
	at org.openstreetmap.josm.data.cache.JCSCachedTileLoaderJob.loadObject(JCSCachedTileLoaderJob.java:385)
	at org.openstreetmap.josm.data.cache.JCSCachedTileLoaderJob.run(JCSCachedTileLoaderJob.java:252)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
	at java.lang.Thread.run(Thread.java:745)

Attachments (0)

Change History (3)

comment:1 Changed 4 years ago by Don-vip

Component: CoreJMapViewer
Owner: changed from team to The111
Summary: Bug when clicking on Imagery/MapQuest aerialNPE when clicking on Imagery/MapQuest aerial

comment:2 Changed 4 years ago by Don-vip

Resolution: fixed
Status: newclosed

Fixed in [o31133].

comment:3 Changed 4 years ago by rickmastfan67

Ticket #11465 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain The111.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.