Modify

Opened 8 years ago

Closed 8 years ago

#11465 closed defect (duplicate)

JOSM 8354 crashed with smth about TMSTileSource

Reported by: Zverikk Owned by: team
Priority: normal Milestone:
Component: Core Version: tested
Keywords: Cc:

Description

A report from NetWorkKido user:
http://forum.openstreetmap.org/viewtopic.php?pid=504580#p504580

Revision: 8354
Repository Root: http://josm.openstreetmap.de/svn
Relative URL: ^/trunk
Last Changed Author: Don-vip
Last Changed Date: 2015-05-14 23:44:36 +0200 (Thu, 14 May 2015)
Build-Date: 2015-05-15 01:31:26
URL: http://josm.openstreetmap.de/svn/trunk
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last Changed Rev: 8354

Identification: JOSM/1.5 (8354 ru) Windows 7 32-Bit
Memory Usage: 247 MB / 247 MB (80 MB allocated, but free)
Java version: 1.8.0_45, Oracle Corporation, Java HotSpot(TM) Client VM
Dataset consistency test: No problems found

Plugins:
- OpeningHoursEditor (30962)
- PicLayer (31114)
- buildings_tools (31120)
- imagery_offset_db (31056)
- poly (31056)
- reltoolbox (31056)
- reverter (31120)
- turnrestrictions (31034)
- utilsplugin2 (31120)

Last errors/warnings:
- W: Cache attributes are null
- W: Cache attributes are null
- W: Cache attributes are null
- W: Cache attributes are null
- W: Cache attributes are null

java.lang.NullPointerException
	at org.openstreetmap.gui.jmapviewer.tilesources.AbstractTMSTileSource.isNoTileAtZoom(AbstractTMSTileSource.java:139)
	at org.openstreetmap.josm.data.imagery.TMSCachedTileLoaderJob.handleNotFound(TMSCachedTileLoaderJob.java:328)
	at org.openstreetmap.josm.data.cache.JCSCachedTileLoaderJob.loadObject(JCSCachedTileLoaderJob.java:385)
	at org.openstreetmap.josm.data.cache.JCSCachedTileLoaderJob.run(JCSCachedTileLoaderJob.java:252)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)

Attachments (0)

Change History (1)

comment:1 Changed 8 years ago by rickmastfan67

Resolution: duplicate
Status: newclosed

Closed as duplicate of #11441.
Suggest to him to update to the current latest. It has already been fixed.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.