Modify

Opened 6 years ago

Closed 6 years ago

#11400 closed defect (fixed)

osm.notes.daysClosed=-1 returns error message

Reported by: anonymous Owned by: team
Priority: normal Milestone: 15.05
Component: Core notes Version:
Keywords: template_report regression Cc: simon04

Description

What steps will reproduce the problem?

  1. Set osm.notes.daysClosed to -1
  2. Download notes

What is the expected result?

According to https://josm.openstreetmap.de/wiki/Help/Dialog/Notes the value -1 should download all created notes ever instead of generating an error

What happens instead?

Error message appears

Please provide any additional information below. Attach a screenshot if possible.

Revision: 8315
Repository Root: http://josm.openstreetmap.de/svn
Relative URL: ^/trunk
Last Changed Author: stoecker
Last Changed Date: 2015-05-02 23:33:56 +0200 (Sat, 02 May 2015)
Build-Date: 2015-05-03 01:32:10
URL: http://josm.openstreetmap.de/svn/trunk
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last Changed Rev: 8315

Identification: JOSM/1.5 (8315 de) Windows 7 64-Bit
Memory Usage: 571 MB / 4444 MB (378 MB allocated, but free)
Java version: 1.8.0_31, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Dataset consistency test: No problems found

Plugins:
- Create_grid_of_ways (30892)
- DirectUpload (30892)
- ElevationProfile (31089)
- FixAddresses (30892)
- HouseNumberTaggingTool (30892)
- OpeningHoursEditor (30962)
- PicLayer (30962)
- RoadSigns (30977)
- SimplifyArea (30962)
- Tracer2 (30984)
- alignways (30892)
- buildings_tools (31100)
- colorscheme (30892)
- conflation (0.1.7)
- contourmerge (1013)
- editgpx (30892)
- geotools (31068)
- imagery_offset_db (31056)
- jts (31002)
- mapdust (30892)
- measurement (30892)
- merge-overlap (30988)
- mirrored_download (30962)
- namemanager (30892)
- public_transport (30892)
- reltoolbox (31056)
- reverter (30990)
- routes (30892)
- tageditor (30892)
- terracer (30892)
- turnlanes (30892)
- turnrestrictions (31034)
- undelete (30892)
- utilsplugin2 (31072)
- waydownloader (30892)

Last errors/warnings:
- E: org.openstreetmap.josm.io.OsmTransferException: java.lang.IllegalArgumentException: Requested note limit is less than 0.. Ursache: java.lang.IllegalArgumentException: Requested note limit is less than 0.
- E: org.openstreetmap.josm.io.OsmTransferException: java.lang.IllegalArgumentException: Requested note limit is less than 0.. Ursache: java.lang.IllegalArgumentException: Requested note limit is less than 0.

org.openstreetmap.josm.io.OsmTransferException: java.lang.IllegalArgumentException: Requested note limit is less than 0.
	at org.openstreetmap.josm.actions.downloadtasks.DownloadNotesTask$DownloadBoundingBoxTask.realRun(DownloadNotesTask.java:167)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:93)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:161)
	at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
	at java.util.concurrent.FutureTask.run(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.IllegalArgumentException: Requested note limit is less than 0.
	at org.openstreetmap.josm.tools.CheckParameterUtil.ensureThat(CheckParameterUtil.java:100)
	at org.openstreetmap.josm.io.BoundingBoxDownloader.parseNotes(BoundingBoxDownloader.java:168)
	at org.openstreetmap.josm.actions.downloadtasks.DownloadNotesTask$DownloadBoundingBoxTask.realRun(DownloadNotesTask.java:150)
	... 7 more

Attachments (0)

Change History (3)

comment:1 Changed 6 years ago by Klumbumbus

Component: CoreCore notes

comment:2 Changed 6 years ago by Don-vip

Cc: simon04 added
Keywords: regression added
Milestone: 15.05

regression of r8218

comment:3 Changed 6 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 8319/josm:

fix #11400 - allow osm.notes.daysClosed=-1

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.