Modify

Opened 6 years ago

Closed 6 years ago

#11399 closed defect (duplicate)

crash scrolling

Reported by: h4ck3rm1k3 Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. scrolling on the map

What is the expected result?

What happens instead?

[INFO] CacheEventQueue - Cache event queue created: CacheEventQueue [listenerId=365001994, cacheName=TMS]
INFO: GET https://api.openstreetmap.org/api/0.6/user/details (get number of unread messages)
[INFO] CacheEventQueue - Cache event queue created: CacheEventQueue [listenerId=365001994, cacheName=TMS]
[INFO] CacheEventQueue - Cache event queue created: CacheEventQueue [listenerId=365001994, cacheName=TMS]
ERROR: java.lang.NullPointerException
java.lang.NullPointerException

at org.openstreetmap.josm.data.cache.CacheEntryAttributes.isNoTileAtZoom(CacheEntryAttributes.java:32)
at org.openstreetmap.josm.data.imagery.TMSCachedTileLoaderJob.isNoTileAtZoom(TMSCachedTileLoaderJob.java:213)
at org.openstreetmap.josm.data.imagery.TMSCachedTileLoaderJob.getCachedTile(TMSCachedTileLoaderJob.java:284)
at org.openstreetmap.josm.data.imagery.TMSCachedTileLoaderJob.getTile(TMSCachedTileLoaderJob.java:164)
at org.openstreetmap.josm.data.imagery.TMSCachedTileLoader.getTile(TMSCachedTileLoader.java:70)
at org.openstreetmap.josm.gui.layer.TMSLayer.getTile(TMSLayer.java:753)
at org.openstreetmap.josm.gui.layer.TMSLayer$TileSet.allTiles(TMSLayer.java:1135)
at org.openstreetmap.josm.gui.layer.TMSLayer$TileSet.allExistingTiles(TMSLayer.java:1117)
at org.openstreetmap.josm.gui.layer.TMSLayer.getTileSetInfo(TMSLayer.java:1181)
at org.openstreetmap.josm.gui.layer.TMSLayer.access$1000(TMSLayer.java:92)
at org.openstreetmap.josm.gui.layer.TMSLayer$DeepTileSet.getTileSetInfo(TMSLayer.java:1231)
at org.openstreetmap.josm.gui.layer.TMSLayer.paint(TMSLayer.java:1268)
at org.openstreetmap.josm.gui.MapView.paintLayer(MapView.java:536)
at org.openstreetmap.josm.gui.MapView.paint(MapView.java:611)
at javax.swing.JComponent.paintChildren(JComponent.java:879)
at javax.swing.JComponent.paint(JComponent.java:1055)
at javax.swing.JComponent.paintToOffscreen(JComponent.java:5212)
at javax.swing.BufferStrategyPaintManager.paint(BufferStrategyPaintManager.java:295)
at javax.swing.RepaintManager.paint(RepaintManager.java:1249)
at javax.swing.JComponent._paintImmediately(JComponent.java:5160)
at javax.swing.JComponent.paintImmediately(JComponent.java:4971)
at javax.swing.RepaintManager$3.run(RepaintManager.java:808)
at javax.swing.RepaintManager$3.run(RepaintManager.java:796)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:796)
at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:769)
at javax.swing.RepaintManager.prePaintDirtyRegions(RepaintManager.java:718)
at javax.swing.RepaintManager.access$1100(RepaintManager.java:62)
at javax.swing.RepaintManager$ProcessingRunnable.run(RepaintManager.java:1677)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:312)
at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:738)
at java.awt.EventQueue.access$300(EventQueue.java:103)
at java.awt.EventQueue$3.run(EventQueue.java:699)
at java.awt.EventQueue$3.run(EventQueue.java:697)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:708)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)

ERROR: java.lang.NullPointerException
java.lang.NullPointerException

at org.openstreetmap.josm.data.cache.CacheEntryAttributes.isNoTileAtZoom(CacheEntryAttributes.java:32)
at org.openstreetmap.josm.data.imagery.TMSCachedTileLoaderJob.isNoTileAtZoom(TMSCachedTileLoaderJob.java:213)
at org.openstreetmap.josm.data.imagery.TMSCachedTileLoaderJob.getCachedTile(TMSCachedTileLoaderJob.java:284)
at org.openstreetmap.josm.data.imagery.TMSCachedTileLoaderJob.getTile(TMSCachedTileLoaderJob.java:164)
at org.openstreetmap.josm.data.imagery.TMSCachedTileLoader.getTile(TMSCachedTileLoader.java:70)
at org.openstreetmap.josm.gui.layer.TMSLayer.getTile(TMSLayer.java:753)
at org.openstreetmap.josm.gui.layer.TMSLayer$TileSet.allTiles(TMSLayer.java:1135)
at org.openstreetmap.josm.gui.layer.TMSLayer$TileSet.allExistingTiles(TMSLayer.java:1117)
at org.openstreetmap.josm.gui.layer.TMSLayer.getTileSetInfo(TMSLayer.java:1181)
at org.openstreetmap.josm.gui.layer.TMSLayer.access$1000(TMSLayer.java:92)
at org.openstreetmap.josm.gui.layer.TMSLayer$DeepTileSet.getTileSetInfo(TMSLayer.java:1231)
at org.openstreetmap.josm.gui.layer.TMSLayer.paint(TMSLayer.java:1268)
at org.openstreetmap.josm.gui.MapView.paintLayer(MapView.java:536)
at org.openstreetmap.josm.gui.MapView.paint(MapView.java:611)
at javax.swing.JComponent.paintChildren(JComponent.java:879)
at javax.swing.JComponent.paint(JComponent.java:1055)
at javax.swing.JComponent.paintToOffscreen(JComponent.java:5212)
at javax.swing.BufferStrategyPaintManager.paint(BufferStrategyPaintManager.java:295)
at javax.swing.RepaintManager.paint(RepaintManager.java:1249)
at javax.swing.JComponent._paintImmediately(JComponent.java:5160)
at javax.swing.JComponent.paintImmediately(JComponent.java:4971)
at javax.swing.RepaintManager$3.run(RepaintManager.java:808)
at javax.swing.RepaintManager$3.run(RepaintManager.java:796)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:796)
at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:769)
at javax.swing.RepaintManager.prePaintDirtyRegions(RepaintManager.java:718)
at javax.swing.RepaintManager.access$1100(RepaintManager.java:62)
at javax.swing.RepaintManager$ProcessingRunnable.run(RepaintManager.java:1677)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:312)
at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:738)
at java.awt.EventQueue.access$300(EventQueue.java:103)
at java.awt.EventQueue$3.run(EventQueue.java:699)
at java.awt.EventQueue$3.run(EventQueue.java:697)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:708)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)

ERROR: java.lang.NullPointerException

Please provide any additional information below. Attach a screenshot if possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2015-05-02 13:43:03
Last Changed Author: stoecker
Revision: 8312
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2015-05-02 15:38:29 +0200 (Sat, 02 May 2015)
Last Changed Rev: 8312

Identification: JOSM/1.5 (8312 en) Linux Mint 10 Julia
Memory Usage: 392 MB / 1747 MB (32 MB allocated, but free)
Java version: 1.7.0_75, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u75-2.5.4-2
Dataset consistency test: No problems found

Plugins:
- AddrInterpolation (30892)
- CommandLine (30892)
- FixAddresses (30892)
- HouseNumberTaggingTool (30892)
- ImageWayPoint (30892)
- ImportImagePlugin (30892)
- OpeningHoursEditor (30962)
- SimplifyArea (30962)
- buildings_tools (31100)
- continuosDownload (1413902943)
- download_along (30892)
- geochat (31056)
- geotools (31068)
- graphview (30892)
- imageryadjust (30892)
- jts (31002)
- junctionchecking (30892)
- lakewalker (30892)
- log4j (30892)
- mapdust (30892)
- mirrored_download (30962)
- opendata (31050)
- osmarender (30892)
- pdfimport (30892)
- photo_geotagging (30967)
- photoadjust (30964)
- public_transport (30892)
- routes (30892)
- routing (30892)
- tag2link (31066)
- tageditor (30892)
- tagging-preset-tester (30892)
- terracer (30892)
- todo (29154)
- utilsplugin2 (31072)
- waydownloader (30892)
- wikipedia (31035)

Last errors/warnings:
- E: java.lang.NullPointerException
- E: java.lang.NullPointerException
- E: java.lang.NullPointerException
- E: java.lang.NullPointerException
- E: java.lang.NullPointerException

java.lang.NullPointerException

Attachments (0)

Change History (1)

comment:1 Changed 6 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #11397.
Please update to latest

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.