Modify

Opened 7 years ago

Closed 9 months ago

#11398 closed defect (fixed)

Install windows version for all windows users

Reported by: slodki_dom@… Owned by: Don-vip
Priority: normal Milestone: 21.08
Component: Installer Windows Version: tested
Keywords: windows install start menu users icon Cc:

Description (last modified by Don-vip)

What steps will reproduce the problem?

  1. Download latest windows installer with a non-elevated user account
  2. Install in default path under Windws 7 with admin privileges
  3. Start menu icons are not avaiable for standard windows users except admin account
  4. When JOSM started from c:\Program Files (x86)\JOSM\josm.exe all works ok for all users

What is the expected result?

JOSM.lnk should be created by windows installer not in c:\Users\Administrator\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\ but in c:\ProgramData\Microsoft\Windows\Start Menu\Programs\ (location linked from c:\Users\All Users\Start Menu\).

Or user selectable option in installer should be available (to install for all users or specific user only).

What happens instead?

No JOSM in start menu after install. JOSM can be started only by:

  • navigating to install directory and selecting exe
  • creating manually link to exe
  • searching for JOSM in search box in start menu

Please provide any additional information below. Attach a screenshot if possible.

Revision: 8279
Repository Root: http://josm.openstreetmap.de/svn
Relative URL: ^/trunk
Last Changed Author: Klumbumbus
Last Changed Date: 2015-04-26 22:42:34 +0200 (Sun, 26 Apr 2015)
Build-Date: 2015-04-27 01:31:19
URL: http://josm.openstreetmap.de/svn/trunk
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last Changed Rev: 8279

Identification: JOSM/1.5 (8279 pl) Windows 7 64-Bit
Memory Usage: 123 MB / 989 MB (77 MB allocated, but free)
Java version: 1.8.0_45, Oracle Corporation, Java HotSpot(TM) Client VM

Attachments (0)

Change History (6)

comment:1 Changed 4 years ago by Hb---

Start menu issues as reported by OP.

Additionally the installer should not take C:\Users\<admin-account>\AppData\Roaming\JOSM as target for the user preferences when started from a non-elevated account.

The target should be C:\Users\<non-elevated-user-account>\Appdata\...

comment:2 Changed 4 years ago by Hb---

Ticket #16004 has been marked as a duplicate of this ticket.

comment:3 Changed 4 years ago by stoecker

Summary: Install windows wersion for all windows usersInstall windows version for all windows users

comment:4 Changed 4 years ago by Don-vip

Description: modified (diff)

comment:5 Changed 9 months ago by Don-vip

Milestone: 21.08
Owner: changed from team to Don-vip
Status: newassigned

comment:6 Changed 9 months ago by Don-vip

Resolution: fixed
Status: assignedclosed

In 18162/josm:

see #17083 - fix #11398 - per-user-install of Windows jpackage installer

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.