Modify

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#11355 closed defect (fixed)

Splash screen should support parallel initialization tasks (was: 'Reading local plugin information' 3 times @ startup?)

Reported by: rickmastfan67 Owned by: team
Priority: normal Milestone: 15.08
Component: Core Version: latest
Keywords: splash regression Cc:

Description

Is this suppose to be happening? Seems kinda weird to see three sets of time for that line on the startup screen, even if you might see if for only a second.


Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2015-04-19 01:32:19
Last Changed Author: simon04
Revision: 8229
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2015-04-19 00:29:10 +0200 (Sun, 19 Apr 2015)
Last Changed Rev: 8229

Identification: JOSM/1.5 (8229 en) Windows 7 64-Bit
Memory Usage: 353 MB / 1820 MB (235 MB allocated, but free)
Java version: 1.7.0_75, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM

Plugins:
- ImageryCache (31083)
- OpeningHoursEditor (30962)
- buildings_tools (30955)
- measurement (30892)
- mirrored_download (30962)
- osmarender (30892)
- reverter (30990)
- turnrestrictions (31034)
- undelete (30892)
- utilsplugin2 (31072)

Attachments (9)

11355_starup.png (24.2 KB) - added by rickmastfan67 6 years ago.
11355.patch (18.7 KB) - added by simon04 6 years ago.
2015-04-26-133009_1200x950_scrot.png (21.8 KB) - added by simon04 6 years ago.
11355v2.patch (19.9 KB) - added by simon04 6 years ago.
splash1.png (3.3 KB) - added by bastiK 6 years ago.
splash2.png (22.9 KB) - added by bastiK 6 years ago.
s1.png (50.8 KB) - added by Don-vip 6 years ago.
s2.png (56.0 KB) - added by Don-vip 6 years ago.
s3.png (40.0 KB) - added by Don-vip 6 years ago.

Download all attachments as: .zip

Change History (32)

Changed 6 years ago by rickmastfan67

Attachment: 11355_starup.png added

comment:1 Changed 6 years ago by simon04

The three lines in different gray colors have been added before the initialization tasks have been parallelized. When some tasks finish at about the same time, this may lead to described behaviour …

To fix this, one would have to modify SplashScreen quite a bit since the concept of ProgressMonitor does currently not work with parallel operations …

comment:2 Changed 6 years ago by rickmastfan67

I was just more curious than anything about this.

Changed 6 years ago by simon04

Attachment: 11355.patch added

comment:3 Changed 6 years ago by simon04

Milestone: 15.05
Summary: 'Reading local plugin information' 3 times @ startup?[Patch] Splash screen should support parallel initialization tasks (was: 'Reading local plugin information' 3 times @ startup?)

Changed 6 years ago by simon04

comment:4 Changed 6 years ago by simon04

This is achieved using a specialized ProgressMonitor for the splash screen.



Last edited 6 years ago by Don-vip (previous) (diff)

comment:5 Changed 6 years ago by simon04

Keywords: splash added

comment:6 Changed 6 years ago by bastiK

On my system, the splash window stays at a fixed size and the content is scrolled in a strange way. Maybe add a scroll box for the bullet list?

Build-Date: 2015-04-26 15:12:57
Revision: 8274
Is-Local-Build: true

Identification: JOSM/1.5 (8274 SVN en_GB) Linux Ubuntu 14.04.2 LTS
Memory Usage: 487 MB / 1763 MB (294 MB allocated, but free)
Java version: 1.7.0_79, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u79-2.5.5-0ubuntu0.14.04.2

comment:7 Changed 6 years ago by simon04

Interesting. I'm using

Identification: JOSM/1.5 (8275 SVN en) Linux Arch Linux

+ http://i3wm.org/

We could set a fixed height of say 240px for the content …

comment:8 Changed 6 years ago by Don-vip

Milestone: 15.0515.06

Changed 6 years ago by simon04

Attachment: 11355v2.patch added

comment:9 Changed 6 years ago by simon04

v2: refactoring of the code/patch and a fixed height of 320px for the task list …

comment:10 Changed 6 years ago by Don-vip

Milestone: 15.0615.07

skip milestone 15.06

comment:11 Changed 6 years ago by simon04

Resolution: fixed
Status: newclosed

In 8497/josm:

fix #11355 - Splash screen: display parallel initialization tasks in a sensible way

Changed 6 years ago by bastiK

Attachment: splash1.png added

Changed 6 years ago by bastiK

Attachment: splash2.png added

comment:12 Changed 6 years ago by bastiK

Looks like this now:


comment:13 Changed 6 years ago by simon04

In 8499/josm:

see #11355 - Splash screen: attempt to fix dialog height issue

comment:14 Changed 6 years ago by simon04

In 8500/josm:

see #11355 - Splash screen: attempt to fix dialog height issue (2)

comment:15 Changed 6 years ago by Don-vip

Keywords: regression added
Priority: trivialnormal
Resolution: fixed
Status: closedreopened

Changed 6 years ago by Don-vip

Attachment: s1.png added

Changed 6 years ago by Don-vip

Attachment: s2.png added

Changed 6 years ago by Don-vip

Attachment: s3.png added

comment:16 Changed 6 years ago by Don-vip

The splashscreen does not work anymore on Windows 8.1 with Java 8u45 (webstart):




comment:17 Changed 6 years ago by simon04

In 8516/josm:

see #11355 - Splash screen: scroll overlong task list

comment:18 Changed 6 years ago by Don-vip

In 8520/josm:

see #11591, see #11355 - disable blocking code + fix some sonar issues. Splash screen does not work anymore but at least JOSM starts correctly.

comment:19 Changed 6 years ago by simon04

In 8524/josm:

see #11591, see #11355 - Splash screen: attempt to fix synchronisation/deadlock issue

comment:20 Changed 6 years ago by simon04

In 8525/josm:

see #11591, see #11355 - Splash screen: attempt to fix lock issue (2)

comment:21 Changed 6 years ago by bastiK

In 8562/josm:

fixed splash deadlock for java 7 (fixes #11591, see #11355)

comment:22 Changed 6 years ago by bastiK

Resolution: fixed
Status: reopenedclosed
Summary: [Patch] Splash screen should support parallel initialization tasks (was: 'Reading local plugin information' 3 times @ startup?)Splash screen should support parallel initialization tasks (was: 'Reading local plugin information' 3 times @ startup?)

comment:23 Changed 6 years ago by Don-vip

Milestone: 15.0715.08

Milestone renamed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.