Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#11356 closed defect (fixed)

Unable to open overpass query

Reported by: naoliv Owned by: team
Priority: normal Milestone: 15.04
Component: Core remotecontrol Version:
Keywords: regression Cc: simon04

Description

JOSM is saying that it's unable to open 'http://overpass-api.de/api/interpreter?fixme=JOSM-ticket-8566&data=%2F*%0AThis%20has%20been%20generated%20by%20the%20overpass-turbo%20wizard.%0AThe%20original%20search%20was%3A%0A%E2%80%9Cbridge%3D*%20in%20%22s%C3%A3o%20paulo%2C%20brazil%22%E2%80%9D%0A*%2F%0A%5Bout%3Axml%5D%3B%2F*fixed%20by%20auto%20repair*%2F%0A%2F%2F%20fetch%20area%20%E2%80%9Cs%C3%A3o%20paulo%2C%20brazil%E2%80%9D%20to%20search%20in%0Aarea(3600298204)-%3E.searchArea%3B%0A%2F%2F%20gather%20results%0A(%0A%20%20%2F%2F%20query%20part%20for%3A%20%E2%80%9Cbridge%3D*%E2%80%9D%0A%20%20node%5B%22bridge%22%5D(area.searchArea)%3B%0A%20%20way%5B%22bridge%22%5D(area.searchArea)%3B%0A%20%20relation%5B%22bridge%22%5D(area.searchArea)%3B%0A)%3B%0A%2F%2F%20print%20results%0Aout%20meta%3B%2F*fixed%20by%20auto%20repair*%2F%0A%3E%3B%0Aout%20meta%20qt%3B%2F*fixed%20by%20auto%20repair*%2F' while trying to export an overpass query.

overpass query is http://overpass-turbo.eu/s/8SI

JOSM:

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2015-04-20 01:31:09
Last Changed Author: simon04
Revision: 8240
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2015-04-20 00:15:43 +0200 (Mon, 20 Apr 2015)
Last Changed Rev: 8240

Identification: JOSM/1.5 (8240 pt_BR) Linux Debian GNU/Linux 8.0 (jessie)
Memory Usage: 247 MB / 4029 MB (181 MB allocated, but free)
Java version: 1.7.0_79, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u79-2.5.5-1
VM arguments: [-Dawt.useSystemAAFontSettings=on]

Plugins:
- AddrInterpolation (30892)
- Create_grid_of_ways (30892)
- FastDraw (30892)
- FixAddresses (30892)
- OpeningHoursEditor (30962)
- PicLayer (30962)
- SimplifyArea (30962)
- buildings_tools (30955)
- download_along (30892)
- editgpx (30892)
- geotools (31068)
- graphview (30892)
- jts (31002)
- measurement (30892)
- merge-overlap (30988)
- opendata (31050)
- pdfimport (30892)
- poly (31056)
- reverter (30990)
- tagging-preset-tester (30892)
- todo (29154)
- turnrestrictions (31034)
- undelete (30892)
- utilsplugin2 (31072)

Attachments (0)

Change History (7)

comment:1 Changed 4 years ago by Klumbumbus

Cc: simon04 added
Component: CoreCore remotecontrol
Keywords: regression added
Milestone: 15.04

Same for me. Works woth JOSM-tested. Maybe caused by recent "Open Location..." modifications.

comment:2 Changed 4 years ago by simon04

I'll check that on Thursdays/Friday when I return home …

comment:4 Changed 4 years ago by simon04

In 8249/josm:

see #11356 - Remote control: fix opening overpass query

The compatibility code calling DownloadOsmTask had not been executed.

comment:5 Changed 4 years ago by simon04

Resolution: fixed
Status: newclosed

comment:6 Changed 4 years ago by brycenesbitt

I just rebuilt JOSM from SVN, and while the error dialog is gone, no data is loaded.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.