Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#11353 closed defect (fixed)

Imagery offset not updating the image

Reported by: naoliv Owned by: team
Priority: normal Milestone: 15.05
Component: Core imagery Version:
Keywords: Cc: wiktorn

Description

Using Bing, clicking on Adjust imagery offset and then moving the layer with the left mouse button (or directly entering a value with the keyboard) isn't updating the layer.
If I move the layer with the right mouse button, it gets updated to the right place (the new position from the offset). If I change the zoom level it also updates. Pressing TAB in JOSM to hide/show the panel also updates it, but moving or entering a value (without doing things like this, to force an update of the map) isn't updating its position.

JOSM:

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2015-04-18 01:31:13
Last Changed Author: simon04
Revision: 8212
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2015-04-18 02:23:03 +0200 (Sat, 18 Apr 2015)
Last Changed Rev: 8212

Identification: JOSM/1.5 (8212 en) Linux Debian GNU/Linux 8.0 (jessie)
Memory Usage: 247 MB / 4029 MB (165 MB allocated, but free)
Java version: 1.7.0_79, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-7-jre:amd64-7u79-2.5.5-1
VM arguments: [-Dawt.useSystemAAFontSettings=on]
Dataset consistency test: No problems found

Plugins:
- AddrInterpolation (30892)
- Create_grid_of_ways (30892)
- FastDraw (30892)
- FixAddresses (30892)
- OpeningHoursEditor (30962)
- PicLayer (30962)
- SimplifyArea (30962)
- buildings_tools (30955)
- download_along (30892)
- editgpx (30892)
- geotools (31068)
- graphview (30892)
- jts (31002)
- measurement (30892)
- merge-overlap (30988)
- opendata (31050)
- pdfimport (30892)
- poly (31056)
- reverter (30990)
- tagging-preset-tester (30892)
- todo (29154)
- turnrestrictions (31034)
- undelete (30892)
- utilsplugin2 (31072)

Attachments (2)

imagery_ajust_freeze.gif (370.5 KB) - added by Felis Pimeja 4 years ago.
fix_offset_setting.patch (720 bytes) - added by wiktorn 4 years ago.

Download all attachments as: .zip

Change History (20)

comment:1 Changed 4 years ago by Felis Pimeja

Exactly the same problem on Windows 7. All the plugins are turned off. The problem started somewhere between snapshot r8167 (all is fine) and snapshot r8175 (the problem exists).

Last edited 4 years ago by stoecker (previous) (diff)

Changed 4 years ago by Felis Pimeja

Attachment: imagery_ajust_freeze.gif added

comment:2 Changed 4 years ago by stoecker

Cc: wiktorn added

comment:3 Changed 4 years ago by Felis Pimeja

Cc: wiktorn removed

https://dl.dropboxusercontent.com/u/8010189/Forum%20attachments/imagery_ajust_freeze.gif
Added an image to illustrate the misbehavior:

  1. Start image ajust
  2. Trying to drag Bing layer with left mouse button pressed and nothing happens
  3. Trying to drag the viewport with right mouse button pressed - imagery reloads immediately. Same when zooming in-out with mouse wheel.

comment:4 Changed 4 years ago by naoliv

Cc: wiktorn added

Adding wiktorn back since it seems that he was removed unintentionally

comment:5 Changed 4 years ago by stoecker

Milestone: 15.05

Changed 4 years ago by wiktorn

Attachment: fix_offset_setting.patch added

comment:6 Changed 4 years ago by wiktorn

Attached patch restores the setOffset method, which fixes the bug.

comment:7 Changed 4 years ago by stoecker

Resolution: fixed
Status: newclosed

In 8288/josm:

fix #11353 - imagery offset regression (patch by wiktorn)

comment:8 Changed 4 years ago by Don-vip

Shouldn't we release a new stable as hotfix? It seems a major regression, no?

comment:9 in reply to:  8 Changed 4 years ago by naoliv

Replying to Don-vip:

Shouldn't we release a new stable as hotfix? It seems a major regression, no?

If my "yes" count as something, then yes from me :-)

comment:10 Changed 4 years ago by stoecker

There was only one report, so currently I see no hotfix reason :-) I assume most users do not use adjusting much.

comment:11 in reply to:  10 ; Changed 4 years ago by wiktorn

Replying to stoecker:

There was only one report, so currently I see no hotfix reason :-) I assume most users do not use adjusting much.

That's a shame. Actually we do care a lot about properly adjusting the maps, so I'd vote for a hotfix release, just to stress, that's important for community.

comment:12 in reply to:  11 Changed 4 years ago by stoecker

Replying to wiktorn:

Replying to stoecker:

There was only one report, so currently I see no hotfix reason :-) I assume most users do not use adjusting much.

That's a shame. Actually we do care a lot about properly adjusting the maps, so I'd vote for a hotfix release, just to stress, that's important for community.

It's not soooo easy. First I already did new changes and I'm not sure they are that stable. Then a release means still a lot of work even when reduced to the bare minimum (as ATM Vincent hasn't enough time for the other stuff). So if nobody complains I think "latest" will be enough for most users - there is always something wrong :-) Unless we get lots of complaints...

comment:13 Changed 4 years ago by aceman

I have also noticed this bug. I use the offset tweaking daily.

comment:14 Changed 4 years ago by Don-vip

Ok wait and see if we get more bug reports.

comment:15 Changed 4 years ago by algotua

There was only one report, so currently I see no hotfix reason :-)

Many users complain on this bug in the forums and give link to this topic.
How it can be escalated if the problem is known?

comment:16 Changed 4 years ago by stoecker

References?

comment:17 Changed 4 years ago by stoecker

BTW - They simply can use latest instead of tested, there is no need to wait.

comment:18 Changed 4 years ago by Zverikk

I'm for releasing a hotfix tested version. Adjusting an imagery layer offset is nearly impossible now. I don't struggle with it all the time, because for most locations using a stored imagery offset (via plugin) is enough. But this function is one of the major points why josm is better than id :)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.