Modify

Opened 5 years ago

Closed 5 years ago

#11352 closed defect (duplicate)

Enter no longer works as a way to commit new tags from the dialog box

Reported by: steve@… Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report macosx javabug Cc:

Description

What steps will reproduce the problem?

  1. Make a node
  2. Click "Add tag"
  3. Type in a key:value tag
  4. Press the Enter key

What is the expected result?

The dialog box should disappear and the tag is accepted.

What happens instead?

The dialog box remains. I've found that I can press Control-Enter to make the dialog box disappear and accept the tag.

Please provide any additional information below. Attach a screenshot if possible.

I have a Mac. The behavior, several versions ago, was to accept the Enter key but now I must press Control-Enter which is a harder button combination to press because it requires two hands.

Revision: 8159
Repository Root: http://josm.openstreetmap.de/svn
Relative URL: ^/trunk
Last Changed Author: stoecker
Last Changed Date: 2015-03-29 14:37:50 +0200 (Sun, 29 Mar 2015)
Build-Date: 2015-03-30 01:30:55
URL: http://josm.openstreetmap.de/svn/trunk
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last Changed Rev: 8159

Identification: JOSM/1.5 (8159 en) Mac OS X 10.10.3
Memory Usage: 393 MB / 910 MB (186 MB allocated, but free)
Java version: 1.8.0_31, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
VM arguments: [-Djava.library.path=/Applications/JOSM.app/Contents/MacOS, -DLibraryDirectory=/Users/stevevance/Library, -DDocumentsDirectory=/Users/stevevance/Documents, -DApplicationSupportDirectory=/Users/stevevance/Library/Application Support, -DCachesDirectory=/Users/stevevance/Library/Caches, -DSandboxEnabled=false, -Dapple.laf.useScreenMenuBar=true, -Dcom.apple.macos.use-file-dialog-packages=true, -Dcom.apple.macos.useScreenMenuBar=true, -Dcom.apple.mrj.application.apple.menu.about.name=JOSM, -Dcom.apple.smallTabs=true]
Dataset consistency test: No problems found

Plugins:
- FastDraw (30892)
- FixAddresses (30892)
- HouseNumberTaggingTool (30892)
- SimplifyArea (30962)
- continuosDownload (1413902943)
- download_along (30892)
- geochat (31056)
- geotools (31068)
- jts (31002)
- mapdust (30892)
- measurement (30892)
- opendata (31050)
- reverter (30990)
- scoutsigns (44)
- turnlanes (30892)
- turnrestrictions (31034)
- utilsplugin2 (31072)

Last errors/warnings:

Attachments (0)

Change History (3)

comment:1 Changed 5 years ago by Don-vip

Please update to latest version of java.

comment:2 Changed 5 years ago by Don-vip

Keywords: macosx javabug added

comment:3 Changed 5 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #10022.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.