Modify

Opened 6 years ago

Closed 4 years ago

#10022 closed defect (othersoftware)

Return key in tag editor currently doesn't work on Mac OSX with Java 8

Reported by: Lesath Owned by: flaimo
Priority: normal Milestone:
Component: Core Version: latest
Keywords: macosx java8 javabug 8u20 enter return key combobox Cc: cquest, Stereo, bitnapper

Description (last modified by Don-vip)

In prior versions the return key could be used to enter values in tag editor. Currently I have to use the mouse to click "Ok" to confirm the values.

Steps to reproduce:

1) Click a node or a way (doesn't matter which one)
2) Click "Add" from "Tags"
3) Enter value in the "Please select a key"
4) Press Tab (to change to the second field)
5) Enter value for the second field
6) Try enter return to confirm the value and close the tag editor

Maybe other editors could have the same problem - I didn't check that.

Revision: 7121
Is-Local-Build: true
Build-Date: 2014-05-14 09:21:25

Identification: JOSM/1.5 (7121 SVN en) Mac OS X 10.9.2
Memory Usage: 171 MB / 455 MB (96 MB allocated, but free)
Java version: 1.8.0, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
VM arguments: [-Djava.library.path=/Applications/JOSM_custom.app/Contents/MacOS, -DLibraryDirectory=/Users/wsobotta/Library, -DDocumentsDirectory=/Users/wsobotta/Documents, -DApplicationSupportDirectory=/Users/wsobotta/Library/Application Support, -DCachesDirectory=/Users/wsobotta/Library/Caches, -DSandboxEnabled=false, -Xmx512m, -Dapple.laf.useScreenMenuBar=true, -Dcom.apple.macos.use-file-dialog-packages=true, -Dcom.apple.macos.useScreenMenuBar=true, -Dcom.apple.mrj.application.apple.menu.about.name=JOSM, -Dcom.apple.smallTabs=true]
Dataset consistency test: No problems found

Plugin: FastDraw (30416)
Plugin: OpeningHoursEditor (30416)
Plugin: download_along (30416)
Plugin: imagery_offset_db (30416)
Plugin: turnlanes (30416)
Plugin: turnrestrictions (30416)

Attachments (4)

Bildschirmfoto 2014-05-14 um 13.08.14.png (53.6 KB) - added by Lesath 6 years ago.
Showing focus after the reproducable steps
Screen Shot 2015-03-15 at 19.16.54.png (732.4 KB) - added by flaimo 6 years ago.
Screen Shot 2015-03-15 at 19.17.05.png (711.3 KB) - added by flaimo 6 years ago.
status report flaimo 2015-03-15.txt (57.5 KB) - added by flaimo 6 years ago.

Download all attachments as: .zip

Change History (44)

comment:1 Changed 6 years ago by Don-vip

Description: modified (diff)

comment:2 Changed 6 years ago by Don-vip

Cc: cquest Stereo added
Keywords: apple mac osx added
Owner: changed from team to Lesath
Status: newneedinfo

Works for me with

Revision: 7122
Is-Local-Build: true
Build-Date: 2014-05-14 10:19:45

Identification: JOSM/1.5 (7122 SVN en) Windows 8.1 64-Bit
Memory Usage: 60 MB / 2731 MB (15 MB allocated, but free)
Java version: 1.8.0_05, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
VM arguments: [-Xmx3G, -Dfile.encoding=UTF-8]

@Lesath, can you please:

  • update your Java version to 8u5 and tell us if the bug's still here
  • if yes, attach a screenshot of the add tag dialog when you're typing the second key, to see where the focus is.

@cquest, Stereo: do you reproduce this bug with Java 7u55?

Thanks.

comment:3 Changed 6 years ago by Stereo

Hi everyone,

I can't reproduce this bug with build 7000 with Java 7u55 on Mac OS X.

@Lesath can you back up your ~/.josm directory and try with a fresh one? What about a fresh user account? Are you running any software that remaps keyboard keys?

comment:4 Changed 6 years ago by Lesath

This seems to be related to the Mac OS X Theme here on Mac - I've will test JDK 8u5 shortly - but it seems to be a bug in the Mac OS X theme - in Metal theme is the bug not reproducable.

BTW: I'm using no input remappers or something other things. The moving of the ~/.josm did not bring up the solution - as soon as I switch to "Mac OS X" theme the bug is there.

Last edited 6 years ago by Lesath (previous) (diff)

Changed 6 years ago by Lesath

Showing focus after the reproducable steps

comment:5 Changed 6 years ago by Lesath

Ok - the Bug still persists with the Mac OS X Theme with JDK 8u5. I've got currently no time to debug it by myself. I will try it today evening.

comment:6 Changed 6 years ago by Stereo

I use the Mac OS X theme too. Who's crazy enough to use the Metal theme? :) My focus looks just like yours. The only difference I can see is that your interface is in German, and I really can't see how that could interfere with the focus.

Maybe try by creating a fresh Mac OS X user account?

comment:7 Changed 6 years ago by Don-vip

Could be this Java bug: 8031485
Seems only to affect Java 8. Fix targeted to 8u20, to be released in August.

Last edited 6 years ago by Don-vip (previous) (diff)

comment:8 Changed 6 years ago by Don-vip

Resolution: othersoftware
Status: needinfoclosed

Yes, that's it. It is described in JDK8 release notes:

Area: Client Libs / java.swing

Synopsis
On Mac OS X, the ComboBox control consumes the Esc and Enter keys. When the ComboBox in a dialog box has focus, the keyboard cannot be used to close the dialog box.

Bug
8031485

Two solutions:

  • wait for JDK 8u20 in August
  • downgrade to Java 7u55

comment:9 Changed 6 years ago by Don-vip

Keywords: java8 added
Summary: Return key in tag editor currently doesn't workReturn key in tag editor currently doesn't work on Mac OSX with Java 8

comment:10 Changed 6 years ago by Lesath

Yes - this it is. Thanks for the pointing to the java-bug! (Also nice to know for me as a programmer ;-) )

comment:11 in reply to:  10 ; Changed 6 years ago by Don-vip

Replying to Lesath:

Also nice to know for me as a programmer ;-)

Wait... you're a Java developer on Mac OSX? :) We'd love some help on Mac-specific tickets :)

comment:12 in reply to:  11 Changed 6 years ago by Lesath

Replying to Don-vip:

Replying to Lesath:

Also nice to know for me as a programmer ;-)

Wait... you're a Java developer on Mac OSX? :) We'd love some help on Mac-specific tickets :)

Ahh - damn it - I knew it - I've should never revealed that I'm a programmer - but I will look into the today evening - since this ticket is resolved ;-)

comment:13 Changed 6 years ago by Stereo

Fantastic, I'll add all the Mac OS X issues that have been bugging me for a while to the bug tracker :)

comment:14 Changed 6 years ago by Don-vip

Keywords: javabug 8u20 added

comment:15 Changed 6 years ago by Don-vip

Java 8u20 has been released and contains fix for this bug, you should update to this version.

comment:16 Changed 6 years ago by Stereo

The bug is actually still there for me in Java Version 1.8.0_20. However, pressing 'tab' after entering the tag value switches focus to the button. The change of focus lets me use 'enter' to close the dialog.

comment:17 Changed 6 years ago by Don-vip

Ticket #10459 has been marked as a duplicate of this ticket.

comment:18 Changed 6 years ago by Don-vip

Cc: bitnapper added

comment:19 Changed 6 years ago by Don-vip

Resolution: othersoftware
Status: closedreopened

Indeed I can finally reproduce the problem with 8u20 as well.

comment:20 Changed 6 years ago by Don-vip

Looks like the fix is incomplete and only corrected the handling of Escape, not Enter.

comment:21 Changed 6 years ago by Don-vip

I have sent another bug report to Oracle. If it gets accepted it will be available here.

comment:22 Changed 6 years ago by Don-vip

Keywords: macosx enter return key combobox added; apple mac osx removed

comment:23 Changed 6 years ago by Don-vip

Owner: changed from Lesath to team
Status: reopenednew

comment:24 Changed 6 years ago by Don-vip

Resolution: othersoftware
Status: newclosed

The bug has been confirmed, we must wait for its correction by Oracle: javabug:8058193. I hope it will be fixed in next update (8u40).

comment:25 Changed 6 years ago by Don-vip

Just fixed in 8u40: javabug:8065376

comment:26 Changed 6 years ago by Stereo

I can confirm that this problem no longer exists in 8u31. Thank you!

comment:27 Changed 6 years ago by Don-vip

Ticket #11132 has been marked as a duplicate of this ticket.

comment:28 Changed 6 years ago by Don-vip

Ticket #11235 has been marked as a duplicate of this ticket.

comment:29 Changed 6 years ago by flaimo

I updated to Java 8 Update 40 on Mac OS 10.10. Problem still exists.

comment:30 Changed 6 years ago by flaimo

Resolution: othersoftware
Status: closedreopened

comment:31 Changed 6 years ago by Don-vip

Owner: changed from team to Lesath
Status: reopenedneedinfo

It shouldn't. Can you please attach your status report and a screenshot?

comment:32 Changed 6 years ago by Don-vip

Owner: changed from Lesath to flaimo

Changed 6 years ago by flaimo

Changed 6 years ago by flaimo

Changed 6 years ago by flaimo

comment:33 Changed 6 years ago by Lesath

Seems to be a problem with JDK 8.0 u40 - will be fixed with JDK 8.0u45 according to javabug:8067583

comment:34 Changed 6 years ago by Don-vip

Nop, that's just a backport of the same bug because 8u45 and 8u40 have been developed at the same time. 8u45 probably won't change anything. Do you reproduce the problem, Lesath?

comment:35 Changed 6 years ago by Lesath

Yes - the problem is still the same - no changes for me here ;-)

On the other hand - I've tried yesterday the preview from JDK 9 - there was the bug gone - thus not reproducible. The same is still for JDK 7... So it seems to be a bug in JDK 8.

Last edited 6 years ago by Lesath (previous) (diff)

comment:36 Changed 5 years ago by Don-vip

Ticket #11352 has been marked as a duplicate of this ticket.

comment:37 Changed 5 years ago by Mashin

Java version: 1.8.0_51
Problem still persists, however:

  • Ctrl + Enter adds a new tag
  • Enter works when editing already existing tag.

comment:38 Changed 4 years ago by Stereo

I can't reproduce this in 1.8.0_101. Hitting the Return key enters the new tag.

Can the mac user CC'd on this bug please see if they can still reproduce it?

comment:39 Changed 4 years ago by flaimo

Works for me now too. Just took Oracle 2 years to fix it :-/

comment:40 Changed 4 years ago by Don-vip

Resolution: othersoftware
Status: needinfoclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain flaimo.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.