Modify

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#11235 closed defect (duplicate)

"Add value" dialog can't be closed with Enter/Return under Mac OS X 10.10

Reported by: flaimo Owned by: team
Priority: normal Milestone:
Component: Core Version: tested
Keywords: macosx javabug Cc:

Description (last modified by flaimo)

Environment:

  • Mac OS X 10.10
  • JOSM Build 8109 Bundle

Steps:
1) Select a way
2) Press Alt+A to open the "Add value?" dialog
3) Write "maxspeed"
4) Press Tab
5) Enter "30"
6) Press "Enter" or "Return"

Result:
The keypress from step 6 isn't recognized. The dialog stays open.

Expected result:
The dialog should close and the new key/value should be added to the element.

This worked in the previous tested build prior to 8109 and also still works when using 8109 on windows. The Problem occurs only an Mac OS X. Also when editing an already existing tag, the enter key works in this other dialog. The problem only occurs in the dialog for adding a new key/value.

This is highly annoying when working with the keyboard most of the time, especially for this major use case.

Attachments (0)

Change History (4)

comment:1 Changed 6 years ago by flaimo

Description: modified (diff)

comment:2 Changed 6 years ago by Don-vip

Keywords: macosx javabug added
Priority: criticalnormal

comment:3 Changed 6 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #10022.
Java bug, please update to latest Java update (8u40): javabug:8058193

comment:4 Changed 6 years ago by flaimo

I updated to Java 8 Update 40 on Mac OS 10.10. Problem still exists.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.