Modify

Opened 4 years ago

Closed 4 years ago

Last modified 3 years ago

#11245 closed enhancement (wontfix)

[PATCH] Clothes tag

Reported by: Larry0ua Owned by: team
Priority: normal Milestone:
Component: Internal preset Version:
Keywords: clothes Cc:

Description

As described in http://wiki.openstreetmap.org/wiki/Key:clothes, I've updated the defaultpresets.xml with clothes=* values

Attachments (1)

clothes.diff (851 bytes) - added by Larry0ua 4 years ago.

Download all attachments as: .zip

Change History (17)

Changed 4 years ago by Larry0ua

Attachment: clothes.diff added

comment:1 Changed 4 years ago by Klumbumbus

Keywords: preset removed
Milestone: 15.03

comment:2 Changed 4 years ago by skyper

Do not like the gender values within the same tag. Does not really fit and cries out for problems. The common gender tags are access tags so either gender=female/male/unisex or clothes:female/male=yes/only/no could work. Similar is true for age e.g. clothes:age=0-2 or clothes:baby/child=yes/only/no but I think this belongs on tagging@.

comment:3 in reply to:  2 Changed 4 years ago by Klumbumbus

Replying to skyper:

The common gender tags are access tags

I think male=yes|no would be an access tag, but not clothes=male|female. clothes is a semicolon-seperated tag anyway (and should be a multiselect instead of a combo).

Last edited 4 years ago by Klumbumbus (previous) (diff)

comment:4 Changed 4 years ago by Klumbumbus

Milestone: 15.0315.04

comment:5 Changed 4 years ago by Klumbumbus

Resolution: fixed
Status: newclosed

In 8187/josm:

fix #11245 - add clothes=* multiselect to shop=clothes preset (modified patch by Larry0ua)

comment:6 in reply to:  5 ; Changed 4 years ago by skyper

Replying to Klumbumbus:

In 8187/josm:

fix #11245 - add clothes=* multiselect to shop=clothes preset (modified patch by Larry0ua)

Still not happy as a semicolon-separated tag is interpreted as logical OR and not as an AND.

How to tag shops which offer different cloth for different gender/age ?

comment:7 in reply to:  6 ; Changed 4 years ago by Klumbumbus

Replying to skyper:

Still not happy as a semicolon-separated tag is interpreted as logical OR and not as an AND.

I know only tags, where the semicolon means AND.

  • ref=B100;B101
  • destination=Berlin;Hamburg
  • turn:lanes=left|through;right
  • sport=tennis;badminton
  • opening_hours=Mo-Fr...; Sa...
  • clothes=woman;babies
Last edited 4 years ago by Klumbumbus (previous) (diff)

comment:8 in reply to:  7 ; Changed 4 years ago by skyper

Replying to Klumbumbus:

Replying to skyper:

Still not happy as a semicolon-separated tag is interpreted as logical OR and not as an AND.

I know only tags, where the semicolon means AND.

  • ref=B100;B101
  • destination=Berlin;Hamburg
  • turn:lanes=left|through;right
  • sport=tennis;badminton

You are right, I somehow twisted my head to much. Looking at it from the wrong side.

  • opening_hours=Mo-Fr...; Sa...

Wrong example, as the semi-colon has as special meaning by overruling any previous value.

  • clothes=woman;babies

How about clothes=babies;suits ? Only suits for babies ? Or clothes=children;men;suits;wedding what does it mean and how to tag:

clothes:women=wedding;underware + clothes:men=suits

comment:9 in reply to:  8 ; Changed 4 years ago by Klumbumbus

Replying to skyper:

How about clothes=babies;suits ? Only suits for babies ?

No, clothes for babies and suits.

Or clothes=children;men;suits;wedding what does it mean and how to tag:

clothes for children and clothes for men and suits and weddingclothes.

I understand what you mean ,different "classes" in one key. But I think this is not such a big problem for this simple key.

clothes:women=wedding;underware + clothes:men=suits

Yes, if you want to tag that in a shop the wedding clothes and the underware is only wor woman and the suits are only for men, you cannot do this with the simple clothes tag. But this is already pretty specialized tagging.

btw. woman is the most used value and men the 3rd most used value for clothes.

comment:10 in reply to:  9 Changed 4 years ago by skyper

Replying to Klumbumbus:

I understand what you mean ,different "classes" in one key. But I think this is not such a big problem for this simple key.

We should not introduce problematic tags with low numbers but rather try to find a better solution and mean-while offer problematic tags only in external presets.

It is much more work to change it after it gets popular.

clothes:women=wedding;underware + clothes:men=suits

Yes, if you want to tag that in a shop the wedding clothes and the underware is only wor woman and the suits are only for men, you cannot do this with the simple clothes tag. But this is already pretty specialized tagging.

btw. woman is the most used value and men the 3rd most used value for clothes.

Currently, according to taginfo only around 1% of almost 100000 shop=clothes are combined with clothes=*. I am not sure which other main tags are combined with the rest (4000) as there are only ~600 shop=fashion.

So the tag is not in major use especially with shop=clothes and if introduced it should be added to more presets than only shop=clothes.

Last edited 4 years ago by skyper (previous) (diff)

comment:11 Changed 4 years ago by Klumbumbus

Resolution: fixed
Status: closedreopened

OK, I will remove it again. Or are there more opinions about this topic?

comment:12 Changed 4 years ago by Larry0ua

I am afraid that only reverting the change is not enough. Initiating a tagging discussion outside of this ticket is required. Anyone?

comment:13 Changed 4 years ago by Klumbumbus

In 8204/josm:

see #11245 - remove controversial clothes tag; fix #10329 - improve color validator warning; fix #11330 - improve uncommon short key validator warning; fix #11344 - add validator warning for 'tower|pole=air_to_ground'

comment:14 Changed 4 years ago by Klumbumbus

Milestone: 15.04
Resolution: wontfix
Status: reopenedclosed

Closed for now. Please reopen once tagging is clear.

comment:15 Changed 3 years ago by Klumbumbus

Ticket #13856 has been marked as a duplicate of this ticket.

comment:16 Changed 3 years ago by Klumbumbus

Ticket #14326 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.