Modify

Opened 5 years ago

Closed 4 years ago

#11237 closed enhancement (fixed)

[Patch] Change default colour of waypoints and GPS tracks

Reported by: mkoniecz Owned by: team
Priority: normal Milestone: 16.01
Component: Core Version:
Keywords: template_report gpx tracks color Cc:

Description

What steps will reproduce the problem?

  1. Open GPX file

What is the expected result?

Track is well visible (red works well)

What happens instead?

Track is camouflaging with its gray color, and it is necessary to change it on opening every new track/waypoint file.

Please provide any additional information below. Attach a screenshot if possible.

Revision: 8133
Repository Root: http://josm.openstreetmap.de/svn
Relative URL: ^/trunk
Last Changed Author: bastiK
Last Changed Date: 2015-03-12 23:37:24 +0100 (Thu, 12 Mar 2015)
Build-Date: 2015-03-13 02:31:01
URL: http://josm.openstreetmap.de/svn/trunk
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last Changed Rev: 8133

Identification: JOSM/1.5 (8133 en) Linux Ubuntu 14.04.2 LTS
Memory Usage: 587 MB / 889 MB (340 MB allocated, but free)
Java version: 1.8.0_40, Oracle Corporation, Java HotSpot(TM) Server VM
Dataset consistency test: No problems found

Plugins:
- FastDraw (30892)
- OpeningHoursEditor (30962)
- PicLayer (30962)
- buildings_tools (30955)
- continuosDownload (1413902943)
- geotools (31000)
- jts (31002)
- log4j (30892)
- measurement (30892)
- undelete (30892)
- wikipedia (31035)

Last errors/warnings:
- E: Failed to locate image 'Flag, Blue'
- E: Failed to locate image 'Flag, Blue'
- E: Failed to locate image 'Flag, Blue'
- E: Failed to locate image 'Flag, Blue'
- E: Failed to locate image 'Flag, Blue'

Attachments (1)

magenta.patch (2.5 KB) - added by simon04 4 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 5 years ago by Klumbumbus

You can change the default color at preferences -> display settings -> colors -> gps point

comment:2 Changed 5 years ago by Don-vip

Resolution: worksforme
Status: newclosed

comment:3 Changed 5 years ago by mkoniecz

Resolution: worksforme
Status: closedreopened

It is a good thing that it may be set - but I think that red, visible on typical backgrounds would be better default than gray that is nearly invisible.

Last edited 5 years ago by mkoniecz (previous) (diff)

Changed 4 years ago by simon04

Attachment: magenta.patch added

comment:4 Changed 4 years ago by simon04

Keywords: gpx tracks color added
Milestone: 16.01
Summary: Change default colour of waypoints and GPS tracks[Patch] Change default colour of waypoints and GPS tracks

I normally set the color of GPX tracks to magenta since it has a nice color contrast wrt. background imagery and JOSM's default style.

comment:5 Changed 4 years ago by simon04

Any objections to magenta? :)

comment:6 Changed 4 years ago by Don-vip

no objection :)

comment:7 Changed 4 years ago by stoecker

·T··JOSM ? ;-)

comment:8 in reply to:  7 Changed 4 years ago by simon04

Replying to stoecker:

·T··JOSM ? ;-)

Sorry, I don't get that? An anagram?

comment:10 Changed 4 years ago by simon04

Not yet using "The search engine that doesn't track you."? → https://duckduckgo.com/?q=magenta+T&iax=1&ia=images :)

Do we fear copy right infringements for 0xFF00FF? ;)

comment:11 Changed 4 years ago by simon04

Resolution: fixed
Status: reopenedclosed

In 9248/josm:

fix #11237 - Change default color of waypoints and GPS tracks to magenta

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.