Modify

Opened 4 years ago

Closed 4 years ago

Last modified 6 months ago

#10944 closed defect (duplicate)

Could not initialize class com.sun.imageio.plugins.jpeg.JPEGImageReader (openSUSE, 8u40)

Reported by: D_S_W Owned by: team
Priority: normal Milestone:
Component: Core imagery Version: tested
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. load josm into new suse 13.2 installation
  2. load osm data
  3. attempt to load any backgrond imagery (eg bing)

What is the expected result?

background image behind data

What happens instead?

no image tiles are loaded

Please provide any additional information below. Attach a screenshot if possible.

have tried this on 2 different suse 13.2 installations and similar failure results

Revision: 7906
Repository Root: http://josm.openstreetmap.de/svn
Relative URL: ^/trunk
Last Changed Author: Don-vip
Last Changed Date: 2014-12-29 00:13:58 +0100 (Mon, 29 Dec 2014)
Build-Date: 2014-12-29 00:11:17
URL: http://josm.openstreetmap.de/svn/trunk
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last Changed Rev: 7906

Identification: JOSM/1.5 (7906 de) Linux openSUSE 13.2 (Harlequin) (x86_64)
Memory Usage: 107 MB / 592 MB (32 MB allocated, but free)
Java version: 1.8.0_40, Oracle Corporation, OpenJDK 64-Bit Server VM
VM arguments: [-Dicedtea-web.bin.name=javaws, -Dicedtea-web.bin.location=/usr/lib64/java-1_8_0-openjdk-plugin/bin/javaws]


Last errors/warnings:
- W: TMS - Failed downloading http://ecn.t3.tiles.virtualearth.net/tiles/a1202031300203.jpeg?g=3179: Attribution is not loaded yet
- W: TMS - Failed downloading http://ecn.t2.tiles.virtualearth.net/tiles/a1202031211331.jpeg?g=3179: Attribution is not loaded yet
- E: java.lang.UnsatisfiedLinkError: com.sun.imageio.plugins.jpeg.JPEGImageReader.initReaderIDs(Ljava/lang/Class;Ljava/lang/Class;Ljava/lang/Class;)V
- E: java.lang.NoClassDefFoundError: Could not initialize class com.sun.imageio.plugins.jpeg.JPEGImageReader
- E: java.lang.NoClassDefFoundError: Could not initialize class com.sun.imageio.plugins.jpeg.JPEGImageReader

Attachments (0)

Change History (3)

comment:1 Changed 4 years ago by bastiK

Resolution: duplicate
Status: newclosed

Closed as duplicate of #10675.

comment:2 Changed 6 months ago by Don-vip

Component: CoreCore imagery
Summary: new josm installation on new Opensuse 13.2 installation cannot load background imageryNoClassDefFoundError: Could not initialize class com.sun.imageio.plugins.jpeg.JPEGImageReader

comment:3 Changed 6 months ago by Don-vip

Summary: NoClassDefFoundError: Could not initialize class com.sun.imageio.plugins.jpeg.JPEGImageReaderCould not initialize class com.sun.imageio.plugins.jpeg.JPEGImageReader (openSUSE, 8u40)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.