Modify

Opened 6 years ago

Closed 6 years ago

Last modified 14 months ago

#10675 closed defect (duplicate)

Could not initialize class com.sun.imageio.plugins.jpeg.JPEGImageReader

Reported by: naoliv Owned by: team
Priority: major Milestone:
Component: Core imagery Version:
Keywords: Cc:

Description (last modified by naoliv)

Just enabled the Bing imagery layer and got this with imagery cache plugin enabled:

Revision: 7643
Repository Root: http://josm.openstreetmap.de/svn
Relative URL: ^/trunk
Last Changed Author: Don-vip
Last Changed Date: 2014-10-21 21:19:16 +0200 (Tue, 21 Oct 2014)
Build-Date: 2014-10-21 19:23:06
URL: http://josm.openstreetmap.de/svn/trunk
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last Changed Rev: 7643

Identification: JOSM/1.5 (7643 pt_BR) Linux Debian GNU/Linux unstable (sid)
Memory Usage: 292 MB / 4029 MB (122 MB allocated, but free)
Java version: 1.8.0_40-internal, Oracle Corporation, OpenJDK 64-Bit Server VM
VM arguments: [-Dawt.useSystemAAFontSettings=on]
Dataset consistency test: No problems found

Plugins:
- AddrInterpolation (30737)
- Create_grid_of_ways (30762)
- FixAddresses (30737)
- ImageryCache (30738)
- OpeningHoursEditor (30737)
- PicLayer (30762)
- SimplifyArea (30762)
- buildings_tools (30762)
- download_along (30762)
- editgpx (30737)
- geotools (30762)
- graphview (30762)
- jts (30762)
- measurement (30737)
- merge-overlap (30762)
- notes (v0.9.4)
- opendata (30762)
- pdfimport (30737)
- poly (30738)
- reverter (30737)
- tagging-preset-tester (30736)
- todo (29154)
- turnrestrictions (30762)
- undelete (30762)
- utilsplugin2 (30762)

Last errors/warnings:
- E: java.net.SocketTimeoutException: connect timed out
- E: org.openstreetmap.josm.io.OsmTransferException: Não foi possível conectar com o servidor OSM. Por favor, verifique sua conexão de internet.. Causa: java.net.SocketTimeoutException: connect timed out
- E: java.lang.UnsatisfiedLinkError: com.sun.imageio.plugins.jpeg.JPEGImageReader.initReaderIDs(Ljava/lang/Class;Ljava/lang/Class;Ljava/lang/Class;)V

java.lang.UnsatisfiedLinkError: com.sun.imageio.plugins.jpeg.JPEGImageReader.initReaderIDs(Ljava/lang/Class;Ljava/lang/Class;Ljava/lang/Class;)V
	at com.sun.imageio.plugins.jpeg.JPEGImageReader.initReaderIDs(Native Method)
	at com.sun.imageio.plugins.jpeg.JPEGImageReader.<clinit>(JPEGImageReader.java:96)
	at com.sun.imageio.plugins.jpeg.JPEGImageReaderSpi.createReaderInstance(JPEGImageReaderSpi.java:85)
	at javax.imageio.spi.ImageReaderSpi.createReaderInstance(ImageReaderSpi.java:320)
	at javax.imageio.ImageIO$ImageReaderIterator.next(ImageIO.java:529)
	at javax.imageio.ImageIO$ImageReaderIterator.next(ImageIO.java:513)
	at javax.imageio.ImageIO.read(ImageIO.java:1443)
	at javax.imageio.ImageIO.read(ImageIO.java:1352)
	at org.openstreetmap.gui.jmapviewer.Tile.loadImage(Tile.java:169)
	at org.openstreetmap.josm.plugins.imagerycache.OsmDBTilesLoader$DatabaseLoadJob.loadOrUpdateTileFromServer(OsmDBTilesLoader.java:242)
	at org.openstreetmap.josm.plugins.imagerycache.OsmDBTilesLoader$DatabaseLoadJob.run(OsmDBTilesLoader.java:111)
	at org.openstreetmap.gui.jmapviewer.JobDispatcher$JobThread.executeJobs(JobDispatcher.java:167)
	at org.openstreetmap.gui.jmapviewer.JobDispatcher$JobThread.run(JobDispatcher.java:134)

Then, with an updated JOSM and without using imagery cache:

ERRO: java.lang.NoClassDefFoundError: Could not initialize class com.sun.imageio.plugins.jpeg.JPEGImageReader
java.lang.NoClassDefFoundError: Could not initialize class com.sun.imageio.plugins.jpeg.JPEGImageReader
	at com.sun.imageio.plugins.jpeg.JPEGImageReaderSpi.createReaderInstance(JPEGImageReaderSpi.java:85)
	at javax.imageio.spi.ImageReaderSpi.createReaderInstance(ImageReaderSpi.java:320)
	at javax.imageio.ImageIO$ImageReaderIterator.next(ImageIO.java:529)
	at javax.imageio.ImageIO$ImageReaderIterator.next(ImageIO.java:513)
	at javax.imageio.ImageIO.read(ImageIO.java:1443)
	at javax.imageio.ImageIO.read(ImageIO.java:1352)
	at org.openstreetmap.gui.jmapviewer.Tile.loadImage(Tile.java:169)
	at org.openstreetmap.gui.jmapviewer.OsmFileCacheTileLoader$FileLoadJob.loadOrUpdateTile(OsmFileCacheTileLoader.java:239)
	at org.openstreetmap.gui.jmapviewer.OsmFileCacheTileLoader$FileLoadJob.run(OsmFileCacheTileLoader.java:175)
	at org.openstreetmap.gui.jmapviewer.JobDispatcher$JobThread.executeJobs(JobDispatcher.java:167)
	at org.openstreetmap.gui.jmapviewer.JobDispatcher$JobThread.run(JobDispatcher.java:134)

So it doesn't seem to be specific to imagery cache.

Attachments (0)

Change History (15)

comment:1 Changed 6 years ago by naoliv

Component: Plugin imagerycacheCore imagery
Description: modified (diff)
Owner: changed from akks to team
Priority: normalmajor
Summary: UnsatisfiedLinkError in ImageryCacheCould not initialize class com.sun.imageio.plugins.jpeg.JPEGImageReader

comment:2 Changed 6 years ago by stoecker

Resolution: duplicate
Status: newclosed

Closed as duplicate of #10603.

comment:3 Changed 6 years ago by Don-vip

Please use a stable release of Java (7u71/72 or 8u25). 8u40 is not released yet so that's a development version.

comment:4 Changed 6 years ago by naoliv

I've changed back to java7.
I really don't know why java8 got installed (nor why it was set to be the default jre) here. Thanks!

comment:5 Changed 6 years ago by stoecker

Ticket #10740 has been marked as a duplicate of this ticket.

comment:6 Changed 6 years ago by Jarda

For example, in OpenSUSE 13.2, openjdk 8u40 is instaled by default.

comment:8 Changed 6 years ago by bastiK

Ticket #10818 has been marked as a duplicate of this ticket.

comment:9 Changed 6 years ago by bastiK

Ticket #10944 has been marked as a duplicate of this ticket.

comment:11 Changed 6 years ago by skyper

Ticket #11195 has been marked as a duplicate of this ticket.

comment:12 Changed 6 years ago by Don-vip

Ticket #11211 has been marked as a duplicate of this ticket.

comment:13 Changed 3 years ago by stoecker

Ticket #15153 has been marked as a duplicate of this ticket.

comment:14 Changed 3 years ago by stoecker

Ticket #13731 has been marked as a duplicate of this ticket.

comment:15 Changed 3 years ago by stoecker

Seems not only related to 8u40, but happens also with later versions.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.