Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 months ago

#10818 closed defect (duplicate)

Could not initialize class com.sun.imageio.plugins.jpeg.JPEGImageReader (openSUSE, 8u40)

Reported by: meppen7 Owned by: team
Priority: normal Milestone:
Component: Core imagery Version: latest
Keywords: Bing Cc:

Description (last modified by Don-vip)

After Activate Bing displayed:
Unerwarteter Fehler (15)

Revision: 7764
Repository Root: http://josm.openstreetmap.de/svn
Relative URL: ^/trunk
Last Changed Author: Don-vip
Last Changed Date: 2014-12-05 01:10:47 +0100 (Fri, 05 Dec 2014)
Build-Date: 2014-12-05 02:34:20
URL: http://josm.openstreetmap.de/svn/trunk
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last Changed Rev: 7764

Identification: JOSM/1.5 (7764 de) Linux openSUSE 13.2 (Harlequin) (i586)
Memory Usage: 195 MB / 455 MB (124 MB allocated, but free)
Java version: 1.8.0_40, Oracle Corporation, OpenJDK Server VM
Dataset consistency test: No problems found


Last errors/warnings:
- E: java.lang.NoClassDefFoundError: Could not initialize class com.sun.imageio.plugins.jpeg.JPEGImageReader
- E: java.lang.NoClassDefFoundError: Could not initialize class com.sun.imageio.plugins.jpeg.JPEGImageReader
- E: java.lang.NoClassDefFoundError: Could not initialize class com.sun.imageio.plugins.jpeg.JPEGImageReader
- E: java.lang.NoClassDefFoundError: Could not initialize class com.sun.imageio.plugins.jpeg.JPEGImageReader
- E: java.lang.NoClassDefFoundError: Could not initialize class com.sun.imageio.plugins.jpeg.JPEGImageReader

java.lang.NoClassDefFoundError: Could not initialize class com.sun.imageio.plugins.jpeg.JPEGImageReader
	at com.sun.imageio.plugins.jpeg.JPEGImageReaderSpi.createReaderInstance(JPEGImageReaderSpi.java:85)
	at javax.imageio.spi.ImageReaderSpi.createReaderInstance(ImageReaderSpi.java:320)
	at javax.imageio.ImageIO$ImageReaderIterator.next(ImageIO.java:529)
	at javax.imageio.ImageIO$ImageReaderIterator.next(ImageIO.java:513)
	at javax.imageio.ImageIO.read(ImageIO.java:1443)
	at javax.imageio.ImageIO.read(ImageIO.java:1352)
	at org.openstreetmap.gui.jmapviewer.Tile.loadImage(Tile.java:169)
	at org.openstreetmap.gui.jmapviewer.OsmFileCacheTileLoader$FileLoadJob.loadOrUpdateTile(OsmFileCacheTileLoader.java:239)
	at org.openstreetmap.gui.jmapviewer.OsmFileCacheTileLoader$FileLoadJob.run(OsmFileCacheTileLoader.java:175)
	at org.openstreetmap.gui.jmapviewer.JobDispatcher$JobThread.executeJobs(JobDispatcher.java:167)
	at org.openstreetmap.gui.jmapviewer.JobDispatcher$JobThread.run(JobDispatcher.java:134)

Attachments (0)

Change History (3)

comment:1 Changed 4 years ago by bastiK

Resolution: duplicate
Status: newclosed

Closed as duplicate of #10675.

comment:2 Changed 4 months ago by Don-vip

Component: CoreCore imagery
Description: modified (diff)
Keywords: Error layer removed
Priority: criticalnormal
Summary: After selecting Bing layer Error message pops upNoClassDefFoundError: Could not initialize class com.sun.imageio.plugins.jpeg.JPEGImageReader

comment:3 Changed 4 months ago by Don-vip

Summary: NoClassDefFoundError: Could not initialize class com.sun.imageio.plugins.jpeg.JPEGImageReaderCould not initialize class com.sun.imageio.plugins.jpeg.JPEGImageReader (openSUSE, 8u40)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.