Modify

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#10936 closed defect (duplicate)

Regression - Tracer2 plugin crashes when trying to trace connected buildings

Reported by: RicoElectrico Owned by: team
Priority: normal Milestone:
Component: Plugin tracer2 Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Run Tracer2 on a building that is divided into 2 parts

What is the expected result?

The second building should be traced and its outline sticked to the first one.

What happens instead?

When tracing the second connected part, plugin will crash

Please provide any additional information below. Attach a screenshot if possible.

Revision: 7925
Repository Root: http://josm.openstreetmap.de/svn
Relative URL: ^/trunk
Last Changed Author: Klumbumbus
Last Changed Date: 2015-01-04 18:11:11 +0100 (Sun, 04 Jan 2015)
Build-Date: 2015-01-05 02:33:53
URL: http://josm.openstreetmap.de/svn/trunk
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last Changed Rev: 7925

Identification: JOSM/1.5 (7925 pl) Windows 8.1 64-Bit
Memory Usage: 1156 MB / 1794 MB (547 MB allocated, but free)
Java version: 1.8.0_25, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Dataset consistency test: No problems found

Plugins:
- FastDraw (30892)
- FixAddresses (30892)
- HouseNumberTaggingTool (30892)
- OpeningHoursEditor (30892)
- PicLayer (30892)
- ShowInGoogleMaps (8)
- SimplifyArea (30892)
- Tracer2 (30892)
- alignways (30892)
- buildings_tools (30892)
- contourmerge (1012)
- dataimport (30892)
- editgpx (30892)
- imagery_offset_db (30892)
- importvec (30892)
- kendzi3d (1.0.183)
- kendzi3d-jogl (37)
- log4j (30892)
- mapdust (30892)
- measurement (30892)
- mirrored_download (30892)
- notes (v0.9.5)
- pbf (30892)
- photo_geotagging (30892)
- poly (30892)
- reverter (30892)
- surveyor2 (29210)
- terracer (30892)
- turnrestrictions (30892)
- undelete (30892)
- utilsplugin2 (30892)
- wikipedia (30892)

Last errors/warnings:
- E: java.lang.IllegalArgumentException: Primitive to delete must be in a dataset

java.lang.IllegalArgumentException: Primitive to delete must be in a dataset
	at org.openstreetmap.josm.command.DeleteCommand.checkConsistency(DeleteCommand.java:115)
	at org.openstreetmap.josm.command.DeleteCommand.<init>(DeleteCommand.java:66)
	at org.openstreetmap.josm.command.DeleteCommand.<init>(DeleteCommand.java:76)
	at org.openstreetmap.josm.plugins.tracer2.ConnectWays.mergeNodes(ConnectWays.java:292)
	at org.openstreetmap.josm.plugins.tracer2.ConnectWays.connectTo(ConnectWays.java:251)
	at org.openstreetmap.josm.plugins.tracer2.ConnectWays.connect(ConnectWays.java:195)
	at org.openstreetmap.josm.plugins.tracer2.TracerAction.traceSync(TracerAction.java:330)
	at org.openstreetmap.josm.plugins.tracer2.TracerAction.access$000(TracerAction.java:62)
	at org.openstreetmap.josm.plugins.tracer2.TracerAction$1.realRun(TracerAction.java:174)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:93)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:161)
	at java.lang.Thread.run(Unknown Source)

Attachments (1)

sd.png (53.6 KB ) - added by RicoElectrico 9 years ago.
Tracer2 log and settings

Download all attachments as: .zip

Change History (3)

by RicoElectrico, 9 years ago

Attachment: sd.png added

Tracer2 log and settings

comment:1 by anonymous, 9 years ago


Tracer2 log and settings

Last edited 9 years ago by Don-vip (previous) (diff)

comment:2 by Klumbumbus, 9 years ago

Component: CorePlugin tracer2
Resolution: duplicate
Status: newclosed

Closed as duplicate of #10834.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.