Modify

Opened 7 years ago

Closed 4 years ago

#10935 closed defect (irreproducible)

15 sec delay on first Download and Upload

Reported by: A_Pirard Owned by: A_Pirard
Priority: normal Milestone:
Component: Core Version:
Keywords: Cc:

Description

I see a 15 sec delay the first time I do a File>Download.
And the same for the first File>Upload afterwards.
Subsequent actions are immediate.
А remotely commanded download is immediate and does not affect the above.
I'll help you to possibly investigate.
Thanks.

Attachments (2)

JOSM delay debug log.txt (23.5 KB) - added by A_Pirard 7 years ago.
JOSM status report.txt (15.2 KB) - added by A_Pirard 7 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 in reply to:  description Changed 7 years ago by Don-vip

Owner: changed from team to A_Pirard
Status: newneedinfo

Replying to A_Pirard:

I'll help you to possibly investigate.

First thing to help is to follow the recommended way of creating bug reports, please.

What could also help in addition is:

  • info about your hardware
  • is there another CPU or I/O operation by another software while you do that
  • launch JOSM with --debug and tell us if there is any relevant message displayed on the console

Thanks.

comment:2 Changed 7 years ago by Aun Johnsen <lists@…>

I sometimes have a delay when trying to upload or download data, I have not seen any pattern in it, other than it seems like it might be a command queue of some sort, like when having several imagery layers open and just panned around the map a lot. I have only seen this after I upgraded Mac OS X to Yosemite Beta, did not have this issue un Maverick

comment:3 Changed 7 years ago by Don-vip

Resolution: needinfo
Status: needinfoclosed

Changed 7 years ago by A_Pirard

Attachment: JOSM delay debug log.txt added

Changed 7 years ago by A_Pirard

Attachment: JOSM status report.txt added

comment:4 Changed 7 years ago by A_Pirard

So I will stop refining my tests and report between other tasks.
Hardware is TK11-BZ-015 AMD E450 2×1.65G 6GB.
Firefox and Thunderbird usually buzzing in background but stopping them changes nothing.
Files attached.
Debug log ----- commented inside.
I see no peculiar message related to a delay.
Thanks.

comment:5 Changed 7 years ago by A_Pirard

Resolution: needinfo
Status: closedreopened

comment:6 Changed 7 years ago by Don-vip

Status: reopenedneedinfo

I see you're using several plugins and an old version of Java. Does disabling all plugins and upgrading to latest Java (7u75 from Oracle or OpenJDK) help?

comment:7 Changed 7 years ago by A_Pirard

I had only openjdk 7u71 in my Ubuntu updates, but that dropped the said delay down to 2-3 seconds (first download only) which should be normal and barely noticeable anyway. Not a terrible help I bring but always useful for someone in search of an explanation.

I was surprised by network timeouts (no startup front page etc.), always frightening after an upgrade, but that was only Murphy on duty, real timeouts, short OpenStreetMap blackout.

Thanks. I let you the pleasure to close (not invalid please ;-))

comment:8 Changed 7 years ago by Don-vip

Resolution: worksforme
Status: needinfoclosed

great :)

comment:9 Changed 6 years ago by A_Pirard

Resolution: worksforme
Status: closedreopened

I'm sorry the problem wasn't solved.
I see the following written to the console log after the delay started and just before it ended;

WARNING: Failed to add resource://data/validator/power.mapcss to tag checker
WARNING: java.io.IOException: Failed to open input stream for resource 'resource://data/validator/power.mapcss'

It only happens on the first upload.
That doesn't sound like an error by me.

comment:10 Changed 4 years ago by Don-vip

Resolution: irreproducible
Status: reopenedclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain A_Pirard.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.